summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2005-06-27 12:13:28 +0000
committerSeemant Kulleen <seemant@gentoo.org>2005-06-27 12:13:28 +0000
commitcfec0ea2e6de0f920f9c9a8dde9d79704323b201 (patch)
tree9b03a69009299d5ba6b5314b45140ca75915b969 /app-office/grisbi
parentmarked stable (diff)
downloadgentoo-2-cfec0ea2e6de0f920f9c9a8dde9d79704323b201.tar.gz
gentoo-2-cfec0ea2e6de0f920f9c9a8dde9d79704323b201.tar.bz2
gentoo-2-cfec0ea2e6de0f920f9c9a8dde9d79704323b201.zip
Version bump, coming from: Guillaume Castagnino <guilc@fr.st> in bug #94866
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'app-office/grisbi')
-rw-r--r--app-office/grisbi/ChangeLog7
-rw-r--r--app-office/grisbi/Manifest2
-rw-r--r--app-office/grisbi/files/digest-grisbi-0.5.71
-rw-r--r--app-office/grisbi/grisbi-0.5.7.ebuild75
4 files changed, 84 insertions, 1 deletions
diff --git a/app-office/grisbi/ChangeLog b/app-office/grisbi/ChangeLog
index 8bde406cd947..d795d35d5203 100644
--- a/app-office/grisbi/ChangeLog
+++ b/app-office/grisbi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/grisbi
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/grisbi/ChangeLog,v 1.16 2005/05/16 12:40:37 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/grisbi/ChangeLog,v 1.17 2005/06/27 12:13:28 seemant Exp $
+
+*grisbi-0.5.7 (27 Jun 2005)
+
+ 27 Jun 2005; Seemant Kulleen <seemant@gentoo.org> +grisbi-0.5.7.ebuild:
+ Version bump, coming from: Guillaume Castagnino <guilc@fr.st> in bug #94866
*grisbi-0.5.6 (16 May 2005)
diff --git a/app-office/grisbi/Manifest b/app-office/grisbi/Manifest
index dc8ebc43d66a..25cb23f5199a 100644
--- a/app-office/grisbi/Manifest
+++ b/app-office/grisbi/Manifest
@@ -1,6 +1,8 @@
MD5 5387e76e6294c5f60159aab38850fee9 metadata.xml 443
MD5 5b0ccd33af5109c47006ab47cd37f6b4 grisbi-0.5.6.ebuild 1678
MD5 c15f9b221369358fe42183be53267e78 ChangeLog 3184
+MD5 3432c8033eb910757b949d7cd41ad92d grisbi-0.5.7.ebuild 1585
MD5 34efdef1d5896910c218177e358bb019 files/grisbi.desktop 207
MD5 4b586e8dc048875af95711c52e2f7ab3 files/grisbi-0.5.6-latex-unicode.patch 461
MD5 25fe3a6e8d61a4ff5e7209f41d101e10 files/digest-grisbi-0.5.6 65
+MD5 3a58ad7603fa0514804ef4027dd31201 files/digest-grisbi-0.5.7 65
diff --git a/app-office/grisbi/files/digest-grisbi-0.5.7 b/app-office/grisbi/files/digest-grisbi-0.5.7
new file mode 100644
index 000000000000..d8b01ab18079
--- /dev/null
+++ b/app-office/grisbi/files/digest-grisbi-0.5.7
@@ -0,0 +1 @@
+MD5 571e5b08ee9477c2adec459fb4d99625 grisbi-0.5.7.tar.bz2 912427
diff --git a/app-office/grisbi/grisbi-0.5.7.ebuild b/app-office/grisbi/grisbi-0.5.7.ebuild
new file mode 100644
index 000000000000..724c0a1271b2
--- /dev/null
+++ b/app-office/grisbi/grisbi-0.5.7.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/grisbi/grisbi-0.5.7.ebuild,v 1.1 2005/06/27 12:13:28 seemant Exp $
+
+inherit eutils
+
+IUSE="print nls ofx"
+
+DESCRIPTION="Grisbi is a personal accounting application for Linux"
+HOMEPAGE="http://www.grisbi.org"
+SRC_URI="mirror://sourceforge/grisbi/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64 ~sparc"
+
+DEPEND="dev-libs/libxml2
+ >=x11-libs/gtk+-2.2.0
+ ofx? ( >=dev-libs/libofx-0.7.0 )"
+
+RDEPEND="${DEPEND}
+ print? ( virtual/tetex
+ >=dev-tex/latex-unicode-20041017 )"
+
+pkg_setup() {
+ if ! use print; then
+ echo
+ einfo
+ einfo "NOTE: The USE variable 'print' is not in your USE flags."
+ einfo "For printing support in grisbi, you will need to restart"
+ einfo "the build with USE=\"print\""
+ einfo
+ echo
+ ebeep 5
+ fi
+}
+
+src_unpack() {
+ unpack ${A}; cd ${S}
+
+ # Apply location patchs
+ ebegin "Applying Gentoo documentation location patch"
+ for i in \
+ `find ./ -name 'Makefile.*'` \
+ `find ./ -name 'grisbi-manuel/html'`
+ do
+ sed -i "s;doc/grisbi/help;doc/${PF}/help;g" ${i}
+ done
+ eend 0
+ epatch ${FILESDIR}/${PN}-0.5.6-latex-unicode.patch
+}
+
+src_compile() {
+
+ econf \
+ $(use_with ofx) \
+ $(use_enable nls) || die
+
+ emake || die
+}
+
+src_install() {
+ einstall || die
+ dodoc AUTHORS COPYING ChangeLog NEWS README
+ insinto /usr/share/applications
+ doins ${FILESDIR}/grisbi.desktop
+}
+
+pkg_postinst() {
+ pkg_setup
+
+ einfo "The first thing you should do is set up the browser command in"
+ einfo "preferences after you start up grisbi. Otherwise you will not"
+ einfo "be able to see the help and manuals"
+}