summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Chatzimichos <tampakrap@gentoo.org>2009-11-22 16:20:31 +0000
committerTheo Chatzimichos <tampakrap@gentoo.org>2009-11-22 16:20:31 +0000
commit495723fb0ddbbd3c1de9474f16ce183c053c681b (patch)
tree63bff11a6e3d4b549984bdd3495dc9e28b6d573a /app-office/karbon
parentVersion bump (diff)
downloadgentoo-2-495723fb0ddbbd3c1de9474f16ce183c053c681b.tar.gz
gentoo-2-495723fb0ddbbd3c1de9474f16ce183c053c681b.tar.bz2
gentoo-2-495723fb0ddbbd3c1de9474f16ce183c053c681b.zip
Version bump
(Portage version: 2.2_rc49/cvs/Linux x86_64)
Diffstat (limited to 'app-office/karbon')
-rw-r--r--app-office/karbon/ChangeLog8
-rw-r--r--app-office/karbon/karbon-2.1.0.ebuild36
2 files changed, 43 insertions, 1 deletions
diff --git a/app-office/karbon/ChangeLog b/app-office/karbon/ChangeLog
index 642eb67c37c4..574affa0ab5c 100644
--- a/app-office/karbon/ChangeLog
+++ b/app-office/karbon/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/karbon
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/karbon/ChangeLog,v 1.98 2009/11/01 09:13:12 abcd Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/karbon/ChangeLog,v 1.99 2009/11/22 16:20:31 tampakrap Exp $
+
+*karbon-2.1.0 (22 Nov 2009)
+
+ 22 Nov 2009; Theo Chatzimichos <tampakrap@gentoo.org>
+ +karbon-2.1.0.ebuild:
+ version bump
01 Nov 2009; Jonathan Callen <abcd@gentoo.org> -karbon-1.6.2.ebuild,
-files/karbon-1.6.2+gcc-4.3.patch:
diff --git a/app-office/karbon/karbon-2.1.0.ebuild b/app-office/karbon/karbon-2.1.0.ebuild
new file mode 100644
index 000000000000..2e4d676af4f6
--- /dev/null
+++ b/app-office/karbon/karbon-2.1.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/karbon/karbon-2.1.0.ebuild,v 1.1 2009/11/22 16:20:31 tampakrap Exp $
+
+EAPI="2"
+KMNAME="koffice"
+KMMODULE="${PN}"
+
+inherit kde4-meta
+
+DESCRIPTION="KOffice vector drawing application."
+
+KEYWORDS="~amd64 ~x86"
+IUSE="+pstoedit wpg"
+
+DEPEND="
+ media-libs/libart_lgpl
+ pstoedit? ( media-gfx/pstoedit )
+ wpg? ( media-libs/libwpg )
+"
+RDEPEND="${DEPEND}"
+
+KMEXTRA="filters/${KMMODULE}"
+KMEXTRACTONLY="
+ libs/
+ plugins/
+ filters/
+"
+KMLOADLIBS="koffice-libs"
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with wpg)
+ $(cmake-utils_use_with pstoedit)"
+ kde4-meta_src_configure
+}