summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarsten Lohrke <carlo@gentoo.org>2006-05-20 15:39:28 +0000
committerCarsten Lohrke <carlo@gentoo.org>2006-05-20 15:39:28 +0000
commitaaefe8f90aa6e37818bf337aff94f261ad049184 (patch)
tree0a07aad716f136ccd3e1869571f7bbb8994d9f8d /app-office/kchart/kchart-1.5.1.ebuild
parentVersion bump. (diff)
downloadgentoo-2-aaefe8f90aa6e37818bf337aff94f261ad049184.tar.gz
gentoo-2-aaefe8f90aa6e37818bf337aff94f261ad049184.tar.bz2
gentoo-2-aaefe8f90aa6e37818bf337aff94f261ad049184.zip
Version bump.
(Portage version: 2.0.54-r2)
Diffstat (limited to 'app-office/kchart/kchart-1.5.1.ebuild')
-rw-r--r--app-office/kchart/kchart-1.5.1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/app-office/kchart/kchart-1.5.1.ebuild b/app-office/kchart/kchart-1.5.1.ebuild
new file mode 100644
index 000000000000..ca807323d3c7
--- /dev/null
+++ b/app-office/kchart/kchart-1.5.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/kchart/kchart-1.5.1.ebuild,v 1.1 2006/05/20 15:39:28 carlo Exp $
+
+MAXKOFFICEVER=${PV}
+KMNAME=koffice
+inherit kde-meta eutils
+
+DESCRIPTION="KOffice integrated graph and chart drawing tool."
+HOMEPAGE="http://www.koffice.org/"
+LICENSE="GPL-2 LGPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="$(deprange $PV $MAXKOFFICEVER app-office/koffice-libs)"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+KMCOPYLIB="libkformula lib/kformula
+ libkofficecore lib/kofficecore
+ libkofficeui lib/kofficeui
+ libkopainter lib/kopainter
+ libkotext lib/kotext
+ libkwmf lib/kwmf
+ libkowmf lib/kwmf
+ libkstore lib/store
+ libkochart interfaces"
+
+KMEXTRACTONLY="lib/
+ interfaces/"
+
+KMEXTRA="filters/kchart"
+
+KMCOMPILEONLY="filters/libdialogfilter"
+
+need-kde 3.4
+
+src_unpack() {
+ kde-meta_src_unpack unpack
+
+ # We need to compile liboofilter first
+ echo "SUBDIRS = libdialogfilter kchart" > $S/filters/Makefile.am
+
+ kde-meta_src_unpack makefiles
+}