summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2001-12-19 15:38:55 +0000
committerDan Armak <danarmak@gentoo.org>2001-12-19 15:38:55 +0000
commitc0eadac74d4c82b1fb6ed4e77c6ce769b40af2e1 (patch)
treec4c02b506c6d135708c783a4d796cd65d0a9c26d /app-office/koffice
parentFixed pcmcia-cs dependency (no longer runtime dependent on (diff)
downloadgentoo-2-c0eadac74d4c82b1fb6ed4e77c6ce769b40af2e1.tar.gz
gentoo-2-c0eadac74d4c82b1fb6ed4e77c6ce769b40af2e1.tar.bz2
gentoo-2-c0eadac74d4c82b1fb6ed4e77c6ce769b40af2e1.zip
this only disables fomit-frame-pointer for kchart/kdchart. works here, the compile will soon finish
and then I'll unmask it. Oh, and this reenables objprelink as well.
Diffstat (limited to 'app-office/koffice')
-rw-r--r--app-office/koffice/koffice-1.1.1.ebuild27
1 files changed, 20 insertions, 7 deletions
diff --git a/app-office/koffice/koffice-1.1.1.ebuild b/app-office/koffice/koffice-1.1.1.ebuild
index c6d7c74a6dbc..f4b027934685 100644
--- a/app-office/koffice/koffice-1.1.1.ebuild
+++ b/app-office/koffice/koffice-1.1.1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Authors Dan Armak <danarmak@gentoo.org>, Bart Verwilst <verwilst@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/app-office/koffice/koffice-1.1.1.ebuild,v 1.3 2001/12/19 15:21:18 verwilst Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/koffice/koffice-1.1.1.ebuild,v 1.4 2001/12/19 15:38:55 danarmak Exp $
. /usr/portage/eclass/inherit.eclass || die
inherit kde-base || die
@@ -21,19 +21,32 @@ DEPEND="$DEPEND
>=dev-lang/python-2.0-r5"
# >=sys-devel/automake-1.4
# >=sys-devel/autoconf-1.13"
- # hm. This was in achim's original. are these versions superior to the ones we have by default in a current-day rc6?
src_unpack() {
base_src_unpack all patch
- #kde-objprelink-patch
+ kde-objprelink-patch
}
src_compile() {
- CFLAGS="${CFLAGS/-fomit-frame-pointer}"
- CXXFLAGS="${CXXFLAGS/-fomit-frame-pointer}"
- kde_src_compile myconf configure
- cd ${S}
+ myconf="$myconf --enable-all"
+ kde_src_compile myconf
+
+ #the dir kchar/kdchart cannot be compiled with the -fomit-frame-pointer flag present
+ CXXFLAGS2="$CXXFLAGS"
+ CFLAGS2="$CFLAGS"
+
+ CFLAGS=${CFLAGS/-fomit-frame-pointer}
+ CXXFLAGS=${CXXFLAGS/-fomit-frame-pointer}
+ cd ${S}
+ kde_src_compile configure
+ cd ${S}/kchart/kdchart
+ make
+
+ CFLAGS="$CFLAGS2"
+ CXXFLAGS="$CXXFLAGS2"
+ cd ${S}
+ kde_src_compile configure
make LIBPYTHON="`python-config --libs`"
}