summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-10-19 23:48:47 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-10-19 23:48:47 +0000
commitf833d45cb69e54ba26ab9e99f04e5b13ffe9ff46 (patch)
tree3b960f777eb6ad715cb76be98d38f0c868d9897c /app-office/koffice
parentFixing GCC4 wrt bug #140482 thanks to Ahmed Ammar for the patch (diff)
downloadgentoo-2-f833d45cb69e54ba26ab9e99f04e5b13ffe9ff46.tar.gz
gentoo-2-f833d45cb69e54ba26ab9e99f04e5b13ffe9ff46.tar.bz2
gentoo-2-f833d45cb69e54ba26ab9e99f04e5b13ffe9ff46.zip
Revision bump to fix the tarball used. Thanks to Rene Gass for reporting.
(Portage version: 2.1.2_pre3-r5)
Diffstat (limited to 'app-office/koffice')
-rw-r--r--app-office/koffice/ChangeLog8
-rw-r--r--app-office/koffice/files/digest-koffice-1.6.0-r13
-rw-r--r--app-office/koffice/koffice-1.6.0-r1.ebuild94
3 files changed, 104 insertions, 1 deletions
diff --git a/app-office/koffice/ChangeLog b/app-office/koffice/ChangeLog
index 5363a595b4c8..b13016baf616 100644
--- a/app-office/koffice/ChangeLog
+++ b/app-office/koffice/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/koffice
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/koffice/ChangeLog,v 1.189 2006/10/19 16:32:40 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/koffice/ChangeLog,v 1.190 2006/10/19 23:48:47 flameeyes Exp $
+
+*koffice-1.6.0-r1 (19 Oct 2006)
+
+ 19 Oct 2006; Diego Pettenò <flameeyes@gentoo.org> -koffice-1.6.0.ebuild,
+ +koffice-1.6.0-r1.ebuild:
+ Revision bump to fix the tarball used. Thanks to Rene Gass for reporting.
*koffice-1.6.0 (19 Oct 2006)
diff --git a/app-office/koffice/files/digest-koffice-1.6.0-r1 b/app-office/koffice/files/digest-koffice-1.6.0-r1
new file mode 100644
index 000000000000..2e01d4cedd36
--- /dev/null
+++ b/app-office/koffice/files/digest-koffice-1.6.0-r1
@@ -0,0 +1,3 @@
+MD5 e669cf19b2e1c7db7029c0772c527c0d koffice-1.6.0.tar.bz2 56718478
+RMD160 be09c18005eb33f6dc35ab0359cc97a8a658ce7c koffice-1.6.0.tar.bz2 56718478
+SHA256 9eddaae640ada9bd184f001e2489854daf7094b73e5f15b0b8deffb4cc654ae2 koffice-1.6.0.tar.bz2 56718478
diff --git a/app-office/koffice/koffice-1.6.0-r1.ebuild b/app-office/koffice/koffice-1.6.0-r1.ebuild
new file mode 100644
index 000000000000..a5b0cf99d20e
--- /dev/null
+++ b/app-office/koffice/koffice-1.6.0-r1.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/koffice/koffice-1.6.0-r1.ebuild,v 1.1 2006/10/19 23:48:47 flameeyes Exp $
+
+inherit kde
+
+RV="${PV}"
+MY_P="koffice-${RV}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="KOffice is an integrated office suite for KDE, the K Desktop Environment."
+HOMEPAGE="http://www.koffice.org/"
+#SRC_URI="mirror://kde/stable/koffice-${PV}/src/${P}.tar.bz2"
+SRC_URI="mirror://kde/unstable/koffice-${PV/_/-}/src/${MY_P}.tar.bz2"
+LICENSE="GPL-2 LGPL-2"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+# See bug #130442.
+#IUSE="doc mysql opengl postgres"
+IUSE="doc mysql postgres"
+
+RDEPEND=">=media-libs/freetype-2
+ media-libs/fontconfig
+ media-libs/libart_lgpl
+ dev-libs/libxml2
+ dev-libs/libxslt
+ sys-libs/readline
+ mysql? ( dev-db/mysql )
+ postgres? ( dev-libs/libpqxx )
+ virtual/python
+ dev-lang/ruby
+ >=app-text/wv2-0.1.9
+ >=app-text/libwpd-0.8.2
+ >=media-gfx/imagemagick-6.2.5.5
+ >=media-libs/lcms-1.14-r1
+ media-libs/tiff
+ media-libs/jpeg
+ >=media-libs/openexr-1.2.2-r2
+ media-libs/libpng
+ >=media-libs/libexif-0.6.13-r1
+ virtual/opengl
+ virtual/glu"
+# opengl? ( virtual/opengl virtual/glu )"
+
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+# add blockers on split packages derived from this one
+for x in $(get-child-packages ${CATEGORY}/${PN}); do
+ DEPEND="${DEPEND} !${x}"
+ RDEPEND="${RDEPEND} !${x}"
+done
+
+need-kde 3.4
+
+# TODO: kword sql plugin needs Qt compiled with sql support
+# the dependency on python is needed for scripting support in kexi
+# and for kivio/kiviopart/kiviosdk.
+
+pkg_setup() {
+ # use opengl &&
+ if ! built_with_use =x11-libs/qt-3* opengl ; then
+ eerror "You need to build x11-libs/qt with opengl use flag enabled."
+ die
+ fi
+}
+
+src_unpack() {
+ kde_src_unpack
+ # FIXME - disable broken tests for now
+ sed -i -e "s:TESTSDIR =.*:TESTSDIR=:" ${S}/krita/core/Makefile.am \
+ `ls ${S}/krita/colorspaces/*/Makefile.am`
+}
+
+src_compile() {
+ local myconf="$(use_enable mysql) $(use_enable postgres pgsql)"
+ # $(use_enable opengl gl)"
+
+ kde_src_compile
+ if use doc; then
+ make apidox || die
+ fi
+}
+
+src_install() {
+ kde_src_install
+ if use doc; then
+ make DESTDIR="${D}" install-apidox || die
+ fi
+
+ dodoc changes-*
+}