summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2007-09-07 14:58:37 +0000
committerHanno Böck <hanno@gentoo.org>2007-09-07 14:58:37 +0000
commitbb8ae29d3398f67fe179602da6dc4ae955f8d197 (patch)
tree9fcfa10eacae6ec3a9606d19bbf89fd08ac458e4 /app-office/taxbird/taxbird-0.10.ebuild
parentppc stable, bug #189255 (diff)
downloadgentoo-2-bb8ae29d3398f67fe179602da6dc4ae955f8d197.tar.gz
gentoo-2-bb8ae29d3398f67fe179602da6dc4ae955f8d197.tar.bz2
gentoo-2-bb8ae29d3398f67fe179602da6dc4ae955f8d197.zip
taxbird add use-flag check for guile
(Portage version: 2.1.3.7)
Diffstat (limited to 'app-office/taxbird/taxbird-0.10.ebuild')
-rw-r--r--app-office/taxbird/taxbird-0.10.ebuild22
1 files changed, 12 insertions, 10 deletions
diff --git a/app-office/taxbird/taxbird-0.10.ebuild b/app-office/taxbird/taxbird-0.10.ebuild
index 84e610ae7e2f..e07c133c90b1 100644
--- a/app-office/taxbird/taxbird-0.10.ebuild
+++ b/app-office/taxbird/taxbird-0.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/taxbird/taxbird-0.10.ebuild,v 1.1 2007/08/14 15:53:14 wrobel Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/taxbird/taxbird-0.10.ebuild,v 1.2 2007/09/07 14:58:37 hanno Exp $
inherit eutils fdo-mime flag-o-matic
@@ -14,23 +14,25 @@ KEYWORDS="~amd64 ~x86"
SLOT="0"
IUSE=""
-DEPEND="
-dev-libs/libgeier
-dev-libs/openssl
-=gnome-extra/gtkhtml-2*
-gnome-base/libgnomeui
-sys-devel/gettext
-dev-scheme/guile"
+DEPEND="dev-libs/libgeier
+ dev-libs/openssl
+ =gnome-extra/gtkhtml-2*
+ gnome-base/libgnomeui
+ sys-devel/gettext
+ dev-scheme/guile"
pkg_setup() {
+ if ! built_with_use 'dev-scheme/guile' 'discouraged deprecated'; then
+ eerror "This package requires dev-scheme/guile with USE=\"discouraged deprecated\"."
+ die "Please reemerge dev-scheme/guile with USE=\"discouraged deprecated\"."
+ fi
+
filter-ldflags -Wl,--as-needed --as-needed
}
src_compile() {
-
econf || die "Configure failed!"
emake || die "Make failed!"
-
}
src_install() {