summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Proschofsky <suka@gentoo.org>2005-01-16 23:18:51 +0000
committerAndreas Proschofsky <suka@gentoo.org>2005-01-16 23:18:51 +0000
commit07ae920fc3699a7b110b3817038bb9b997137b4a (patch)
tree2ccd9b8a7897b448207fd992558f40a8ed2db675 /app-office
parentdep correction & cleanup (Manifest recommit) (diff)
downloadgentoo-2-07ae920fc3699a7b110b3817038bb9b997137b4a.tar.gz
gentoo-2-07ae920fc3699a7b110b3817038bb9b997137b4a.tar.bz2
gentoo-2-07ae920fc3699a7b110b3817038bb9b997137b4a.zip
Fixes for hardened-gccs, trying to solve bug #52642
(Portage version: 2.0.51-r13)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/openoffice/ChangeLog7
-rw-r--r--app-office/openoffice/files/1.1.4/hardened-link.patch14
-rw-r--r--app-office/openoffice/files/1.1.4/pthreadlink-fix.patch32
-rw-r--r--app-office/openoffice/openoffice-1.1.4.ebuild12
4 files changed, 62 insertions, 3 deletions
diff --git a/app-office/openoffice/ChangeLog b/app-office/openoffice/ChangeLog
index 90d71ad83145..806196e9aa30 100644
--- a/app-office/openoffice/ChangeLog
+++ b/app-office/openoffice/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/openoffice
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice/ChangeLog,v 1.100 2005/01/16 20:07:53 suka Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice/ChangeLog,v 1.101 2005/01/16 23:18:51 suka Exp $
+
+ 17 Jan 2005; Andreas Proschofsky <suka@gentoo.org>
+ +files/1.1.4/hardened-link.patch, +files/1.1.4/pthreadlink-fix.patch:
+ Try to fix build problems with hardened-gccs, patches provided by
+ Kevin F. Quinn <co@kevquinn.com> in bug #52642
16 Jan 2005; Andreas Proschofsky <suka@gentoo.org>
openoffice-1.1.4.ebuild:
diff --git a/app-office/openoffice/files/1.1.4/hardened-link.patch b/app-office/openoffice/files/1.1.4/hardened-link.patch
new file mode 100644
index 000000000000..83c707dc106d
--- /dev/null
+++ b/app-office/openoffice/files/1.1.4/hardened-link.patch
@@ -0,0 +1,14 @@
+diff -ur solenv.orig/inc/unxlngi4.mk solenv/inc/unxlngi4.mk
+--- solenv.orig/inc/unxlngi4.mk 2004-10-23 20:09:29.344518376 +0200
++++ solenv/inc/unxlngi4.mk 2004-10-23 20:09:43.084429592 +0200
+@@ -156,8 +156,8 @@
+ LINKFLAGS=-Wl,-z,combreloc $(LINKFLAGSDEFS) $(LINKFLAGSRUNPATH)
+
+ # linker flags for linking applications
+-LINKFLAGSAPPGUI= -Wl,-export-dynamic
+-LINKFLAGSAPPCUI= -Wl,-export-dynamic
++LINKFLAGSAPPGUI= -Wl,-export-dynamic -Wl,-z,execheap
++LINKFLAGSAPPCUI= -Wl,-export-dynamic -Wl,-z,execheap
+
+ # linker flags for linking shared libraries
+ LINKFLAGSSHLGUI= -shared
diff --git a/app-office/openoffice/files/1.1.4/pthreadlink-fix.patch b/app-office/openoffice/files/1.1.4/pthreadlink-fix.patch
new file mode 100644
index 000000000000..ffd0a647faa8
--- /dev/null
+++ b/app-office/openoffice/files/1.1.4/pthreadlink-fix.patch
@@ -0,0 +1,32 @@
+diff -ur solenv.orig/inc/unxlngi4.mk solenv/inc/unxlngi4.mk
+--- solenv.orig/inc/unxlngi4.mk 2004-10-23 20:07:59.714144264 +0200
++++ solenv/inc/unxlngi4.mk 2004-10-23 20:08:36.190599000 +0200
+@@ -151,13 +151,13 @@
+ LINK*=$(CC)
+
+ # default linker flags
+-LINKFLAGSDEFS*=-z defs
++LINKFLAGSDEFS*=-Wl,-z,defs
+ LINKFLAGSRUNPATH*=-Wl,-rpath,\''$$ORIGIN'\'
+-LINKFLAGS=-z combreloc $(LINKFLAGSDEFS) $(LINKFLAGSRUNPATH)
++LINKFLAGS=-Wl,-z,combreloc $(LINKFLAGSDEFS) $(LINKFLAGSRUNPATH)
+
+ # linker flags for linking applications
+-LINKFLAGSAPPGUI= -Wl,-export-dynamic -Wl,--noinhibit-exec
+-LINKFLAGSAPPCUI= -Wl,-export-dynamic -Wl,--noinhibit-exec
++LINKFLAGSAPPGUI= -Wl,-export-dynamic
++LINKFLAGSAPPCUI= -Wl,-export-dynamic
+
+ # linker flags for linking shared libraries
+ LINKFLAGSSHLGUI= -shared
+@@ -198,8 +198,8 @@
+
+ LIBSALCPPRT*=-Wl,--whole-archive -lsalcpprt -Wl,--no-whole-archive
+
+-LIBSTLPORT=$(DYNAMIC) -lstlport_gcc -lstdc++
+-LIBSTLPORTST=$(STATIC) -lstlport_gcc $(DYNAMIC)
++LIBSTLPORT=$(DYNAMIC) -lstlport_gcc -lpthread -lstdc++
++LIBSTLPORTST=$(STATIC) -lstlport_gcc -lpthread $(DYNAMIC)
+
+ #FILLUPARC=$(STATIC) -lsupc++ $(DYNAMIC)
+
diff --git a/app-office/openoffice/openoffice-1.1.4.ebuild b/app-office/openoffice/openoffice-1.1.4.ebuild
index 875897aa8f80..092bfead6338 100644
--- a/app-office/openoffice/openoffice-1.1.4.ebuild
+++ b/app-office/openoffice/openoffice-1.1.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice/openoffice-1.1.4.ebuild,v 1.7 2005/01/16 20:07:53 suka Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice/openoffice-1.1.4.ebuild,v 1.8 2005/01/16 23:18:51 suka Exp $
# Notes:
#
@@ -26,7 +26,7 @@
inherit flag-o-matic eutils toolchain-funcs
-IUSE="gnome kde java curl nptl zlib"
+IUSE="curl gnome hardened java kde nptl zlib"
LOC="/opt"
INSTDIR="${LOC}/OpenOffice.org"
@@ -242,6 +242,14 @@ src_unpack() {
#Another java problem
epatch ${FILESDIR}/${PV}/javafix.patch
+ #phtread-fix
+ epatch ${FILESDIR}/${PV}/pthreadlink-fix.patch
+
+ #Fix for hardened
+ if use hardened; then
+ epatch ${FILESDIR}/${PV}/hardened-link.patch
+ fi
+
# GCC 3.4.x fixes
if [ "$(gcc-version)" = "3.4" ]
then