summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2013-07-20 22:13:43 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2013-07-20 22:13:43 +0000
commit2ac134d1fddaaeb0a773c225e064f7aa40a8b596 (patch)
tree07ccaa2acb18e2b0f551102a069aa66a6de9ef91 /app-office
parentVersion bump (diff)
downloadgentoo-2-2ac134d1fddaaeb0a773c225e064f7aa40a8b596.tar.gz
gentoo-2-2ac134d1fddaaeb0a773c225e064f7aa40a8b596.tar.bz2
gentoo-2-2ac134d1fddaaeb0a773c225e064f7aa40a8b596.zip
Version bump
(Portage version: 2.2.0_alpha188/cvs/Linux x86_64, signed Manifest commit with key EBE6A336BE19039C!)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/libreoffice-bin-debug/ChangeLog8
-rw-r--r--app-office/libreoffice-bin-debug/libreoffice-bin-debug-4.0.4.2.ebuild64
2 files changed, 71 insertions, 1 deletions
diff --git a/app-office/libreoffice-bin-debug/ChangeLog b/app-office/libreoffice-bin-debug/ChangeLog
index 5393418fdfbd..f5e5c5d237f2 100644
--- a/app-office/libreoffice-bin-debug/ChangeLog
+++ b/app-office/libreoffice-bin-debug/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/libreoffice-bin-debug
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice-bin-debug/ChangeLog,v 1.30 2013/05/31 02:13:30 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice-bin-debug/ChangeLog,v 1.31 2013/07/20 22:13:43 dilfridge Exp $
+
+*libreoffice-bin-debug-4.0.4.2 (20 Jul 2013)
+
+ 20 Jul 2013; Andreas K. Huettel <dilfridge@gentoo.org>
+ +libreoffice-bin-debug-4.0.4.2.ebuild:
+ Version bump
31 May 2013; Patrick Lauer <patrick@gentoo.org>
-libreoffice-bin-debug-3.6.4.3.ebuild:
diff --git a/app-office/libreoffice-bin-debug/libreoffice-bin-debug-4.0.4.2.ebuild b/app-office/libreoffice-bin-debug/libreoffice-bin-debug-4.0.4.2.ebuild
new file mode 100644
index 000000000000..bf0d36101cd1
--- /dev/null
+++ b/app-office/libreoffice-bin-debug/libreoffice-bin-debug-4.0.4.2.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice-bin-debug/libreoffice-bin-debug-4.0.4.2.ebuild,v 1.1 2013/07/20 22:13:43 dilfridge Exp $
+
+EAPI=5
+
+BASE_AMD64_URI="mirror://gentoo/amd64-debug-"
+BASE_X86_URI="mirror://gentoo/x86-debug-"
+
+DESCRIPTION="LibreOffice, a full office productivity suite. Binary package, debug info."
+HOMEPAGE="http://www.libreoffice.org"
+SRC_URI_AMD64="
+ kde? (
+ !java? ( ${BASE_AMD64_URI}${PN/-bin-debug}-kde-${PVR}.tar.xz )
+ java? ( ${BASE_AMD64_URI}${PN/-bin-debug}-kde-java-${PVR}.tar.xz )
+ )
+ gnome? (
+ !java? ( ${BASE_AMD64_URI}${PN/-bin-debug}-gnome-${PVR}.tar.xz )
+ java? ( ${BASE_AMD64_URI}${PN/-bin-debug}-gnome-java-${PVR}.tar.xz )
+ )
+ !kde? ( !gnome? (
+ !java? ( ${BASE_AMD64_URI}${PN/-bin-debug}-base-${PVR}.tar.xz )
+ java? ( ${BASE_AMD64_URI}${PN/-bin-debug}-base-java-${PVR}.tar.xz )
+ ) )
+"
+SRC_URI_X86="
+ kde? (
+ !java? ( ${BASE_X86_URI}${PN/-bin-debug}-kde-${PVR}.tar.xz )
+ java? ( ${BASE_X86_URI}${PN/-bin-debug}-kde-java-${PVR}.tar.xz )
+ )
+ gnome? (
+ !java? ( ${BASE_X86_URI}${PN/-bin-debug}-gnome-${PVR}.tar.xz )
+ java? ( ${BASE_X86_URI}${PN/-bin-debug}-gnome-java-${PVR}.tar.xz )
+ )
+ !kde? ( !gnome? (
+ !java? ( ${BASE_X86_URI}${PN/-bin-debug}-base-${PVR}.tar.xz )
+ java? ( ${BASE_X86_URI}${PN/-bin-debug}-base-java-${PVR}.tar.xz )
+ ) )
+"
+
+SRC_URI="
+ amd64? ( ${SRC_URI_AMD64} )
+ x86? ( ${SRC_URI_X86} )
+"
+
+IUSE="gnome java kde"
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+
+RDEPEND="=app-office/${PN/-debug}-${PVR}[gnome=,java=,kde=]"
+
+RESTRICT="test strip"
+
+S="${WORKDIR}"
+
+src_configure() { :; }
+
+src_compile() { :; }
+
+src_install() {
+ dodir /usr
+ cp -aR "${S}"/usr/* "${ED}"/usr/ || die
+}