summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2013-06-08 15:00:01 +0000
committerMike Gilbert <floppym@gentoo.org>2013-06-08 15:00:01 +0000
commit51495aa3d27e725b97594fc47741fada47ee42a7 (patch)
treebabd61e38ad8ce09508e039d780d1bcd7d899168 /app-office
parentVersion bump and conversion to EAPI5 (diff)
downloadgentoo-2-51495aa3d27e725b97594fc47741fada47ee42a7.tar.gz
gentoo-2-51495aa3d27e725b97594fc47741fada47ee42a7.tar.bz2
gentoo-2-51495aa3d27e725b97594fc47741fada47ee42a7.zip
Convert to python-single-r1. Replace dev-python/imaging with virtual/python-imaging.
(Portage version: 2.2.0_alpha177/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/impressive/ChangeLog12
-rw-r--r--app-office/impressive/files/impressive-pillow.patch15
-rw-r--r--app-office/impressive/impressive-0.10.3-r2.ebuild49
3 files changed, 73 insertions, 3 deletions
diff --git a/app-office/impressive/ChangeLog b/app-office/impressive/ChangeLog
index ab2c5c96c971..05661996661b 100644
--- a/app-office/impressive/ChangeLog
+++ b/app-office/impressive/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-office/impressive
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/impressive/ChangeLog,v 1.5 2012/09/11 10:44:55 dilfridge Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/impressive/ChangeLog,v 1.6 2013/06/08 15:00:01 floppym Exp $
+
+*impressive-0.10.3-r2 (08 Jun 2013)
+
+ 08 Jun 2013; Mike Gilbert <floppym@gentoo.org> +files/impressive-pillow.patch,
+ +impressive-0.10.3-r2.ebuild:
+ Convert to python-single-r1. Replace dev-python/imaging with virtual/python-
+ imaging.
11 Sep 2012; Andreas K. Huettel <dilfridge@gentoo.org> metadata.xml:
Drop maintainership
@@ -24,4 +31,3 @@
+impressive-0.10.3.ebuild, +metadata.xml:
New application. Thanks to Maarten Wegewijs for the tip and to marienz and
rafaelmartins for reviewing.
-
diff --git a/app-office/impressive/files/impressive-pillow.patch b/app-office/impressive/files/impressive-pillow.patch
new file mode 100644
index 000000000000..1b7a1be76f74
--- /dev/null
+++ b/app-office/impressive/files/impressive-pillow.patch
@@ -0,0 +1,15 @@
+# See revision 53 in upstream svn
+# https://bugs.gentoo.org/show_bug.cgi?id=471496
+--- a/impressive.py
++++ b/impressive.py
+@@ -182,8 +182,8 @@
+ from OpenGL.GL import *
+ import pygame
+ from pygame.locals import *
+- import Image, ImageDraw, ImageFont, ImageFilter
+- import TiffImagePlugin, BmpImagePlugin, JpegImagePlugin, PngImagePlugin, PpmImagePlugin
++ from PIL import Image, ImageDraw, ImageFont, ImageFilter
++ from PIL import TiffImagePlugin, BmpImagePlugin, JpegImagePlugin, PngImagePlugin, PpmImagePlugin
+ except (ValueError, ImportError), err:
+ print >>sys.stderr, "Oops! Cannot load necessary modules:", err
+ print >>sys.stderr, """To use Impressive, you need to install the following Python modules:
diff --git a/app-office/impressive/impressive-0.10.3-r2.ebuild b/app-office/impressive/impressive-0.10.3-r2.ebuild
new file mode 100644
index 000000000000..97605ae10bf7
--- /dev/null
+++ b/app-office/impressive/impressive-0.10.3-r2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/impressive/impressive-0.10.3-r2.ebuild,v 1.1 2013/06/08 15:00:01 floppym Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit eutils python-single-r1
+
+MY_PN="Impressive"
+
+DESCRIPTION="Stylish way of giving presentations with Python"
+HOMEPAGE="http://impressive.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_PN}/${PV}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="app-text/pdftk
+ virtual/python-imaging[${PYTHON_USEDEP}]
+ dev-python/pygame[${PYTHON_USEDEP}]
+ dev-python/pyopengl[${PYTHON_USEDEP}]
+ x11-misc/xdg-utils
+ x11-apps/xrandr
+ || ( app-text/xpdf app-text/ghostscript-gpl )
+ || ( media-fonts/dejavu media-fonts/ttf-bitstream-vera media-fonts/corefonts )"
+
+S=${WORKDIR}/${MY_PN}-${PV}
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-pillow.patch"
+}
+
+src_install() {
+ python_fix_shebang impressive.py
+ dobin impressive.py
+
+ # compatibility symlinks
+ dosym impressive.py /usr/bin/impressive || die
+ dosym impressive.py /usr/bin/keyjnote || die
+
+ # docs
+ doman impressive.1 || die
+ dohtml impressive.html || die
+ dodoc changelog.txt demo.pdf || die
+}