summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Proschofsky <suka@gentoo.org>2006-11-03 19:12:48 +0000
committerAndreas Proschofsky <suka@gentoo.org>2006-11-03 19:12:48 +0000
commit578eeb2915478abb24e0381b711abdbcedb8cabb (patch)
tree45c54a8b2c163ed47655be9047df3d62490ac9ec /app-office
parentbump dev version (diff)
downloadgentoo-2-578eeb2915478abb24e0381b711abdbcedb8cabb.tar.gz
gentoo-2-578eeb2915478abb24e0381b711abdbcedb8cabb.tar.bz2
gentoo-2-578eeb2915478abb24e0381b711abdbcedb8cabb.zip
Add a patch from upstream to combat the common regcomp / pyuno segfaults during install
(Portage version: 2.1.2_rc1-r3)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/openoffice/ChangeLog8
-rw-r--r--app-office/openoffice/files/2.0.4/gentoo-2.0.4.diff13
-rw-r--r--app-office/openoffice/files/2.0.4/pyuno-objects-allocation.diff70
-rw-r--r--app-office/openoffice/openoffice-2.0.4.ebuild5
4 files changed, 93 insertions, 3 deletions
diff --git a/app-office/openoffice/ChangeLog b/app-office/openoffice/ChangeLog
index bc38f9018648..2bb2fff44b0c 100644
--- a/app-office/openoffice/ChangeLog
+++ b/app-office/openoffice/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/openoffice
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice/ChangeLog,v 1.267 2006/10/27 12:06:33 suka Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice/ChangeLog,v 1.268 2006/11/03 19:12:48 suka Exp $
+
+ 03 Nov 2006; Andreas Proschofsky <suka@gentoo.org>
+ +files/2.0.4/pyuno-objects-allocation.diff, files/2.0.4/gentoo-2.0.4.diff,
+ openoffice-2.0.4.ebuild:
+ Add a patch from upstream to combat the common regcomp / pyuno segfaults
+ during install.
27 Oct 2006; Andreas Proschofsky <suka@gentoo.org>
+files/2.0.4/libgcc3_uno_noexecstack.diff, files/2.0.4/gentoo-2.0.4.diff,
diff --git a/app-office/openoffice/files/2.0.4/gentoo-2.0.4.diff b/app-office/openoffice/files/2.0.4/gentoo-2.0.4.diff
index 3e0756b46d0e..0e6f1c65499b 100644
--- a/app-office/openoffice/files/2.0.4/gentoo-2.0.4.diff
+++ b/app-office/openoffice/files/2.0.4/gentoo-2.0.4.diff
@@ -22,6 +22,19 @@
--- patches/src680/apply
+++ patches/src680/apply
+@@ -243,6 +243,12 @@
+ wizards-crasher-fix.diff, i#68079, michael
+ # update pyuno docs from www.oo.o
+ pyuno-update-docs.diff, i#63846, michael
++# replace PyMem_DEL() with PyObject_Del() on object dealloc functions to free
++# objects the right way (regcomp segfaulted on openSUSE-10.2)
++# replace PyObject_NEW with PyObject_New because the macro version most
++# probably does not preserve binary compatibility across Python versions
++# and is therefore deprecated in extension modules.
++pyuno-objects-allocation.diff, i#71078, pmladek
+ # disable font management dialog in padmin
+ padmin-nofontconfig.diff, michael
+ # Improve the web bullet export / export to png not gif.
@@ -1069,6 +1069,8 @@
64bit-jdk-server-paths.diff, i#65974, hmth
# use IBM j9vm over IBM classic JVM
diff --git a/app-office/openoffice/files/2.0.4/pyuno-objects-allocation.diff b/app-office/openoffice/files/2.0.4/pyuno-objects-allocation.diff
new file mode 100644
index 000000000000..aa3902c1dc0e
--- /dev/null
+++ b/app-office/openoffice/files/2.0.4/pyuno-objects-allocation.diff
@@ -0,0 +1,70 @@
+diff -urN pyuno.orig/source/module/pyuno_callable.cxx pyuno/source/module/pyuno_callable.cxx
+--- pyuno.orig/source/module/pyuno_callable.cxx 2006-06-20 07:03:27.000000000 +0200
++++ pyuno/source/module/pyuno_callable.cxx 2006-11-01 15:51:33.000000000 +0100
+@@ -74,7 +74,7 @@
+
+ me = (PyUNO_callable*) self;
+ delete me->members;
+- PyMem_DEL (self);
++ PyObject_Del (self);
+
+ return;
+ }
+@@ -261,7 +261,7 @@
+ {
+ PyUNO_callable* self;
+
+- self = PyObject_NEW (PyUNO_callable, &PyUNO_callable_Type);
++ self = PyObject_New (PyUNO_callable, &PyUNO_callable_Type);
+ if (self == NULL)
+ return NULL; //NULL == Error!
+
+diff -urN pyuno.orig/source/module/pyuno.cxx pyuno/source/module/pyuno.cxx
+--- pyuno.orig/source/module/pyuno.cxx 2006-06-20 07:03:05.000000000 +0200
++++ pyuno/source/module/pyuno.cxx 2006-11-01 15:51:42.000000000 +0100
+@@ -78,7 +78,7 @@
+ {
+ PyUNO* me = reinterpret_cast< PyUNO* > (self);
+ delete me->members;
+- PyMem_DEL (self);
++ PyObject_Del (self);
+ }
+
+
+@@ -727,7 +727,7 @@
+ Sequence<Any> arguments (1);
+ Reference<XInterface> tmp_interface;
+
+- self = PyObject_NEW (PyUNO, &PyUNOType);
++ self = PyObject_New (PyUNO, &PyUNOType);
+ if (self == NULL)
+ return NULL; //NULL == error
+ self->members = new PyUNOInternals();
+diff -urN pyuno.orig/source/module/pyuno_runtime.cxx pyuno/source/module/pyuno_runtime.cxx
+--- pyuno.orig/source/module/pyuno_runtime.cxx 2006-08-28 17:46:54.000000000 +0200
++++ pyuno/source/module/pyuno_runtime.cxx 2006-11-01 15:50:53.000000000 +0100
+@@ -242,13 +242,13 @@
+ PyRef stRuntimeImpl::create( const Reference< XComponentContext > &ctx )
+ throw( com::sun::star::uno::RuntimeException )
+ {
+- RuntimeImpl *me = PyObject_NEW (RuntimeImpl, &RuntimeImpl_Type);
++ RuntimeImpl *me = PyObject_New (RuntimeImpl, &RuntimeImpl_Type);
+ if( ! me )
+ throw RuntimeException(
+ OUString( RTL_CONSTASCII_USTRINGPARAM( "cannot instantiate pyuno::RuntimeImpl" ) ),
+ Reference< XInterface > () );
+ me->cargo = 0;
+- // must use a different struct here, as the PyObject_NEW macro
++ // must use a different struct here, as the PyObject_New
+ // makes C++ unusable
+ RuntimeCargo *c = new RuntimeCargo();
+ readLoggingConfig( &(c->logLevel) , &(c->logFile) );
+@@ -324,7 +324,7 @@
+ if( me->cargo->logFile )
+ fclose( me->cargo->logFile );
+ delete me->cargo;
+- PyMem_DEL (self);
++ PyObject_Del (self);
+ }
+
+
diff --git a/app-office/openoffice/openoffice-2.0.4.ebuild b/app-office/openoffice/openoffice-2.0.4.ebuild
index 9bbb74d76131..536f3bb872db 100644
--- a/app-office/openoffice/openoffice-2.0.4.ebuild
+++ b/app-office/openoffice/openoffice-2.0.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice/openoffice-2.0.4.ebuild,v 1.9 2006/10/27 12:06:33 suka Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice/openoffice-2.0.4.ebuild,v 1.10 2006/11/03 19:12:48 suka Exp $
inherit check-reqs debug eutils fdo-mime flag-o-matic java-pkg-opt-2 kde-functions multilib toolchain-funcs
@@ -72,7 +72,6 @@ COMMON_DEPEND="!app-office/openoffice-bin
app-arch/unzip
>=app-text/hunspell-1.1.4-r1
dev-libs/expat
- >=dev-libs/boost-1.33.1
>=dev-libs/icu-3.4
linguas_ja? ( >=media-fonts/kochi-substitute-20030809-r3 )
linguas_zh_CN? ( >=media-fonts/arphicfonts-0.1-r2 )
@@ -93,6 +92,7 @@ DEPEND="${COMMON_DEPEND}
dev-perl/Compress-Zlib
dev-util/pkgconfig
dev-util/intltool
+ >=dev-libs/boost-1.33.1
>=net-misc/curl-7.9.8
sys-libs/zlib
sys-apps/coreutils
@@ -176,6 +176,7 @@ src_unpack() {
#Some fixes for our patchset
cd ${S}
cp -a ${FILESDIR}/${PV}/libgcc3_uno_noexecstack.diff ${S}/patches/src680 || die
+ cp -a ${FILESDIR}/${PV}/pyuno-objects-allocation.diff ${S}/patches/src680 || die
epatch ${FILESDIR}/${PV}/gentoo-${PV}.diff
#Use flag checks