summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRémi Cardona <remi@gentoo.org>2010-05-25 20:22:43 +0000
committerRémi Cardona <remi@gentoo.org>2010-05-25 20:22:43 +0000
commitaf5bfea1bcb08fab65dde8ebb6bd1097c2746c80 (patch)
tree1bb290fe3def56497b89b6ce6b00f240e28f8360 /app-office
parentBug #318937: Fix support for low-speed USB devices. (diff)
downloadgentoo-2-af5bfea1bcb08fab65dde8ebb6bd1097c2746c80.tar.gz
gentoo-2-af5bfea1bcb08fab65dde8ebb6bd1097c2746c80.tar.bz2
gentoo-2-af5bfea1bcb08fab65dde8ebb6bd1097c2746c80.zip
app-office/grisbi: bump to 0.6.0, rewrite ebuild to use the gnome2 eclass
(Portage version: 2.2_rc67/cvs/Linux i686)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/grisbi/ChangeLog7
-rw-r--r--app-office/grisbi/grisbi-0.6.0.ebuild58
2 files changed, 64 insertions, 1 deletions
diff --git a/app-office/grisbi/ChangeLog b/app-office/grisbi/ChangeLog
index 2cc0fbfcd087..95609e19d343 100644
--- a/app-office/grisbi/ChangeLog
+++ b/app-office/grisbi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/grisbi
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/grisbi/ChangeLog,v 1.39 2010/03/20 12:55:16 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/grisbi/ChangeLog,v 1.40 2010/05/25 20:22:43 remi Exp $
+
+*grisbi-0.6.0 (25 May 2010)
+
+ 25 May 2010; Rémi Cardona <remi@gentoo.org> +grisbi-0.6.0.ebuild:
+ bump to 0.6.0, rewrite ebuild to use the gnome2 eclass
20 Mar 2010; Raúl Porcel <armin76@gentoo.org> grisbi-0.6.0_rc2.ebuild:
sparc stable wrt #306033
diff --git a/app-office/grisbi/grisbi-0.6.0.ebuild b/app-office/grisbi/grisbi-0.6.0.ebuild
new file mode 100644
index 000000000000..690a00ff4ba3
--- /dev/null
+++ b/app-office/grisbi/grisbi-0.6.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/grisbi/grisbi-0.6.0.ebuild,v 1.1 2010/05/25 20:22:43 remi Exp $
+
+EAPI="2"
+
+inherit eutils gnome2
+
+IUSE="nls ofx ssl"
+
+DESCRIPTION="Grisbi is a personal accounting application for Linux"
+HOMEPAGE="http://www.grisbi.org"
+SRC_URI="mirror://sourceforge/grisbi/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+# minimum gtk 2.10 to have print support
+RDEPEND="dev-libs/libxml2
+ >=x11-libs/gtk+-2.10.0
+ ssl? ( dev-libs/openssl )
+ ofx? ( >=dev-libs/libofx-0.7.0 )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.20"
+
+pkg_setup() {
+ G2CONF="
+ --with-plugins \
+ $(use_with ofx) \
+ $(use_enable nls)"
+ DOCS="AUTHORS NEWS README"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Apply location patchs
+ ebegin "Applying Gentoo documentation location patch"
+ for i in \
+ $(find ./ -name 'Makefile.am') \
+ $(find ./ -name 'grisbi-manuel.html')
+ do
+ sed -i "s;doc/grisbi/;doc/${PF}/;g" "${i}"
+ done
+ eend 0
+
+ # Fix Icon value in desktop file
+ sed -i "s/grisbi.png/grisbi/" share/grisbi.desktop || die
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ elog "The first thing you should do is set up the browser command in"
+ elog "preferences after you start up grisbi. Otherwise you will not"
+ elog "be able to see the help and manuals."
+}