summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarsten Lohrke <carlo@gentoo.org>2006-03-29 15:16:28 +0000
committerCarsten Lohrke <carlo@gentoo.org>2006-03-29 15:16:28 +0000
commitc2dfb21054d6eff7fe910b0bde788a454e7bf90e (patch)
tree981b2108799fb88ddff1a028a084dca3676e353c /app-office
parentVersion bump. (diff)
downloadgentoo-2-c2dfb21054d6eff7fe910b0bde788a454e7bf90e.tar.gz
gentoo-2-c2dfb21054d6eff7fe910b0bde788a454e7bf90e.tar.bz2
gentoo-2-c2dfb21054d6eff7fe910b0bde788a454e7bf90e.zip
Version bump.
(Portage version: 2.0.54)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/kchart/ChangeLog7
-rw-r--r--app-office/kchart/Manifest4
-rw-r--r--app-office/kchart/files/digest-kchart-1.5_rc11
-rw-r--r--app-office/kchart/kchart-1.5_rc1.ebuild48
4 files changed, 58 insertions, 2 deletions
diff --git a/app-office/kchart/ChangeLog b/app-office/kchart/ChangeLog
index 63703850c9e4..4ab103442249 100644
--- a/app-office/kchart/ChangeLog
+++ b/app-office/kchart/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/kchart
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/kchart/ChangeLog,v 1.31 2006/03/11 15:55:56 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/kchart/ChangeLog,v 1.32 2006/03/29 15:16:28 carlo Exp $
+
+*kchart-1.5_rc1 (29 Mar 2006)
+
+ 29 Mar 2006; Carsten Lohrke <carlo@gentoo.org> +kchart-1.5_rc1.ebuild:
+ Version bump.
*kchart-1.5_beta2 (11 Mar 2006)
diff --git a/app-office/kchart/Manifest b/app-office/kchart/Manifest
index cf8aa54fd9ab..3c9c23becf0b 100644
--- a/app-office/kchart/Manifest
+++ b/app-office/kchart/Manifest
@@ -1,8 +1,10 @@
-MD5 e84b41f7dfaa26e17b47abe739353a47 ChangeLog 3529
+MD5 9e81be8ccf03da8da703776c57dcbea1 ChangeLog 3650
MD5 902823ac54984271d00a3e72454440b1 files/digest-kchart-1.4.2 250
MD5 82af01b67d83c02945f1e26ae9529232 files/digest-kchart-1.5_beta1 253
MD5 a08e04910037e4b3b9e9cbfb92eda61e files/digest-kchart-1.5_beta2 69
+MD5 f01ddda79b7e0afa602b27c09ae05217 files/digest-kchart-1.5_rc1 72
MD5 b2be4f48d6c3a22f2b019b15f3901e52 kchart-1.4.2.ebuild 908
MD5 ccd720eaac7e71e78e57335104c8a7ac kchart-1.5_beta1.ebuild 1096
MD5 3eb68f06d95c02b23d1a4c497fc89b5d kchart-1.5_beta2.ebuild 1096
+MD5 ccd720eaac7e71e78e57335104c8a7ac kchart-1.5_rc1.ebuild 1096
MD5 02039d51ca4a42817775fd436dfaa956 metadata.xml 157
diff --git a/app-office/kchart/files/digest-kchart-1.5_rc1 b/app-office/kchart/files/digest-kchart-1.5_rc1
new file mode 100644
index 000000000000..cf4d6b4f0ae2
--- /dev/null
+++ b/app-office/kchart/files/digest-kchart-1.5_rc1
@@ -0,0 +1 @@
+MD5 e9346977d18c67185d5b50f49ee8225b koffice-1.5.0-rc1.tar.bz2 35965316
diff --git a/app-office/kchart/kchart-1.5_rc1.ebuild b/app-office/kchart/kchart-1.5_rc1.ebuild
new file mode 100644
index 000000000000..f3b035396ced
--- /dev/null
+++ b/app-office/kchart/kchart-1.5_rc1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/kchart/kchart-1.5_rc1.ebuild,v 1.1 2006/03/29 15:16:28 carlo Exp $
+
+MAXKOFFICEVER=${PV}
+KMNAME=koffice
+inherit kde-meta eutils
+
+DESCRIPTION="KOffice integrated graph and chart drawing tool."
+HOMEPAGE="http://www.koffice.org/"
+LICENSE="GPL-2 LGPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="$(deprange $PV $MAXKOFFICEVER app-office/koffice-libs)"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+KMCOPYLIB="libkformula lib/kformula
+ libkofficecore lib/kofficecore
+ libkofficeui lib/kofficeui
+ libkopainter lib/kopainter
+ libkotext lib/kotext
+ libkwmf lib/kwmf
+ libkowmf lib/kwmf
+ libkstore lib/store
+ libkochart interfaces"
+
+KMEXTRACTONLY="lib/
+ interfaces/"
+
+KMEXTRA="filters/kchart"
+
+KMCOMPILEONLY="filters/libdialogfilter"
+
+need-kde 3.4
+
+src_unpack() {
+ kde-meta_src_unpack unpack
+
+ # We need to compile liboofilter first
+ echo "SUBDIRS = libdialogfilter kchart" > $S/filters/Makefile.am
+
+ kde-meta_src_unpack makefiles
+}