summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTodd Heim <heim@gentoo.org>2003-04-19 05:51:38 +0000
committerTodd Heim <heim@gentoo.org>2003-04-19 05:51:38 +0000
commitffe8f40b0dcfb6fec0917d491b326422ad4c08cd (patch)
tree8b7e3fe416db60d577f3e5f43410369caf63aff7 /app-office
parentversion bump; changed hardcoding of apache user/group (diff)
downloadgentoo-2-ffe8f40b0dcfb6fec0917d491b326422ad4c08cd.tar.gz
gentoo-2-ffe8f40b0dcfb6fec0917d491b326422ad4c08cd.tar.bz2
gentoo-2-ffe8f40b0dcfb6fec0917d491b326422ad4c08cd.zip
version bump; changed hardcoding of apache user/group
Diffstat (limited to 'app-office')
-rw-r--r--app-office/phprojekt/ChangeLog6
-rw-r--r--app-office/phprojekt/Manifest4
-rw-r--r--app-office/phprojekt/files/digest-phprojekt-4.01
-rw-r--r--app-office/phprojekt/phprojekt-4.0.ebuild31
4 files changed, 39 insertions, 3 deletions
diff --git a/app-office/phprojekt/ChangeLog b/app-office/phprojekt/ChangeLog
index 074351f8f59e..c4aaabb2dbd9 100644
--- a/app-office/phprojekt/ChangeLog
+++ b/app-office/phprojekt/ChangeLog
@@ -1,9 +1,13 @@
# ChangeLog for app-office/phprojekt
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/phprojekt/ChangeLog,v 1.4 2003/02/12 05:14:01 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/phprojekt/ChangeLog,v 1.5 2003/04/19 05:51:14 heim Exp $
*phprojekt-3.2a (02 Aug 2002)
+ 19 Apr 2003; Todd Heim <heim@gentoo.org> :
+ New version.
+ Replaced hardcoding of apache user/group.
+
14 Nov 2002; Mike Frysinger <vapier@gentoo.org> :
Replaced hardcoding of /home/httpd/htdocs with a grep of /etc/apache/conf/apache.conf
diff --git a/app-office/phprojekt/Manifest b/app-office/phprojekt/Manifest
index ef714420437f..65517fbb26a2 100644
--- a/app-office/phprojekt/Manifest
+++ b/app-office/phprojekt/Manifest
@@ -1,5 +1,5 @@
-MD5 5c7f43ca0c35d221a37b8c867ea98b0b ChangeLog 672
+MD5 524529e79885eca7e395aceab315addf ChangeLog 670
MD5 07ae0b330f3c4ba0c18bfe18b2dce7af phprojekt-3.2a.ebuild 863
-MD5 8327c3ed8750ca76adeda05c61774602 phprojekt-4.0.ebuild 1061
+MD5 b70d4ccb982624fd4b21cc9b5efee90a phprojekt-4.0.ebuild 1059
MD5 a5312d2a7dbb70b1d0416e37c9fd82d8 files/digest-phprojekt-3.2a 61
MD5 a4fc4523f14a2ad77b9d00dd7e386b88 files/digest-phprojekt-4.0 65
diff --git a/app-office/phprojekt/files/digest-phprojekt-4.0 b/app-office/phprojekt/files/digest-phprojekt-4.0
new file mode 100644
index 000000000000..94436fbe66f6
--- /dev/null
+++ b/app-office/phprojekt/files/digest-phprojekt-4.0
@@ -0,0 +1 @@
+MD5 a42e8b580ffa2dc59a1f13c9804c7a6a phprojekt-4.0.tar.gz 779647
diff --git a/app-office/phprojekt/phprojekt-4.0.ebuild b/app-office/phprojekt/phprojekt-4.0.ebuild
new file mode 100644
index 000000000000..86c49845eeaa
--- /dev/null
+++ b/app-office/phprojekt/phprojekt-4.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/phprojekt/phprojekt-4.0.ebuild,v 1.1 2003/04/19 05:51:14 heim Exp $
+
+# lid of download link
+MY_DOWNLOAD_ID=14
+
+HTTPD_ROOT="`grep '^DocumentRoot' /etc/apache/conf/apache.conf | cut -d\ -f2`"
+HTTPD_USER="`grep '^User' /etc/apache/conf/commonapache.conf | cut -d \ -f2`"
+HTTPD_GROUP="`grep '^Group' /etc/apache/conf/commonapache.conf | cut -d \ -f2`"
+[ -z "${HTTPD_ROOT}" ] && HTTPD_ROOT="/home/httpd/htdocs"
+[ -z "${HTTPD_USER}" ] && HTTPD_USER="apache"
+[ -z "${HTTPD_GROUP}" ] && HTTPD_GROUP="apache"
+
+DESCRIPTION="Project management and coordination system"
+HOMEPAGE="http://www.phprojekt.com/"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ppc"
+
+RDEPEND="virtual/php"
+
+src_install() {
+ dodoc ChangeLog install readme
+ dodir ${HTTPD_ROOT}/phprojekt
+ cp -r . ${D}/${HTTPD_ROOT}/phprojekt
+ cd ${D}/${HTTPD_ROOT}
+ chown -R ${HTTPD_USER}:${HTTPD_GROUP} phprojekt
+}