summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFederico Ferri <mescalinum@gentoo.org>2008-11-13 06:32:47 +0000
committerFederico Ferri <mescalinum@gentoo.org>2008-11-13 06:32:47 +0000
commitce9091a49de6dd8d3a63e94d700a11abc8da1bec (patch)
treee027ea1187a0685d5cb6dbd26a5ddc907a5e31a5 /app-pda/synce-trayicon
parentgetting synce-0.12 into tree. ebuild coming from synce overlay, reviewed and ... (diff)
downloadgentoo-2-ce9091a49de6dd8d3a63e94d700a11abc8da1bec.tar.gz
gentoo-2-ce9091a49de6dd8d3a63e94d700a11abc8da1bec.tar.bz2
gentoo-2-ce9091a49de6dd8d3a63e94d700a11abc8da1bec.zip
getting synce-0.12 into tree. ebuild coming from synce overlay, reviewed and tested.
(Portage version: 2.1.4.4)
Diffstat (limited to 'app-pda/synce-trayicon')
-rw-r--r--app-pda/synce-trayicon/ChangeLog11
-rw-r--r--app-pda/synce-trayicon/files/automake-1.9.patch8
-rw-r--r--app-pda/synce-trayicon/synce-trayicon-0.11.ebuild49
-rw-r--r--app-pda/synce-trayicon/synce-trayicon-0.12.ebuild35
4 files changed, 102 insertions, 1 deletions
diff --git a/app-pda/synce-trayicon/ChangeLog b/app-pda/synce-trayicon/ChangeLog
index 20360a2f8125..ba3dca3f1fe9 100644
--- a/app-pda/synce-trayicon/ChangeLog
+++ b/app-pda/synce-trayicon/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for app-pda/synce-trayicon
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/synce-trayicon/ChangeLog,v 1.17 2008/05/21 12:48:15 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/synce-trayicon/ChangeLog,v 1.18 2008/11/13 06:32:47 mescalinum Exp $
+
+*synce-trayicon-0.12 (13 Nov 2008)
+*synce-trayicon-0.11 (13 Nov 2008)
+
+ 13 Nov 2008; Federico Ferri <mescalinum@gentoo.org>
+ +files/automake-1.9.patch, +synce-trayicon-0.11.ebuild,
+ +synce-trayicon-0.12.ebuild:
+ getting synce-0.12 into tree. ebuild coming from synce overlay, reviewed
+ and tested.
21 May 2008; Samuli Suominen <drac@gentoo.org>
synce-trayicon-0.9.0.ebuild:
diff --git a/app-pda/synce-trayicon/files/automake-1.9.patch b/app-pda/synce-trayicon/files/automake-1.9.patch
new file mode 100644
index 000000000000..5d3a7b18d545
--- /dev/null
+++ b/app-pda/synce-trayicon/files/automake-1.9.patch
@@ -0,0 +1,8 @@
+--- autogen.sh.orig 2007-07-12 10:20:47.000000000 +0300
++++ autogen.sh 2007-07-11 21:33:53.000000000 +0300
+@@ -46,4 +46,5 @@
+ exit 1
+ }
+
++export REQUIRED_AUTOMAKE_VERSION=1.9
+ USE_GNOME2_MACROS=1 . gnome-autogen.sh $@
diff --git a/app-pda/synce-trayicon/synce-trayicon-0.11.ebuild b/app-pda/synce-trayicon/synce-trayicon-0.11.ebuild
new file mode 100644
index 000000000000..f8a60d4094e8
--- /dev/null
+++ b/app-pda/synce-trayicon/synce-trayicon-0.11.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/synce-trayicon/synce-trayicon-0.11.ebuild,v 1.1 2008/11/13 06:32:47 mescalinum Exp $
+
+inherit eutils subversion gnome2
+
+DESCRIPTION="SynCE - Gnome trayicon"
+HOMEPAGE="http://sourceforge.net/projects/synce/"
+LICENSE="MIT"
+
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+DEPEND="sys-apps/dbus
+ dev-libs/dbus-glib
+ >=dev-libs/glib-2.0
+ >=x11-libs/gtk+-2.0
+ gnome-base/libgnome
+ gnome-base/libgnomeui
+ gnome-base/libgtop
+ gnome-base/libglade
+ gnome-base/gnome-keyring
+ gnome-base/gnome-common
+ ~app-pda/synce-libsynce-0.11.1
+ ~app-pda/synce-librra-0.11.1
+ ~app-pda/synce-librapi2-0.11.1"
+
+WANT_AUTOMAKE=1.9
+SRC_URI="mirror://sourceforge/synce/${P}.tar.gz"
+
+src_unpack() {
+ subversion_src_unpack
+ cd "${S}"
+ # Force using automake 1.9
+ epatch "${FILESDIR}"/automake-1.9.patch
+}
+
+src_compile() {
+ # gnome-common < 2.18.0 hack
+ touch COPYING
+ touch INSTALL
+ ./autogen.sh --prefix=/usr
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ gnome2_icon_cache_update
+}
diff --git a/app-pda/synce-trayicon/synce-trayicon-0.12.ebuild b/app-pda/synce-trayicon/synce-trayicon-0.12.ebuild
new file mode 100644
index 000000000000..d86cceb0fd91
--- /dev/null
+++ b/app-pda/synce-trayicon/synce-trayicon-0.12.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/synce-trayicon/synce-trayicon-0.12.ebuild,v 1.1 2008/11/13 06:32:47 mescalinum Exp $
+
+inherit eutils gnome2
+
+DESCRIPTION="SynCE - Gnome trayicon"
+HOMEPAGE="http://sourceforge.net/projects/synce/"
+LICENSE="MIT"
+
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+DEPEND="sys-apps/dbus
+ dev-libs/dbus-glib
+ >=dev-libs/glib-2.0
+ >=x11-libs/gtk+-2.0
+ gnome-base/libgnome
+ gnome-base/libgnomeui
+ gnome-base/libgtop
+ gnome-base/libglade
+ gnome-base/gnome-keyring
+ gnome-base/gnome-common
+ ~app-pda/synce-libsynce-0.12
+ ~app-pda/synce-librra-0.12
+ ~app-pda/synce-librapi2-0.12
+ >=app-pda/orange-0.3.2"
+
+WANT_AUTOMAKE=1.9
+SRC_URI="mirror://sourceforge/synce/${P}.tar.gz"
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ gnome2_icon_cache_update
+}