summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Auty <ikelos@gentoo.org>2006-05-30 21:16:45 +0000
committerMike Auty <ikelos@gentoo.org>2006-05-30 21:16:45 +0000
commitd1d80aaf274925df211e204793d50cb4e32c2545 (patch)
treebccd4a0c53dd5088e58ea569274e46d46643bf53 /app-pda
parentInterblock l2tpd with xl2tpd. Install only basic configuration files and chan... (diff)
downloadgentoo-2-d1d80aaf274925df211e204793d50cb4e32c2545.tar.gz
gentoo-2-d1d80aaf274925df211e204793d50cb4e32c2545.tar.bz2
gentoo-2-d1d80aaf274925df211e204793d50cb4e32c2545.zip
Version bump fixing bug #129835
(Portage version: 2.1_rc3-r2)
Diffstat (limited to 'app-pda')
-rw-r--r--app-pda/jpilot/ChangeLog8
-rw-r--r--app-pda/jpilot/files/digest-jpilot-0.99.8-r13
-rw-r--r--app-pda/jpilot/files/jpilot-0.99.8-glibc-free.patch12
-rw-r--r--app-pda/jpilot/jpilot-0.99.8-r1.ebuild66
4 files changed, 88 insertions, 1 deletions
diff --git a/app-pda/jpilot/ChangeLog b/app-pda/jpilot/ChangeLog
index ac9d5f718fde..0a224186c5a4 100644
--- a/app-pda/jpilot/ChangeLog
+++ b/app-pda/jpilot/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-pda/jpilot
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/jpilot/ChangeLog,v 1.28 2006/03/28 13:05:49 deltacow Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/jpilot/ChangeLog,v 1.29 2006/05/30 21:16:45 ikelos Exp $
+
+*jpilot-0.99.8-r1 (30 May 2006)
+
+ 30 May 2006; Mike Auty <ikelos@gentoo.org>
+ +files/jpilot-0.99.8-glibc-free.patch, +jpilot-0.99.8-r1.ebuild:
+ Version bump fixing bug #129835
*jpilot-0.99.8 (28 Mar 2006)
diff --git a/app-pda/jpilot/files/digest-jpilot-0.99.8-r1 b/app-pda/jpilot/files/digest-jpilot-0.99.8-r1
new file mode 100644
index 000000000000..79669a2350c1
--- /dev/null
+++ b/app-pda/jpilot/files/digest-jpilot-0.99.8-r1
@@ -0,0 +1,3 @@
+MD5 4bdb200367e691e64d02bd6dfcdec604 jpilot-0.99.8.tar.gz 1589217
+RMD160 9d19e41a8d73f1dbfc5107e0ee1657ac09b55189 jpilot-0.99.8.tar.gz 1589217
+SHA256 a89ca99df142efa6046509df7522794c34da84158893bfbce836c9f5fd943d78 jpilot-0.99.8.tar.gz 1589217
diff --git a/app-pda/jpilot/files/jpilot-0.99.8-glibc-free.patch b/app-pda/jpilot/files/jpilot-0.99.8-glibc-free.patch
new file mode 100644
index 000000000000..0b33fc8b191f
--- /dev/null
+++ b/app-pda/jpilot/files/jpilot-0.99.8-glibc-free.patch
@@ -0,0 +1,12 @@
+diff -uNr jpilot-0.99.8.orig/jpilot.c jpilot-0.99.8/jpilot.c
+--- jpilot-0.99.8.orig/jpilot.c 2005-10-24 20:15:41.000000000 +0100
++++ jpilot-0.99.8/jpilot.c 2006-05-23 08:57:41.000000000 +0100
+@@ -1371,7 +1371,7 @@
+ gdk_pixdata_from_pixbuf(pixdata, pixbuf, FALSE);
+ data = gdk_pixdata_serialize(pixdata, &len);
+
+- g_free(pixbuf);
++ g_object_unref(pixbuf);
+ g_free(pixdata);
+
+ return data;
diff --git a/app-pda/jpilot/jpilot-0.99.8-r1.ebuild b/app-pda/jpilot/jpilot-0.99.8-r1.ebuild
new file mode 100644
index 000000000000..5c8ef450212d
--- /dev/null
+++ b/app-pda/jpilot/jpilot-0.99.8-r1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/jpilot/jpilot-0.99.8-r1.ebuild,v 1.1 2006/05/30 21:16:45 ikelos Exp $
+
+inherit eutils multilib
+
+DESCRIPTION="Desktop Organizer Software for the Palm Pilot"
+HOMEPAGE="http://jpilot.org/"
+SRC_URI="mirror://gentoo/distfiles/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE="nls gtk2"
+
+RDEPEND="gtk2? ( >=x11-libs/gtk+-2 )
+ !gtk2? ( >=x11-libs/gtk+-1.2 )
+ >=app-pda/pilot-link-0.11.5"
+DEPEND="${RDEPEND}
+ gtk2? ( dev-util/pkgconfig )
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S} || die
+
+ # There are four icons available. Use the third.
+ sed -i 's/jpilot.xpm/jpilot-icon3.xpm/' jpilot.desktop || die
+
+ # these two patches are from upstream
+ epatch ${FILESDIR}/${P}-memory.patch
+ epatch ${FILESDIR}/${P}-glob.patch
+ epatch ${FILESDIR}/${P}-glibc-free.patch
+}
+
+src_compile() {
+ econf $(use_enable gtk2) $(use_enable nls) || die "configure failed"
+ emake -j1 || die "make failed"
+}
+
+src_install() {
+ make install DESTDIR=${D} \
+ libdir=/usr/$(get_libdir) \
+ docdir=/usr/share/doc/${PF} \
+ icondir=/usr/share/pixmaps \
+ desktopdir=/usr/share/applications || die "install failed"
+
+ dodoc README TODO UPGRADING ABOUT-NLS BUGS ChangeLog
+ doman docs/*.1
+
+ dodir /usr/share/${PN}
+ insinto /usr/share/${PN}
+ doins ${S}/jpilotrc.*
+}
+
+pkg_postinst() {
+ einfo
+ einfo "The jpilot-syncmal plugin has moved to its own ebuild."
+ einfo "If you want to use that plugin, please run"
+ einfo " emerge jpilot-syncmal"
+ einfo
+ einfo "There are other plugins available as well. To see the"
+ einfo "list, please run"
+ einfo " emerge -s jpilot"
+ einfo
+}