summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2014-04-06 08:34:26 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2014-04-06 08:34:26 +0000
commite8bccea544f2063dcbff7838f58fd4964ff0db88 (patch)
tree7d7674bdf2ba4fe042bcecc1552011148c161abb /app-pda
parentUse subslot 0/2 for SONAME of libplist.so (diff)
downloadgentoo-2-e8bccea544f2063dcbff7838f58fd4964ff0db88.tar.gz
gentoo-2-e8bccea544f2063dcbff7838f58fd4964ff0db88.tar.bz2
gentoo-2-e8bccea544f2063dcbff7838f58fd4964ff0db88.zip
Version bump; notice that upstream removed the usbmuxd binary in purpose from the package.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'app-pda')
-rw-r--r--app-pda/usbmuxd/ChangeLog10
-rw-r--r--app-pda/usbmuxd/usbmuxd-1.0.9.ebuild35
2 files changed, 43 insertions, 2 deletions
diff --git a/app-pda/usbmuxd/ChangeLog b/app-pda/usbmuxd/ChangeLog
index cc7b0cdb441c..16226b83e3b0 100644
--- a/app-pda/usbmuxd/ChangeLog
+++ b/app-pda/usbmuxd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-pda/usbmuxd
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/usbmuxd/ChangeLog,v 1.31 2013/02/02 22:23:47 ago Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/usbmuxd/ChangeLog,v 1.32 2014/04/06 08:34:26 ssuominen Exp $
+
+*usbmuxd-1.0.9 (06 Apr 2014)
+
+ 06 Apr 2014; Samuli Suominen <ssuominen@gentoo.org> +usbmuxd-1.0.9.ebuild:
+ Version bump; notice that upstream removed the usbmuxd binary in purpose from
+ the package.
02 Feb 2013; Agostino Sarubbo <ago@gentoo.org> usbmuxd-1.0.8-r1.ebuild:
Add ~arm, wrt bug #449220
diff --git a/app-pda/usbmuxd/usbmuxd-1.0.9.ebuild b/app-pda/usbmuxd/usbmuxd-1.0.9.ebuild
new file mode 100644
index 000000000000..fe98c247c3f2
--- /dev/null
+++ b/app-pda/usbmuxd/usbmuxd-1.0.9.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/usbmuxd/usbmuxd-1.0.9.ebuild,v 1.1 2014/04/06 08:34:26 ssuominen Exp $
+
+EAPI=5
+inherit autotools-utils
+
+MY_P=lib${P}
+
+DESCRIPTION="USB multiplex daemon for use with Apple iPhone/iPod Touch devices"
+HOMEPAGE="http://www.libimobiledevice.org/"
+SRC_URI="http://www.libimobiledevice.org/downloads/${MY_P}.tar.bz2"
+
+# tools/iproxy.c is GPL-2+, everything else is LGPL-2.1+
+LICENSE="GPL-2+ LGPL-2.1+"
+SLOT="0/2" # based on SONAME of libusbmuxd.so
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="kernel_linux static-libs"
+
+RDEPEND=">=app-pda/libplist-1.11:=
+ virtual/libusb:1"
+DEPEND="${RDEPEND}
+ virtual/os-headers
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS README )
+
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ local myeconfargs=( $(use_enable static-libs static) )
+ use kernel_linux || myeconfargs+=( --without-inotify )
+
+ autotools-utils_src_configure
+}