summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Ruppert <idl0r@gentoo.org>2011-01-02 20:40:22 +0000
committerChristian Ruppert <idl0r@gentoo.org>2011-01-02 20:40:22 +0000
commit1cf74e8081a20a26fb7ab8f1912eb8f45afd18cf (patch)
treeb130de632552a0226185b07a876a030b080637c6 /app-portage
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-1cf74e8081a20a26fb7ab8f1912eb8f45afd18cf.tar.gz
gentoo-2-1cf74e8081a20a26fb7ab8f1912eb8f45afd18cf.tar.bz2
gentoo-2-1cf74e8081a20a26fb7ab8f1912eb8f45afd18cf.zip
Use python_convert_shebangs, bug 350366
(Portage version: 2.1.9.25/cvs/Linux i686)
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/mirrorselect/ChangeLog10
-rw-r--r--app-portage/mirrorselect/mirrorselect-2.1.0-r3.ebuild52
2 files changed, 60 insertions, 2 deletions
diff --git a/app-portage/mirrorselect/ChangeLog b/app-portage/mirrorselect/ChangeLog
index f7fd6888b770..44af601adac3 100644
--- a/app-portage/mirrorselect/ChangeLog
+++ b/app-portage/mirrorselect/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-portage/mirrorselect
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/mirrorselect/ChangeLog,v 1.104 2010/12/29 15:18:29 ranger Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/mirrorselect/ChangeLog,v 1.105 2011/01/02 20:40:22 idl0r Exp $
+
+*mirrorselect-2.1.0-r3 (02 Jan 2011)
+
+ 02 Jan 2011; Christian Ruppert <idl0r@gentoo.org>
+ +mirrorselect-2.1.0-r3.ebuild:
+ Use python_convert_shebangs, bug 350366
29 Dec 2010; Brent Baude <ranger@gentoo.org> mirrorselect-2.1.0-r2.ebuild:
stable ppc64, bug 344599
diff --git a/app-portage/mirrorselect/mirrorselect-2.1.0-r3.ebuild b/app-portage/mirrorselect/mirrorselect-2.1.0-r3.ebuild
new file mode 100644
index 000000000000..b81fc7362c3e
--- /dev/null
+++ b/app-portage/mirrorselect/mirrorselect-2.1.0-r3.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/mirrorselect/mirrorselect-2.1.0-r3.ebuild,v 1.1 2011/01/02 20:40:22 idl0r Exp $
+
+EAPI="3"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit eutils python
+
+DESCRIPTION="Tool to help select distfiles mirrors for Gentoo"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="dev-lang/python[xml]
+ dev-util/dialog
+ net-analyzer/netselect"
+
+RESTRICT_PYTHON_ABIS="3*"
+
+src_prepare() {
+ # bug 312753
+ epatch "${FILESDIR}/0001-Fix-rsync-mirror-selectection.patch"
+ # bug 330611
+ epatch "${FILESDIR}/0002-Check-for-a-valid-mirrorselect-test-file.patch"
+
+ python_convert_shebangs 2 main.py mirrorselect/mirrorparser3.py
+}
+
+src_install() {
+ newsbin main.py ${PN} || die
+
+ installation() {
+ insinto $(python_get_sitedir)
+ doins -r ${PN}/
+ }
+ python_execute_function installation
+
+ doman ${PN}.8 || die
+}
+
+pkg_postinst() {
+ python_mod_optimize ${PN}
+}
+
+pkg_postrm() {
+ python_mod_cleanup ${PN}
+}