summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Stakenvicius <axs@gentoo.org>2013-01-14 13:54:01 +0000
committerIan Stakenvicius <axs@gentoo.org>2013-01-14 13:54:01 +0000
commit7b3cd009c9d2ffc7eff4f75275e9ed1204166d14 (patch)
tree1164c27b568f1da38431e338a3f9b2e8ba82157d /app-portage
parentdev-python/pytools: Version Bump, #416409; take package (diff)
downloadgentoo-2-7b3cd009c9d2ffc7eff4f75275e9ed1204166d14.tar.gz
gentoo-2-7b3cd009c9d2ffc7eff4f75275e9ed1204166d14.tar.bz2
gentoo-2-7b3cd009c9d2ffc7eff4f75275e9ed1204166d14.zip
version bump; internal restructuring, minor bugfixes, documentation updates
(Portage version: 2.1.11.38/cvs/Linux x86_64, signed Manifest commit with key 2B6559ED)
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/eix/ChangeLog9
-rw-r--r--app-portage/eix/eix-0.28.0.ebuild68
2 files changed, 75 insertions, 2 deletions
diff --git a/app-portage/eix/ChangeLog b/app-portage/eix/ChangeLog
index f3006f230f40..ad4fe5007bb4 100644
--- a/app-portage/eix/ChangeLog
+++ b/app-portage/eix/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-portage/eix
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/eix/ChangeLog,v 1.441 2012/12/22 16:42:43 ago Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/eix/ChangeLog,v 1.442 2013/01/14 13:54:01 axs Exp $
+
+*eix-0.28.0 (14 Jan 2013)
+
+ 14 Jan 2013; Ian Stakenvicius <axs@gentoo.org> +eix-0.28.0.ebuild:
+ version bump; internal restructuring, minor bugfixes, documentation updates
22 Dec 2012; Agostino Sarubbo <ago@gentoo.org> eix-0.27.6.ebuild:
Add ~ppc, wrt bug #425494
diff --git a/app-portage/eix/eix-0.28.0.ebuild b/app-portage/eix/eix-0.28.0.ebuild
new file mode 100644
index 000000000000..35a0a71929b3
--- /dev/null
+++ b/app-portage/eix/eix-0.28.0.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/eix/eix-0.28.0.ebuild,v 1.1 2013/01/14 13:54:01 axs Exp $
+
+EAPI=5
+
+PLOCALES="de ru"
+inherit bash-completion-r1 eutils multilib l10n
+
+DESCRIPTION="Search and query ebuilds, portage incl. local settings, ext. overlays, version changes, and more"
+HOMEPAGE="http://eix.berlios.de"
+SRC_URI="mirror://berlios/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~ia64-hpux ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x86-solaris"
+IUSE="clang debug +dep doc nls optimization security strong-optimization sqlite tools zsh-completion"
+
+RDEPEND="app-shells/push
+ sqlite? ( >=dev-db/sqlite-3 )
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ clang? ( sys-devel/clang )
+ nls? ( sys-devel/gettext )"
+
+pkg_setup() {
+ if [[ ${REPLACING_VERSIONS//./} -lt 0253 ]]; then
+ local eixcache="${EROOT}"/var/cache/${PN}
+ [[ -f ${eixcache} ]] && rm -f "${eixcache}"
+ fi
+}
+
+src_prepare() {
+ epatch_user
+}
+
+src_configure() {
+ econf $(use_with sqlite) $(use_with doc extra-doc) \
+ $(use_with zsh-completion) \
+ $(use_enable nls) $(use_enable tools separate-tools) \
+ $(use_enable security) $(use_enable optimization) \
+ $(use_enable strong-optimization) $(use_enable debug debugging) \
+ $(use_with prefix always-accept-keywords) \
+ $(use_with dep dep-default) \
+ $(use_with clang nongnu-cxx clang++) \
+ --with-ebuild-sh-default="/usr/$(get_libdir)/portage/bin/ebuild.sh" \
+ --with-portage-rootpath="${ROOTPATH}" \
+ --with-eprefix-default="${EPREFIX}" \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ --htmldir="${EPREFIX}/usr/share/doc/${PF}/html"
+}
+
+src_install() {
+ default
+ dobashcomp bash/eix
+ keepdir "/var/cache/${PN}"
+ fowners portage:portage "/var/cache/${PN}"
+ fperms 775 "/var/cache/${PN}"
+}
+
+pkg_postinst() {
+ # fowners in src_install doesn't work for owner/group portage:
+ # merging changes this owner/group back to root.
+ use prefix || chown portage:portage "${EROOT}var/cache/${PN}"
+ local obs="${EROOT}var/cache/eix.previous"
+ ! test -f "${obs}" || ewarn "Found obsolete ${obs}, please remove it"
+}