summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Varner <fuzzyray@gentoo.org>2015-03-02 23:16:42 +0000
committerPaul Varner <fuzzyray@gentoo.org>2015-03-02 23:16:42 +0000
commit9bfb8a46c7f5720680a8fd908bdea6a783282dad (patch)
treedded40ddf38c767d929312a1a570c72a486bf998 /app-portage
parentRemove old version (diff)
downloadgentoo-2-9bfb8a46c7f5720680a8fd908bdea6a783282dad.tar.gz
gentoo-2-9bfb8a46c7f5720680a8fd908bdea6a783282dad.tar.bz2
gentoo-2-9bfb8a46c7f5720680a8fd908bdea6a783282dad.zip
Version bump.
(Portage version: 2.2.17/cvs/Linux x86_64, signed Manifest commit with key 0x6E1CBA7B)
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/ufed/ChangeLog9
-rw-r--r--app-portage/ufed/ufed-0.92.ebuild39
2 files changed, 46 insertions, 2 deletions
diff --git a/app-portage/ufed/ChangeLog b/app-portage/ufed/ChangeLog
index d80a36fa4e10..6f0836ef8b18 100644
--- a/app-portage/ufed/ChangeLog
+++ b/app-portage/ufed/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-portage/ufed
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/ufed/ChangeLog,v 1.108 2014/11/02 09:10:15 ago Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/ufed/ChangeLog,v 1.109 2015/03/02 23:16:42 fuzzyray Exp $
+
+*ufed-0.92 (02 Mar 2015)
+
+ 02 Mar 2015; Paul Varner <fuzzyray@gentoo.org> +ufed-0.92.ebuild:
+ Version bump
02 Nov 2014; Agostino Sarubbo <ago@gentoo.org> ufed-0.91.ebuild:
Stable for alpha, wrt bug #524670
diff --git a/app-portage/ufed/ufed-0.92.ebuild b/app-portage/ufed/ufed-0.92.ebuild
new file mode 100644
index 000000000000..d54d8169b3af
--- /dev/null
+++ b/app-portage/ufed/ufed-0.92.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/ufed/ufed-0.92.ebuild,v 1.1 2015/03/02 23:16:42 fuzzyray Exp $
+
+EAPI=5
+
+inherit base eutils multilib autotools
+
+DESCRIPTION="Gentoo Linux USE flags editor"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2
+ http://dev.gentoo.org/~fuzzyray/distfiles/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE=""
+
+COMMON_DEPEND="sys-libs/ncurses"
+RDEPEND="${COMMON_DEPEND}
+ dev-lang/perl"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig"
+
+# Populate the patches array for patches applied for -rX releases
+# It is an array of patch file names of the form:
+# "${FILESDIR}"/${P}-make.globals-path.patch
+PATCHES=()
+
+src_prepare() {
+ base_src_prepare
+ # Change the version number to reflect the ebuild version
+ sed -i "s:,\[git\],:,\[${PVR}\],:" configure.ac
+ eautoreconf
+}
+
+src_configure() {
+ econf --libexecdir="${EPREFIX}"/usr/$(get_libdir)/ufed
+}