summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPieter van den Abeele <pvdabeel@gentoo.org>2004-12-23 09:09:07 +0000
committerPieter van den Abeele <pvdabeel@gentoo.org>2004-12-23 09:09:07 +0000
commitc6b7cb55009d9e9917fabedd786ef2f2e8bdef38 (patch)
tree7ee0014a44189f1f83558922973ed4c7dacf3671 /app-portage
parentSee changelog (Manifest recommit) (diff)
downloadgentoo-2-c6b7cb55009d9e9917fabedd786ef2f2e8bdef38.tar.gz
gentoo-2-c6b7cb55009d9e9917fabedd786ef2f2e8bdef38.tar.bz2
gentoo-2-c6b7cb55009d9e9917fabedd786ef2f2e8bdef38.zip
*** empty log message ***
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/basc/Manifest2
-rw-r--r--app-portage/basc/basc-1.3.9-r1.ebuild77
-rw-r--r--app-portage/basc/files/digest-basc-1.3.9-r11
3 files changed, 80 insertions, 0 deletions
diff --git a/app-portage/basc/Manifest b/app-portage/basc/Manifest
index 504bbb4c3705..438f8b0db864 100644
--- a/app-portage/basc/Manifest
+++ b/app-portage/basc/Manifest
@@ -1,4 +1,6 @@
MD5 a7ec8f59bb9ef1df96943be42a63d139 ChangeLog 397
MD5 dcb8dc246c5de4b71523851e3328623c basc-1.3.9.ebuild 1860
MD5 f771ec5e8f277ad4d47d4339d412ba85 metadata.xml 257
+MD5 dcb8dc246c5de4b71523851e3328623c basc-1.3.9-r1.ebuild 1860
MD5 e2d5a46d807b9a6fc2aba48df22d2971 files/digest-basc-1.3.9 61
+MD5 e2d5a46d807b9a6fc2aba48df22d2971 files/digest-basc-1.3.9-r1 61
diff --git a/app-portage/basc/basc-1.3.9-r1.ebuild b/app-portage/basc/basc-1.3.9-r1.ebuild
new file mode 100644
index 000000000000..888ce886797c
--- /dev/null
+++ b/app-portage/basc/basc-1.3.9-r1.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/basc/basc-1.3.9-r1.ebuild,v 1.1 2004/12/23 09:09:07 pvdabeel Exp $
+
+# ebuild contributed by Alexander Mieland and Daniel Herzog
+
+inherit eutils gcc
+
+DESCRIPTION="Buildtime And Statistics Client for http://www.gentoo-stats.org"
+HOMEPAGE="http://www.gentoo-stats.org"
+SRC_URI="http://www.gentoo-stats.org/download/${P}-r1.tar.gz"
+
+KEYWORDS="x86 ~sparc ~mips ~hppa ppc ~amd64"
+SLOT="0"
+LICENSE="GPL-2"
+
+IUSE=""
+
+RDEPEND="app-portage/gentoolkit
+ dev-lang/perl
+ dev-perl/DateManip
+ net-misc/wget
+ sys-devel/gcc
+ sys-apps/sed
+ sys-apps/grep
+ app-arch/gzip
+ >=sys-apps/uhinv-0.4"
+
+pkg_setup() {
+ enewgroup stats
+ enewuser stats -1 /bin/false /tmp stats
+}
+
+src_compile() {
+ sed -i "s:/usr/local:/usr:g" client/basc
+ sed -i "s:/usr/local:/usr:g" client/hgenlop
+ $(gcc-getCC) ${CFLAGS} -o client/smt-detect client/smt-detect.c
+}
+
+src_install() {
+ exeinto /usr/bin
+ doexe client/basc client/hgenlop client/smt-detect
+ dodoc README ChangeLog TEAM
+ dodir /etc/basc
+ touch ${D}/etc/basc/basc.conf
+
+ fowners root:stats /etc/basc
+ fperms og+w /etc/basc
+
+ fowners root:stats /etc/basc/basc.conf
+ fperms og+w /etc/basc/basc.conf
+}
+
+pkg_postinst() {
+ local GU=`/usr/bin/hgenlop -nt gcc`
+ echo "GU=\"${GU}\"" >> /etc/basc/basc.conf
+
+ draw_line
+ einfo
+ einfo "The Gentoo Buildtime and Statistics client can be started by"
+ einfo "typing:"
+ einfo ""
+ einfo " \"basc -u\"."
+ einfo ""
+ einfo "If you want to automatically launch the client every 24h,"
+ einfo "you must set up a cronjob for the stats user or a user in"
+ einfo "the stats group."
+ einfo ""
+ einfo "For example:"
+ einfo ""
+ einfo " \"0 0 * * * /usr/bin/basc -q >/dev/null 2>&1\""
+ einfo ""
+ einfo "will start the client every day at 00:00am"
+ einfo
+ draw_line
+ ebeep
+}
diff --git a/app-portage/basc/files/digest-basc-1.3.9-r1 b/app-portage/basc/files/digest-basc-1.3.9-r1
new file mode 100644
index 000000000000..286bff54db1e
--- /dev/null
+++ b/app-portage/basc/files/digest-basc-1.3.9-r1
@@ -0,0 +1 @@
+MD5 94d1cb6286e9d30073d72f0517b46b0d basc-1.3.9.tar.gz 13775