summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMalcolm Lashley <malc@gentoo.org>2004-07-31 21:14:30 +0000
committerMalcolm Lashley <malc@gentoo.org>2004-07-31 21:14:30 +0000
commit3c0f8eaec410a452ed37409ae9272cf4cb433032 (patch)
treeb8682e11ee08a75b5461e2836b72eb54c7a7e067 /app-sci/fung-calc
parentsyntax cleanup, add in :help versionblah.txt einfo (diff)
downloadgentoo-2-3c0f8eaec410a452ed37409ae9272cf4cb433032.tar.gz
gentoo-2-3c0f8eaec410a452ed37409ae9272cf4cb433032.tar.bz2
gentoo-2-3c0f8eaec410a452ed37409ae9272cf4cb433032.zip
Add gcc34 and fPIC patches, keyword ~amd64, closes bug #57768
Diffstat (limited to 'app-sci/fung-calc')
-rw-r--r--app-sci/fung-calc/ChangeLog5
-rw-r--r--app-sci/fung-calc/files/fung-calc-fPIC41
-rw-r--r--app-sci/fung-calc/files/fung-calc-gcc34-fix29
-rw-r--r--app-sci/fung-calc/fung-calc-1.3.2b.ebuild8
4 files changed, 80 insertions, 3 deletions
diff --git a/app-sci/fung-calc/ChangeLog b/app-sci/fung-calc/ChangeLog
index b660df04929d..09152bdaca21 100644
--- a/app-sci/fung-calc/ChangeLog
+++ b/app-sci/fung-calc/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-sci/fung-calc
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/fung-calc/ChangeLog,v 1.7 2004/07/01 19:38:47 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/fung-calc/ChangeLog,v 1.8 2004/07/31 21:14:30 malc Exp $
+
+ 31 Jul 2004; <malc@gentoo.org> fung-calc-1.3.2b.ebuild:
+ Add gcc34 and fPIC patches, keyword ~amd64, closes bug #57768
01 Jul 2004; Jeremy Huddleston <eradicator@gentoo.org>
fung-calc-1.3.2b.ebuild:
diff --git a/app-sci/fung-calc/files/fung-calc-fPIC b/app-sci/fung-calc/files/fung-calc-fPIC
new file mode 100644
index 000000000000..a9c49c7a6a77
--- /dev/null
+++ b/app-sci/fung-calc/files/fung-calc-fPIC
@@ -0,0 +1,41 @@
+diff -Naur libfungcalcP/Makefile.in libfungcalc/Makefile.in
+--- src/libfungcalcP/Makefile.in 2004-07-31 21:42:00.546760608 +0100
++++ src/libfungcalc/Makefile.in 2003-07-19 06:04:22.000000000 +0100
+@@ -51,14 +51,14 @@
+ AWK = @AWK@
+ CC = @CC@
+ CCDEPMODE = @CCDEPMODE@
+-CFLAGS = @CFLAGS@
++CFLAGS = @CFLAGS@ -fPIC
+ CONF_FILES = @CONF_FILES@
+ CPP = @CPP@
+-CPPFLAGS = @CPPFLAGS@
++CPPFLAGS = @CPPFLAGS@
+ CXX = @CXX@
+ CXXCPP = @CXXCPP@
+ CXXDEPMODE = @CXXDEPMODE@
+-CXXFLAGS = @CXXFLAGS@
++CXXFLAGS = @CXXFLAGS@ -fPIC
+ CYGPATH_W = @CYGPATH_W@
+ DCOPIDL = @DCOPIDL@
+ DCOPIDL2CPP = @DCOPIDL2CPP@
+diff -Naur libfungcalcuiP/Makefile.in libfungcalcui/Makefile.in
+--- src/libfungcalcuiP/Makefile.in 2004-07-31 21:42:09.651376496 +0100
++++ src/libfungcalcui/Makefile.in 2003-07-19 06:04:22.000000000 +0100
+@@ -51,14 +51,14 @@
+ AWK = @AWK@
+ CC = @CC@
+ CCDEPMODE = @CCDEPMODE@
+-CFLAGS = @CFLAGS@
++CFLAGS = @CFLAGS@ -fPIC
+ CONF_FILES = @CONF_FILES@
+ CPP = @CPP@
+ CPPFLAGS = @CPPFLAGS@
+ CXX = @CXX@
+ CXXCPP = @CXXCPP@
+ CXXDEPMODE = @CXXDEPMODE@
+-CXXFLAGS = @CXXFLAGS@
++CXXFLAGS = @CXXFLAGS@ -fPIC
+ CYGPATH_W = @CYGPATH_W@
+ DCOPIDL = @DCOPIDL@
+ DCOPIDL2CPP = @DCOPIDL2CPP@
diff --git a/app-sci/fung-calc/files/fung-calc-gcc34-fix b/app-sci/fung-calc/files/fung-calc-gcc34-fix
new file mode 100644
index 000000000000..a0d58e1c4400
--- /dev/null
+++ b/app-sci/fung-calc/files/fung-calc-gcc34-fix
@@ -0,0 +1,29 @@
+--- orig/src/libfungcalc/fparser/fparser.cc 2003-07-04 00:22:01.000000000 +0100
+--- new/src/libfungcalc/fparser/fparser.cc 2003-07-04 00:22:01.000000000 +0100
+@@ -163,7 +163,7 @@
+ }
+ return 0;
+ }
+-};
++}
+
+ //---------------------------------------------------------------------------
+ // Constructors and destructors
+@@ -236,7 +236,7 @@
+ }
+ return true;
+ }
+-};
++}
+
+ bool FunctionParser::isValidName(const std::string& name)
+ {
+@@ -361,7 +361,7 @@
+ {
+ while(F[Ind] && F[Ind] == ' ') ++Ind;
+ }
+-};
++}
+
+ // Returns an iterator to the variable with the same name as 'F', or to
+ // Variables.end() if no such variable exists:
diff --git a/app-sci/fung-calc/fung-calc-1.3.2b.ebuild b/app-sci/fung-calc/fung-calc-1.3.2b.ebuild
index 25c2603c09fe..8e9dc52cf069 100644
--- a/app-sci/fung-calc/fung-calc-1.3.2b.ebuild
+++ b/app-sci/fung-calc/fung-calc-1.3.2b.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/fung-calc/fung-calc-1.3.2b.ebuild,v 1.6 2004/07/01 11:51:53 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/fung-calc/fung-calc-1.3.2b.ebuild,v 1.7 2004/07/31 21:14:30 malc Exp $
IUSE="opengl"
@@ -9,7 +9,7 @@ HOMEPAGE="http://fung-calc.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86 ~ppc"
+KEYWORDS="~x86 ~ppc ~amd64"
DEPEND=">=sys-libs/zlib-1
>=media-libs/libpng-1.2
@@ -20,12 +20,16 @@ DEPEND=">=sys-libs/zlib-1
opengl? ( virtual/opengl )
>=kde-base/kdebase-3.1"
+inherit eutils flag-o-matic
+
src_compile() {
addwrite ${QTDIR}/etc/settings
local myconf
use opengl || myconf="${myconf} --disable-glgraph"
+ use amd64 && epatch ${FILESDIR}/fung-calc-fPIC || die
# use kde || myconf="${myconf} --disable-kde-app"
econf ${myconf} || die "configure failed"
+ epatch ${FILESDIR}/fung-calc-gcc34-fix || die
emake || die "make failed"
}