summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2002-10-14 17:58:53 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2002-10-14 17:58:53 +0000
commit9ee887297e97ec8c4e21bcad843a1ff748e71dd6 (patch)
tree7c3865af11e7dab0dc23ef6639dc94be716332fc /app-sci/magic/magic-7.1-r1.ebuild
parentNew upstream version. (diff)
downloadgentoo-2-9ee887297e97ec8c4e21bcad843a1ff748e71dd6.tar.gz
gentoo-2-9ee887297e97ec8c4e21bcad843a1ff748e71dd6.tar.bz2
gentoo-2-9ee887297e97ec8c4e21bcad843a1ff748e71dd6.zip
Fix for #8581.
Diffstat (limited to 'app-sci/magic/magic-7.1-r1.ebuild')
-rw-r--r--app-sci/magic/magic-7.1-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/app-sci/magic/magic-7.1-r1.ebuild b/app-sci/magic/magic-7.1-r1.ebuild
new file mode 100644
index 000000000000..68fe73860b07
--- /dev/null
+++ b/app-sci/magic/magic-7.1-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/app-sci/magic/magic-7.1-r1.ebuild,v 1.1 2002/10/14 17:58:53 aliz Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="The VLSI design CAD tool"
+SRC_URI="http://vlsi.cornell.edu/${PN}/${P}.tar.gz"
+HOMEPAGE="http://vlsi.cornell.edu/magic/"
+KEYWORDS="x86"
+LICENSE="as-is"
+DEPEND="sys-apps/findutils
+ sys-devel/perl
+ >=app-shells/tcsh-6.10-r3
+ sys-libs/libtermcap-compat"
+RDEPEND="sys-libs/libtermcap-compat"
+SLOT="7"
+
+src_unpack() {
+ unpack ${A}
+
+ # Patch to use FHS paths
+ patch -p1 < ${FILESDIR}/${P}-fhs.patch
+
+ # Patch for GCC 3.2 compatibility
+ patch -p1 < ${FILESDIR}/${P}-gcc3.2.patch
+
+ # Insert our idea of configuration file
+ cp ${FILESDIR}/defs.mak-${PV}-r1 ${S}/defs.mak
+
+ # Clean up all the pre-GCC-3.2 preprocessor directives
+ einfo "Cleansing preprocessor directives"
+ find ./ -name "*.[ch]" | xargs -n 1 perl -pi -e 's/^\#endif..*$/\#endif/'
+ find ./ -name "*.[ch]" | xargs -n 1 perl -pi -e 's/^\#else..*$/\#else/'
+}
+
+src_compile() {
+ emake || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+
+ insinto /etc/env.d
+ doins ${FILESDIR}/10magic
+}