summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2002-05-07 01:57:35 +0000
committerGeorge Shapovalov <george@gentoo.org>2002-05-07 01:57:35 +0000
commitd517eba7a9d8e497fe68d95c7bf4724375042e0f (patch)
tree6dd188c7bb4de2054397db168157c886309da0ff /app-sci/moldy
parentmoved gperiodic from app-misc to app-sci (diff)
downloadgentoo-2-d517eba7a9d8e497fe68d95c7bf4724375042e0f.tar.gz
gentoo-2-d517eba7a9d8e497fe68d95c7bf4724375042e0f.tar.bz2
gentoo-2-d517eba7a9d8e497fe68d95c7bf4724375042e0f.zip
moved kstars, moldy, scigraphica, units and xcirquit from app-misc to app-sci
Diffstat (limited to 'app-sci/moldy')
-rw-r--r--app-sci/moldy/ChangeLog13
-rw-r--r--app-sci/moldy/files/digest-moldy-2.16e1
-rw-r--r--app-sci/moldy/moldy-2.16e.ebuild56
3 files changed, 70 insertions, 0 deletions
diff --git a/app-sci/moldy/ChangeLog b/app-sci/moldy/ChangeLog
new file mode 100644
index 000000000000..00df7ec3d068
--- /dev/null
+++ b/app-sci/moldy/ChangeLog
@@ -0,0 +1,13 @@
+# ChangeLog for app-misc/moldy
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/app-sci/moldy/ChangeLog,v 1.1 2002/05/07 01:57:35 george Exp $
+
+*moldy-2.16e (1 Feb 2002)
+
+ 1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
+
+ Added initial ChangeLog which should be updated whenever the package is
+ updated in any way. This changelog is targetted to users. This means that the
+ comments should well explained and written in clean English. The details about
+ writing correct changelogs are explained in the skel.ChangeLog file which you
+ can find in the root directory of the portage repository.
diff --git a/app-sci/moldy/files/digest-moldy-2.16e b/app-sci/moldy/files/digest-moldy-2.16e
new file mode 100644
index 000000000000..e048f7b14413
--- /dev/null
+++ b/app-sci/moldy/files/digest-moldy-2.16e
@@ -0,0 +1 @@
+MD5 8a062795aaf531adcfbdb030c87b9ff1 moldy-2.16e.tar.gz 488410
diff --git a/app-sci/moldy/moldy-2.16e.ebuild b/app-sci/moldy/moldy-2.16e.ebuild
new file mode 100644
index 000000000000..b311eaec6bdb
--- /dev/null
+++ b/app-sci/moldy/moldy-2.16e.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Tod Neidt <tneidt@fidnet.com>
+# /home/cvsroot/gentoo-x86/skel.build,v 1.7 2001/08/25 21:15:08 chadh Exp
+
+S=${WORKDIR}
+DESCRIPTION="Program for performing molecular dynamics simulations."
+SRC_URI="ftp://ftp.earth.ox.ac.uk/pub/${P}.tar.gz"
+#For lack of a better homepage
+HOMEPAGE="http://sal.kachinatech.com/Z/2/MOLDY.html"
+
+DEPEND="virtual/glibc
+ X? ( x11-base/xfree )"
+
+src_compile() {
+
+ local myconf
+ if [ -z "`use X`" ]
+ then
+ myconf="--without-x"
+ fi
+
+#Individuals may want to edit the OPT* variables below.
+#From the READ.ME:
+#You may need to "hand-tune" compiler or optimization options,
+#which may be specified by setting the OPT and OPT2 environment
+#variables. OPT2 is used to compile only the most performance-critical
+#modules and usually will select a very high level of optimization.
+#It should be safe to select an optimization which means "treat all
+#function arguments as restricted pointers which are not aliased to
+#any other object". OPT is used for less preformance-critical modules
+#and may be set to a lower level of optimization than OPT2.
+
+ OPT=${CFLAGS} OPT2=${CFLAGS} \
+ ./configure --prefix=/usr \
+ --host=${CHOST} \
+ ${myconf} || die
+
+ emake || die
+ make moldy.pdf || die
+}
+
+src_install () {
+
+ dodir /usr/bin
+ make prefix=${D}/usr install || die
+ rm Makefile.in configure.in config.h.in
+ insinto /usr/share/${PN}/examples/
+ doins *.in *.out control.*
+ dodoc BENCHMARK COPYING READ.ME RELNOTES
+ insinto /usr/share/doc/${P}/pdf
+ newins moldy.pdf moldy-manual.pdf
+
+}
+
+