summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Fisette <ribosome@gentoo.org>2004-07-20 20:56:20 +0000
committerOlivier Fisette <ribosome@gentoo.org>2004-07-20 20:56:20 +0000
commit18a1fff32e8da14c4d56dd1d52e3792f7992882c (patch)
tree9191f2060fccb4a58aea62b24a4072591244ea5f /app-sci
parentBump x11-plugins/wmcms-0.3.5.ebuild revision with patch to make it work seaml... (diff)
downloadgentoo-2-18a1fff32e8da14c4d56dd1d52e3792f7992882c.tar.gz
gentoo-2-18a1fff32e8da14c4d56dd1d52e3792f7992882c.tar.bz2
gentoo-2-18a1fff32e8da14c4d56dd1d52e3792f7992882c.zip
Updated version. Added support for parallel computing.
Diffstat (limited to 'app-sci')
-rw-r--r--app-sci/tree-puzzle/ChangeLog10
-rw-r--r--app-sci/tree-puzzle/Manifest6
-rw-r--r--app-sci/tree-puzzle/files/digest-tree-puzzle-5.21
-rw-r--r--app-sci/tree-puzzle/metadata.xml4
-rw-r--r--app-sci/tree-puzzle/tree-puzzle-5.2.ebuild47
5 files changed, 65 insertions, 3 deletions
diff --git a/app-sci/tree-puzzle/ChangeLog b/app-sci/tree-puzzle/ChangeLog
index b05355443692..bd06a32bb42b 100644
--- a/app-sci/tree-puzzle/ChangeLog
+++ b/app-sci/tree-puzzle/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-sci/tree-puzzle
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/tree-puzzle/ChangeLog,v 1.3 2004/06/24 22:19:48 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/tree-puzzle/ChangeLog,v 1.4 2004/07/20 20:56:20 ribosome Exp $
+
+*tree-puzzle-5.2 (20 Jul 2004)
+
+ 20 Jul 2004; Olivier Fisette <ribosome@gentoo.org>
+ tree-puzzle-5.2.ebuild, metadata.xml:
+ New version and an updated ebuild supporting the compilation of the
+ parallelized version of the program (ppuzzle).
+ Set myself as maintainer.
*tree-puzzle-5.1 (08 Jun 2004)
diff --git a/app-sci/tree-puzzle/Manifest b/app-sci/tree-puzzle/Manifest
index cf659fbf35ea..03e7c544a215 100644
--- a/app-sci/tree-puzzle/Manifest
+++ b/app-sci/tree-puzzle/Manifest
@@ -1,4 +1,6 @@
+MD5 ee8f2ae70e64aa11a2a31164d261e98d tree-puzzle-5.2.ebuild 1225
MD5 0d4a63cf20942f2d6c71199a260536ad tree-puzzle-5.1.ebuild 910
-MD5 d8bd2c114e49afe7543b32f50b6172a4 ChangeLog 479
-MD5 b3b353ea8c6ac55d3918c4c09b785dd8 metadata.xml 1451
+MD5 7538c1279814d44d1e9ad4e813e43157 ChangeLog 752
+MD5 d034503a05e54849a282d5baca880756 metadata.xml 1548
MD5 432840347efef142f52c23eb03c21e89 files/digest-tree-puzzle-5.1 67
+MD5 91165e7d2ebcd4a70e55b5e8bea21e43 files/digest-tree-puzzle-5.2 67
diff --git a/app-sci/tree-puzzle/files/digest-tree-puzzle-5.2 b/app-sci/tree-puzzle/files/digest-tree-puzzle-5.2
new file mode 100644
index 000000000000..fa411d8fcefb
--- /dev/null
+++ b/app-sci/tree-puzzle/files/digest-tree-puzzle-5.2
@@ -0,0 +1 @@
+MD5 20fa9606434ddc789670e681d98fe68f tree-puzzle-5.2.tar.gz 875142
diff --git a/app-sci/tree-puzzle/metadata.xml b/app-sci/tree-puzzle/metadata.xml
index d7499f40c396..ee5ea99507eb 100644
--- a/app-sci/tree-puzzle/metadata.xml
+++ b/app-sci/tree-puzzle/metadata.xml
@@ -1,6 +1,10 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
+ <maintainer>
+ <email>ribosome@gentoo.org</email>
+ <name>Olivier Fisette</name>
+ </maintainer>
<herd>sci</herd>
<longdescription>
TREE-PUZZLE is a computer program to reconstruct phylogenetic trees
diff --git a/app-sci/tree-puzzle/tree-puzzle-5.2.ebuild b/app-sci/tree-puzzle/tree-puzzle-5.2.ebuild
new file mode 100644
index 000000000000..6d9cade3eeae
--- /dev/null
+++ b/app-sci/tree-puzzle/tree-puzzle-5.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/tree-puzzle/tree-puzzle-5.2.ebuild,v 1.1 2004/07/20 20:56:20 ribosome Exp $
+
+DESCRIPTION="Maximum likelihood analysis for nucleotide, amino acid, and two-state data."
+HOMEPAGE="http://www.tree-puzzle.de"
+SRC_URI="http://www.tree-puzzle.de/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="mpi"
+
+DEPEND="virtual/glibc
+ mpi? ( sys-cluster/lam-mpi )"
+
+pkg_setup () {
+ use mpi && [ ${CC} = icc ] && die "The parallelized version of tree-puzzle cannot be compiled using icc.
+ Either disable the \"mpi\" USE flag to compile only the non-parallelized
+ version of the program, or use gcc as your compiler (CC=\"gcc\")."
+}
+
+src_compile() {
+ econf || die
+ cd ${S}/src
+ if ! use mpi; then
+ sed -i -e 's:bin_PROGRAMS = puzzle$(EXEEXT) ppuzzle:bin_PROGRAMS = puzzle :' Makefile
+ sed -i -e 's:DIST_SOURCES = $(ppuzzle_SOURCES) $(puzzle_SOURCES):DIST_SOURCES = $(puzzle_SOURCES):' Makefile
+ fi
+ cd {S}
+ emake || die
+}
+
+src_install() {
+ dobin src/puzzle
+ use mpi && dobin src/ppuzzle
+ dodoc AUTHORS ChangeLog README
+
+ # User manual
+ insinto /usr/share/doc/${PF}
+ doins doc/tree-puzzle.pdf
+
+ # Example data files
+ insinto /usr/share/${PN}/data
+ rm data/Makefile*
+ doins data/*
+}