summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Goller <morfic@gentoo.org>2004-11-13 02:40:25 +0000
committerDaniel Goller <morfic@gentoo.org>2004-11-13 02:40:25 +0000
commit6bb07a2c2546d1c0270e28646203c7892b613055 (patch)
tree63bf5f98e9bee65882a645a8d64d68ec0cb984dd /app-sci
parentadded ~ppc-macos. closes bug #58713 (Manifest recommit) (diff)
downloadgentoo-2-6bb07a2c2546d1c0270e28646203c7892b613055.tar.gz
gentoo-2-6bb07a2c2546d1c0270e28646203c7892b613055.tar.bz2
gentoo-2-6bb07a2c2546d1c0270e28646203c7892b613055.zip
added arts use flag + stable on x86
Diffstat (limited to 'app-sci')
-rw-r--r--app-sci/celestia/Manifest3
-rw-r--r--app-sci/celestia/celestia-1.3.2.ebuild11
-rw-r--r--app-sci/celestia/files/celestia-1.3.2-noarts.patch141
3 files changed, 152 insertions, 3 deletions
diff --git a/app-sci/celestia/Manifest b/app-sci/celestia/Manifest
index 651dd65bb884..e836ebad9352 100644
--- a/app-sci/celestia/Manifest
+++ b/app-sci/celestia/Manifest
@@ -1,13 +1,16 @@
MD5 4f9ff1f859899ca41f510d245af7d109 celestia-1.3.0-r1.ebuild 2222
MD5 881ad207128ff8ef475049306d2249a8 celestia-1.3.1.ebuild 2308
MD5 0f4d71adea6a063dd7b7924cb7b9e095 celestia-1.3.0.ebuild 2099
+MD5 2280a333329a5e3bd76061c0e6d15a1b celestia-1.3.2-r1.ebuild 3111
MD5 c3fe4fce1e6ecbe4f36951f09357fd40 ChangeLog 4762
MD5 1b55bd73a1313e288a88762af6cd0fb7 metadata.xml 330
MD5 bf7562960b2caaa972de42fd05a45d74 celestia-1.3.2.ebuild 3030
MD5 48aea4af15487f0c322ff982360d7ee8 files/celestia-1.3.1-gtkmain.patch 2501
MD5 f96a6eb019a59bf1a643b96c43657af8 files/resmanager.h.patch 893
+MD5 c27f53e852650b3f03ae8a66107dc476 files/celestia-1.3.2-noarts.patch 3596
MD5 95f9f0d84c71195fe1f00ba37ea79c0e files/digest-celestia-1.3.0 68
MD5 03b2de07240ae616efd0d19d150b65bb files/digest-celestia-1.3.1 68
MD5 d4ff8e51fb3a546279e7442cf24e07d7 files/digest-celestia-1.3.2 68
MD5 95f9f0d84c71195fe1f00ba37ea79c0e files/digest-celestia-1.3.0-r1 68
+MD5 d4ff8e51fb3a546279e7442cf24e07d7 files/digest-celestia-1.3.2-r1 68
MD5 318b4452af1f7b12deb515e84ca6848a files/celestia-gcc3.patch 4576
diff --git a/app-sci/celestia/celestia-1.3.2.ebuild b/app-sci/celestia/celestia-1.3.2.ebuild
index d76f9cfc3d68..f029b8c32aa9 100644
--- a/app-sci/celestia/celestia-1.3.2.ebuild
+++ b/app-sci/celestia/celestia-1.3.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/celestia/celestia-1.3.2.ebuild,v 1.3 2004/09/30 22:01:26 kugelfang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/celestia/celestia-1.3.2.ebuild,v 1.4 2004/11/13 02:40:25 morfic Exp $
inherit eutils flag-o-matic gnome2 kde-functions
@@ -10,8 +10,8 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86 ~ppc ~amd64"
-IUSE="gnome gtk kde"
+KEYWORDS="x86 ~ppc ~amd64"
+IUSE="gnome gtk kde arts"
DEPEND=">=media-libs/glut-3.7.1
virtual/glu
@@ -63,6 +63,11 @@ src_unpack() {
epatch ${FILESDIR}/resmanager.h.patch \
|| die "patching gcc 3.4 support failed"
+ if use !arts;
+ then
+ epatch ${FILESDIR}/celestia-1.3.2-noarts.patch
+ fi
+
if [ "${MYMAKE}" != "gnome" ]; then
# alright this snapshot seems to have some trouble with installing a
# file properly. It wants to install celestia.schemas in / which leads
diff --git a/app-sci/celestia/files/celestia-1.3.2-noarts.patch b/app-sci/celestia/files/celestia-1.3.2-noarts.patch
new file mode 100644
index 000000000000..f6d803f2ea25
--- /dev/null
+++ b/app-sci/celestia/files/celestia-1.3.2-noarts.patch
@@ -0,0 +1,141 @@
+--- configure.old 2004-11-05 15:10:33.551447944 -0800
++++ configure 2004-11-05 15:12:24.319608624 -0800
+@@ -27442,138 +27442,6 @@
+ fi
+
+
+- echo "$as_me:$LINENO: checking for mcopidl" >&5
+-echo $ECHO_N "checking for mcopidl... $ECHO_C" >&6
+- if test -n "$MCOPIDL"; then
+- kde_cv_path="$MCOPIDL";
+- else
+- kde_cache=`echo mcopidl | sed 'y%./+-%__p_%'`
+-
+- if eval "test \"\${kde_cv_path_$kde_cache+set}\" = set"; then
+- echo $ECHO_N "(cached) $ECHO_C" >&6
+-else
+-
+- kde_cv_path="NONE"
+- dirs="$kde_default_bindirs"
+- kde_save_IFS=$IFS
+- IFS=':'
+- for dir in $PATH; do
+- dirs="$dirs $dir"
+- done
+- IFS=$kde_save_IFS
+-
+- for dir in $dirs; do
+- if test -x "$dir/mcopidl"; then
+- if test -n ""
+- then
+- evalstr="$dir/mcopidl 2>&1 "
+- if eval $evalstr; then
+- kde_cv_path="$dir/mcopidl"
+- break
+- fi
+- else
+- kde_cv_path="$dir/mcopidl"
+- break
+- fi
+- fi
+- done
+-
+- eval "kde_cv_path_$kde_cache=$kde_cv_path"
+-
+-
+-fi
+-
+-
+- eval "kde_cv_path=\"`echo '$kde_cv_path_'$kde_cache`\""
+-
+- fi
+-
+- if test -z "$kde_cv_path" || test "$kde_cv_path" = NONE; then
+- echo "$as_me:$LINENO: result: not found" >&5
+-echo "${ECHO_T}not found" >&6
+-
+- { { echo "$as_me:$LINENO: error: The important program mcopidl was not found!
+-Please check whether you installed aRts correctly.
+-" >&5
+-echo "$as_me: error: The important program mcopidl was not found!
+-Please check whether you installed aRts correctly.
+-" >&2;}
+- { (exit 1); exit 1; }; }
+-
+- else
+- echo "$as_me:$LINENO: result: $kde_cv_path" >&5
+-echo "${ECHO_T}$kde_cv_path" >&6
+- MCOPIDL=$kde_cv_path
+-
+- fi
+-
+-
+- echo "$as_me:$LINENO: checking for artsc-config" >&5
+-echo $ECHO_N "checking for artsc-config... $ECHO_C" >&6
+- if test -n "$ARTSCCONFIG"; then
+- kde_cv_path="$ARTSCCONFIG";
+- else
+- kde_cache=`echo artsc-config | sed 'y%./+-%__p_%'`
+-
+- if eval "test \"\${kde_cv_path_$kde_cache+set}\" = set"; then
+- echo $ECHO_N "(cached) $ECHO_C" >&6
+-else
+-
+- kde_cv_path="NONE"
+- dirs="$kde_default_bindirs"
+- kde_save_IFS=$IFS
+- IFS=':'
+- for dir in $PATH; do
+- dirs="$dirs $dir"
+- done
+- IFS=$kde_save_IFS
+-
+- for dir in $dirs; do
+- if test -x "$dir/artsc-config"; then
+- if test -n ""
+- then
+- evalstr="$dir/artsc-config 2>&1 "
+- if eval $evalstr; then
+- kde_cv_path="$dir/artsc-config"
+- break
+- fi
+- else
+- kde_cv_path="$dir/artsc-config"
+- break
+- fi
+- fi
+- done
+-
+- eval "kde_cv_path_$kde_cache=$kde_cv_path"
+-
+-
+-fi
+-
+-
+- eval "kde_cv_path=\"`echo '$kde_cv_path_'$kde_cache`\""
+-
+- fi
+-
+- if test -z "$kde_cv_path" || test "$kde_cv_path" = NONE; then
+- echo "$as_me:$LINENO: result: not found" >&5
+-echo "${ECHO_T}not found" >&6
+-
+- { { echo "$as_me:$LINENO: error: The important program artsc-config was not found!
+-Please check whether you installed aRts correctly.
+-" >&5
+-echo "$as_me: error: The important program artsc-config was not found!
+-Please check whether you installed aRts correctly.
+-" >&2;}
+- { (exit 1); exit 1; }; }
+-
+- else
+- echo "$as_me:$LINENO: result: $kde_cv_path" >&5
+-echo "${ECHO_T}$kde_cv_path" >&6
+- ARTSCCONFIG=$kde_cv_path
+-
+- fi
+-
+-
+ echo "$as_me:$LINENO: checking for kde-config" >&5
+ echo $ECHO_N "checking for kde-config... $ECHO_C" >&6
+ if test -n "$KDECONFIG"; then