summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2013-05-04 10:07:37 +0000
committerMichael Weber <xmw@gentoo.org>2013-05-04 10:07:37 +0000
commit281b93a8d5dbd2acb44485d882455258f9e2981b (patch)
treeadd0bc105272ece8f91337141a3bc301a3fc494f /app-shells/autojump
parentNew package dev-ruby/ruby-gobject-introspection required for new version of R... (diff)
downloadgentoo-2-281b93a8d5dbd2acb44485d882455258f9e2981b.tar.gz
gentoo-2-281b93a8d5dbd2acb44485d882455258f9e2981b.tar.bz2
gentoo-2-281b93a8d5dbd2acb44485d882455258f9e2981b.zip
drop old version
(Portage version: 2.2.0_alpha173/cvs/Linux x86_64, signed Manifest commit with key 62EEF090)
Diffstat (limited to 'app-shells/autojump')
-rw-r--r--app-shells/autojump/ChangeLog7
-rw-r--r--app-shells/autojump/autojump-20.9.ebuild76
-rw-r--r--app-shells/autojump/autojump-21.1.0.ebuild76
-rw-r--r--app-shells/autojump/autojump-21.1.2.ebuild76
-rw-r--r--app-shells/autojump/autojump-21.2.1.ebuild71
5 files changed, 5 insertions, 301 deletions
diff --git a/app-shells/autojump/ChangeLog b/app-shells/autojump/ChangeLog
index eecf063cfb86..50106f552d82 100644
--- a/app-shells/autojump/ChangeLog
+++ b/app-shells/autojump/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-shells/autojump
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/autojump/ChangeLog,v 1.9 2013/01/09 09:06:26 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/autojump/ChangeLog,v 1.10 2013/05/04 10:07:36 xmw Exp $
+
+ 04 May 2013; Michael Weber <xmw@gentoo.org> -autojump-20.9.ebuild,
+ -autojump-21.1.0.ebuild, -autojump-21.1.2.ebuild, -autojump-21.2.1.ebuild:
+ drop old version
*autojump-21.3.0 (09 Jan 2013)
@@ -46,4 +50,3 @@
+metadata.xml:
Initial import fixes 335401, thanks to Olivier Mehani
<shtrom-gentoo@ssji.net> for the initial ebuild.
-
diff --git a/app-shells/autojump/autojump-20.9.ebuild b/app-shells/autojump/autojump-20.9.ebuild
deleted file mode 100644
index e31ebaf06803..000000000000
--- a/app-shells/autojump/autojump-20.9.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/autojump/autojump-20.9.ebuild,v 1.3 2012/06/27 17:39:56 xarthisius Exp $
-
-EAPI=4
-
-PYTHON_DEPEND="python? *"
-SUPPORT_PYTHON_ABIS="1"
-
-inherit python vcs-snapshot
-
-DESCRIPTION="change directory command that learns"
-HOMEPAGE="http://github.com/joelthelion/autojump"
-SRC_URI="https://github.com/joelthelion/${PN}/tarball/release-v${PV/./-} -> ${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="bash-completion gtk python test zsh-completion"
-
-RDEPEND="gtk? ( dev-python/pygtk:2 )
- bash-completion? ( >=app-shells/bash-4 )
- zsh-completion? ( app-shells/zsh app-shells/zsh-completion )"
-DEPEND="test? ( dev-lang/python )"
-
-src_prepare() {
- #https://github.com/joelthelion/autojump/issues/129
- sed -e '/def test_db_load_migrate/,/autojump.CONFIG_DIR = ORIG_CONFIG_DIR/d' \
- -i tests/runtests.py || die
-}
-
-src_test() {
- #https://github.com/joelthelion/autojump/issues/130
- mkdir -p "${HOME}"/.local/share/autojump || die
-
- "$(PYTHON)" ./tests/runtests.py
-}
-
-src_compile() { :; }
-
-src_install() {
- dobin bin/autojump
-
- if use gtk ; then
- dobin bin/jumpapplet
- insinto /usr/share/${PN}
- doins bin/icon.png
- fi
-
- insinto /etc/profile.d
- doins bin/${PN}.sh
-
- if use bash-completion ; then
- doins bin/${PN}.bash
- fi
-
- if use zsh-completion ; then
- doins bin/${PN}.zsh
- insinto /usr/share/zsh/site-functions
- doins bin/_j
- fi
-
- if use python ; then
- install_python() {
- insinto "$(python_get_sitedir)"
- doins tools/autojump_ipython.py
- }
- python_execute_function -q install_python
-
- einfo "This tool provides \"j\" for ipython, please add"
- einfo "\"imporrt autojump_ipython\" to your ipy_user_conf.py."
- fi
-
- doman docs/${PN}.1
- dodoc README.md
-}
diff --git a/app-shells/autojump/autojump-21.1.0.ebuild b/app-shells/autojump/autojump-21.1.0.ebuild
deleted file mode 100644
index c12560747e7a..000000000000
--- a/app-shells/autojump/autojump-21.1.0.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/autojump/autojump-21.1.0.ebuild,v 1.1 2012/11/24 11:10:09 xmw Exp $
-
-EAPI=4
-
-PYTHON_DEPEND="python? *"
-SUPPORT_PYTHON_ABIS="1"
-
-inherit python vcs-snapshot
-
-DESCRIPTION="change directory command that learns"
-HOMEPAGE="http://github.com/joelthelion/autojump"
-SRC_URI="https://github.com/joelthelion/${PN}/archive/release-v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="bash-completion gtk python test zsh-completion"
-
-RDEPEND="gtk? ( dev-python/pygtk:2 )
- bash-completion? ( >=app-shells/bash-4 )
- zsh-completion? ( app-shells/zsh app-shells/zsh-completion )"
-DEPEND="test? ( dev-lang/python )"
-
-src_prepare() {
- #https://github.com/joelthelion/autojump/issues/129
- sed -e '/def test_db_load_migrate/,/autojump.CONFIG_DIR = ORIG_CONFIG_DIR/d' \
- -i tests/runtests.py || die
-}
-
-src_test() {
- #https://github.com/joelthelion/autojump/issues/130
- mkdir -p "${HOME}"/.local/share/autojump || die
-
- "$(PYTHON)" ./tests/runtests.py
-}
-
-src_compile() { :; }
-
-src_install() {
- dobin bin/autojump
-
- if use gtk ; then
- dobin bin/jumpapplet
- insinto /usr/share/${PN}
- doins bin/icon.png
- fi
-
- insinto /etc/profile.d
- doins bin/${PN}.sh
-
- if use bash-completion ; then
- doins bin/${PN}.bash
- fi
-
- if use zsh-completion ; then
- doins bin/${PN}.zsh
- insinto /usr/share/zsh/site-functions
- doins bin/_j
- fi
-
- if use python ; then
- install_python() {
- insinto "$(python_get_sitedir)"
- doins tools/autojump_ipython.py
- }
- python_execute_function -q install_python
-
- einfo "This tool provides \"j\" for ipython, please add"
- einfo "\"imporrt autojump_ipython\" to your ipy_user_conf.py."
- fi
-
- doman docs/${PN}.1
- dodoc README.md
-}
diff --git a/app-shells/autojump/autojump-21.1.2.ebuild b/app-shells/autojump/autojump-21.1.2.ebuild
deleted file mode 100644
index 1bfee8c6c2c3..000000000000
--- a/app-shells/autojump/autojump-21.1.2.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/autojump/autojump-21.1.2.ebuild,v 1.1 2013/01/09 08:45:42 xmw Exp $
-
-EAPI=4
-
-PYTHON_DEPEND="python? *"
-SUPPORT_PYTHON_ABIS="1"
-
-inherit python vcs-snapshot
-
-DESCRIPTION="change directory command that learns"
-HOMEPAGE="http://github.com/joelthelion/autojump"
-SRC_URI="https://github.com/joelthelion/${PN}/archive/release-v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="bash-completion gtk python test zsh-completion"
-
-RDEPEND="gtk? ( dev-python/pygtk:2 )
- bash-completion? ( >=app-shells/bash-4 )
- zsh-completion? ( app-shells/zsh app-shells/zsh-completion )"
-DEPEND="test? ( dev-lang/python )"
-
-src_prepare() {
- #https://github.com/joelthelion/autojump/issues/129
- sed -e '/def test_db_load_migrate/,/autojump.CONFIG_DIR = ORIG_CONFIG_DIR/d' \
- -i tests/runtests.py || die
-}
-
-src_test() {
- #https://github.com/joelthelion/autojump/issues/130
- mkdir -p "${HOME}"/.local/share/autojump || die
-
- "$(PYTHON)" ./tests/runtests.py
-}
-
-src_compile() { :; }
-
-src_install() {
- dobin bin/autojump
-
- if use gtk ; then
- dobin bin/jumpapplet
- insinto /usr/share/${PN}
- doins bin/icon.png
- fi
-
- insinto /etc/profile.d
- doins bin/${PN}.sh
-
- if use bash-completion ; then
- doins bin/${PN}.bash
- fi
-
- if use zsh-completion ; then
- doins bin/${PN}.zsh
- insinto /usr/share/zsh/site-functions
- doins bin/_j
- fi
-
- if use python ; then
- install_python() {
- insinto "$(python_get_sitedir)"
- doins tools/autojump_ipython.py
- }
- python_execute_function -q install_python
-
- einfo "This tool provides \"j\" for ipython, please add"
- einfo "\"imporrt autojump_ipython\" to your ipy_user_conf.py."
- fi
-
- doman docs/${PN}.1
- dodoc README.md
-}
diff --git a/app-shells/autojump/autojump-21.2.1.ebuild b/app-shells/autojump/autojump-21.2.1.ebuild
deleted file mode 100644
index a57aa434cf8e..000000000000
--- a/app-shells/autojump/autojump-21.2.1.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/autojump/autojump-21.2.1.ebuild,v 1.1 2013/01/09 08:55:21 xmw Exp $
-
-EAPI=4
-
-PYTHON_DEPEND="python? *"
-SUPPORT_PYTHON_ABIS="1"
-
-inherit python vcs-snapshot
-
-DESCRIPTION="change directory command that learns"
-HOMEPAGE="http://github.com/joelthelion/autojump"
-SRC_URI="https://github.com/joelthelion/${PN}/archive/release-v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="bash-completion gtk python test zsh-completion"
-
-RDEPEND="gtk? ( dev-python/pygtk:2 )
- bash-completion? ( >=app-shells/bash-4 )
- zsh-completion? ( app-shells/zsh app-shells/zsh-completion )"
-DEPEND="test? ( dev-lang/python )"
-
-src_prepare() {
- #https://github.com/joelthelion/autojump/issues/129
- sed -e '/def test_db_load_migrate/,/autojump.CONFIG_DIR = ORIG_CONFIG_DIR/d' \
- -i tests/runtests.py || die
-}
-
-src_compile() {
- true
-}
-
-src_install() {
- dobin bin/autojump
-
- if use gtk ; then
- dobin bin/jumpapplet
- insinto /usr/share/${PN}
- doins bin/icon.png
- fi
-
- insinto /etc/profile.d
- doins bin/${PN}.sh
-
- if use bash-completion ; then
- doins bin/${PN}.bash
- fi
-
- if use zsh-completion ; then
- doins bin/${PN}.zsh
- insinto /usr/share/zsh/site-functions
- doins bin/_j
- fi
-
- if use python ; then
- install_python() {
- insinto "$(python_get_sitedir)"
- doins tools/autojump_ipython.py
- }
- python_execute_function -q install_python
-
- einfo "This tool provides \"j\" for ipython, please add"
- einfo "\"imporrt autojump_ipython\" to your ipy_user_conf.py."
- fi
-
- doman docs/${PN}.1
- dodoc README.md
-}