summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-06-24 00:25:51 +0000
committerMike Frysinger <vapier@gentoo.org>2004-06-24 00:25:51 +0000
commitc26e707d2b9e03d9d06b8bd55f5095a19ca74601 (patch)
treecec4575c9d787d49cab400fe9634be44ce3844c8 /app-shells/sandboxshell
parentQA - fix use invocation (Manifest recommit) (diff)
downloadgentoo-2-c26e707d2b9e03d9d06b8bd55f5095a19ca74601.tar.gz
gentoo-2-c26e707d2b9e03d9d06b8bd55f5095a19ca74601.tar.bz2
gentoo-2-c26e707d2b9e03d9d06b8bd55f5095a19ca74601.zip
Add support for new homedir and trap signals went prompting
Diffstat (limited to 'app-shells/sandboxshell')
-rw-r--r--app-shells/sandboxshell/ChangeLog10
-rw-r--r--app-shells/sandboxshell/files/digest-sandboxshell-0.1-r1 (renamed from app-shells/sandboxshell/files/digest-sandboxshell-0.1)0
-rw-r--r--app-shells/sandboxshell/files/sandboxshell.conf6
-rw-r--r--app-shells/sandboxshell/sandboxshell-0.1-r1.ebuild (renamed from app-shells/sandboxshell/sandboxshell-0.1.ebuild)2
4 files changed, 13 insertions, 5 deletions
diff --git a/app-shells/sandboxshell/ChangeLog b/app-shells/sandboxshell/ChangeLog
index 8341c0733679..062de55670ac 100644
--- a/app-shells/sandboxshell/ChangeLog
+++ b/app-shells/sandboxshell/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-shells/sandboxshell
-# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/sandboxshell/ChangeLog,v 1.2 2003/08/01 03:45:50 vapier Exp $
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/sandboxshell/ChangeLog,v 1.3 2004/06/24 00:25:51 vapier Exp $
+
+*sandboxshell-0.1-r1 (23 Jun 2004)
+
+ 23 Jun 2004; Mike Frysinger <vapier@gentoo.org> files/sandboxshell.conf,
+ +sandboxshell-0.1-r1.ebuild:
+ Add support for new homedir and trap signals went prompting
*sandboxshell-0.1 (09 Jul 2003)
diff --git a/app-shells/sandboxshell/files/digest-sandboxshell-0.1 b/app-shells/sandboxshell/files/digest-sandboxshell-0.1-r1
index e69de29bb2d1..e69de29bb2d1 100644
--- a/app-shells/sandboxshell/files/digest-sandboxshell-0.1
+++ b/app-shells/sandboxshell/files/digest-sandboxshell-0.1-r1
diff --git a/app-shells/sandboxshell/files/sandboxshell.conf b/app-shells/sandboxshell/files/sandboxshell.conf
index e9e4440894dc..a34e3abe9578 100644
--- a/app-shells/sandboxshell/files/sandboxshell.conf
+++ b/app-shells/sandboxshell/files/sandboxshell.conf
@@ -1,7 +1,9 @@
#!/bin/bash
# Written by vapier@gentoo.org
# public-domain code ... z0r ...
-# $Header: /var/cvsroot/gentoo-x86/app-shells/sandboxshell/files/sandboxshell.conf,v 1.3 2003/07/10 02:00:45 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/sandboxshell/files/sandboxshell.conf,v 1.4 2004/06/24 00:25:51 vapier Exp $
+
+trap ":" INT QUIT TSTP
source /etc/profile
@@ -30,7 +32,7 @@ if [ "${PWD:0:${#sbs_pdir}}" == "${sbs_pdir}" ] ; then
sbs_PREPWD=${PWD}
if [ "${env}" == "y" ] ; then
source ${sbs_tmpenvfile} 2> /dev/null
- export SANDBOX_WRITE="${SANDBOX_WRITE}:${sbs_pdir}${sbs_bdir}"
+ export SANDBOX_WRITE="${SANDBOX_WRITE}:${sbs_pdir}${sbs_bdir}:${sbs_pdir}/homedir"
fi
PWD=${sbs_PREPWD}
fi
diff --git a/app-shells/sandboxshell/sandboxshell-0.1.ebuild b/app-shells/sandboxshell/sandboxshell-0.1-r1.ebuild
index 4ae02e1939bb..9cda994dad69 100644
--- a/app-shells/sandboxshell/sandboxshell-0.1.ebuild
+++ b/app-shells/sandboxshell/sandboxshell-0.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/sandboxshell/sandboxshell-0.1.ebuild,v 1.6 2004/04/25 20:11:35 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/sandboxshell/sandboxshell-0.1-r1.ebuild,v 1.1 2004/06/24 00:25:51 vapier Exp $
DESCRIPTION="launch a sandboxed shell ... useful for debugging ebuilds"
HOMEPAGE="http://wh0rd.org/"