summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2003-03-16 05:37:31 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2003-03-16 05:37:31 +0000
commit032116798dc74043d43342d79676e20c52d4c53e (patch)
tree6ed83ba3c9af05e951a4b391f8fc4a2d46434da8 /app-shells/scsh/scsh-0.6.3.ebuild
parentremoved crusty ebuilds (diff)
downloadgentoo-2-032116798dc74043d43342d79676e20c52d4c53e.tar.gz
gentoo-2-032116798dc74043d43342d79676e20c52d4c53e.tar.bz2
gentoo-2-032116798dc74043d43342d79676e20c52d4c53e.zip
Minor version bump. Moved from /bin to /usr/bin. Documentation fix.
Diffstat (limited to 'app-shells/scsh/scsh-0.6.3.ebuild')
-rw-r--r--app-shells/scsh/scsh-0.6.3.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-shells/scsh/scsh-0.6.3.ebuild b/app-shells/scsh/scsh-0.6.3.ebuild
new file mode 100644
index 000000000000..6f04a850a045
--- /dev/null
+++ b/app-shells/scsh/scsh-0.6.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/scsh/scsh-0.6.3.ebuild,v 1.1 2003/03/16 05:37:31 mkennedy Exp $
+
+DESCRIPTION="Unix shell embedded in Scheme"
+SRC_URI="ftp://ftp.scsh.net/pub/scsh/0.6/${P}.tar.gz"
+HOMEPAGE="http://www.scsh.net/"
+
+SLOT="0"
+LICENSE="as-is | BSD | GPL-2"
+KEYWORDS="x86 ppc sparc"
+
+IUSE=""
+DEPEND=""
+
+src_compile() {
+ econf --prefix=/usr --libdir=/usr/lib --includedir=/usr/include || die
+ make || die
+}
+
+src_install() {
+ einstall prefix=${D}/usr \
+ htmldir=${D}/usr/share/doc/${PF}/html \
+ incdir=${D}/usr/include \
+ mandir=${D}/usr/share/man/man1 \
+ libdir=${D}/usr/lib || die
+ dodoc RELEASE
+
+ # Let scsh install the documentation and then clean up afterwards
+
+ dosed "s:${D}::" /usr/share/man/man1/scsh.1
+ dodir /usr/share/doc/${PF}
+ find /usr/share/doc/
+ mv ${D}/usr/lib/scsh/doc/* ${D}/usr/share/doc/${PF}
+ rmdir ${D}/usr/lib/scsh/doc
+}