summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Trygve Kalleberg <karltk@gentoo.org>2002-03-04 22:08:48 +0000
committerKarl Trygve Kalleberg <karltk@gentoo.org>2002-03-04 22:08:48 +0000
commit97e5a32ed02c91172d7d1598f055d62a612d4201 (patch)
tree0ed99feb8e92bbd209f3320721ca563c2d439a10 /app-shells/scsh
parentnew upstream version; cleaned up ebuild a bit (diff)
downloadgentoo-2-97e5a32ed02c91172d7d1598f055d62a612d4201.tar.gz
gentoo-2-97e5a32ed02c91172d7d1598f055d62a612d4201.tar.bz2
gentoo-2-97e5a32ed02c91172d7d1598f055d62a612d4201.zip
Foo
Diffstat (limited to 'app-shells/scsh')
-rw-r--r--app-shells/scsh/scsh-0.6.0.ebuild4
-rw-r--r--app-shells/scsh/scsh-0.6.1.ebuild48
2 files changed, 50 insertions, 2 deletions
diff --git a/app-shells/scsh/scsh-0.6.0.ebuild b/app-shells/scsh/scsh-0.6.0.ebuild
index a030ff40befa..8c6bba61009b 100644
--- a/app-shells/scsh/scsh-0.6.0.ebuild
+++ b/app-shells/scsh/scsh-0.6.0.ebuild
@@ -2,11 +2,11 @@
# Distributed under the terms of the GNU General Public License, v2 or later
# Maintainer: System Team <system@gentoo.org>
# Author: Matthew Kennedy <mbkennedy@ieee.org>
-# $Header: /var/cvsroot/gentoo-x86/app-shells/scsh/scsh-0.6.0.ebuild,v 1.1 2002/02/24 22:31:38 karltk Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/scsh/scsh-0.6.0.ebuild,v 1.2 2002/03/04 22:08:48 karltk Exp $
S=${WORKDIR}/${P}
DESCRIPTION="Scsh is a Unix shell embedded in Scheme"
-SRC_URI="ftp://ftp.scsh.net/pub/scsh/0.6/scsh-0.6.0.tar.gz"
+SRC_URI="ftp://ftp.scsh.net/pub/scsh/0.6/scsh-${PV}.tar.gz"
HOMEPAGE="http://www.scsh.net/"
DEPEND="virtual/glibc"
diff --git a/app-shells/scsh/scsh-0.6.1.ebuild b/app-shells/scsh/scsh-0.6.1.ebuild
new file mode 100644
index 000000000000..6a6b17b21656
--- /dev/null
+++ b/app-shells/scsh/scsh-0.6.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: System Team <system@gentoo.org>
+# Author: Matthew Kennedy <mbkennedy@ieee.org>
+# $Header: /var/cvsroot/gentoo-x86/app-shells/scsh/scsh-0.6.1.ebuild,v 1.1 2002/03/04 22:08:48 karltk Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Scsh is a Unix shell embedded in Scheme"
+SRC_URI="ftp://ftp.scsh.net/pub/scsh/0.6/scsh-${PV}.tar.gz"
+HOMEPAGE="http://www.scsh.net/"
+
+DEPEND="virtual/glibc"
+
+src_compile() {
+ ./configure --prefix=/ --host=${CHOST} \
+ --mandir=/usr/share/man \
+ --libdir=/usr/lib \
+ --includedir=/usr/include
+ make || die
+}
+
+src_install() {
+ make prefix=${D} \
+ htmldir=${D}/usr/share/doc/${P}/html \
+ incdir=${D}/usr/include \
+ libdir=${D}/usr/lib \
+ mandir=${D}/usr/share/man \
+ install || die
+
+ dodoc COPYING INSTALL RELEASE
+
+
+ # Scsh doesn't have a very consistent documentation
+ # structure. It's possible to override the placement of the
+ # HTML during make install, but not the other documentation in
+ # TeX, DVI and PS formats.
+
+ # Thus we let scsh install the documentation and then clean up
+ # afterwards.
+
+ mv ${D}/usr/lib/scsh/doc/* ${D}/usr/share/doc/${P}
+ rmdir ${D}/usr/lib/scsh/doc
+ find ${D}/usr/share/doc/${P} \( -name \*.ps -o \
+ -name \*.txt -o \
+ -name \*.dvi -o \
+ -name \*.tex \) \
+ -print | xargs gzip
+}