summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDawid Węgliński <cla@gentoo.org>2009-12-04 01:49:31 +0000
committerDawid Węgliński <cla@gentoo.org>2009-12-04 01:49:31 +0000
commitb8f02423a0c293cf0fa638c4018afc82df3162ed (patch)
tree618e82127633ff0fc3060e1da81f2d3ece279c8d /app-shells/zsh-completion/zsh-completion-20091203.ebuild
parent20091130 snapshot (diff)
downloadgentoo-2-b8f02423a0c293cf0fa638c4018afc82df3162ed.tar.gz
gentoo-2-b8f02423a0c293cf0fa638c4018afc82df3162ed.tar.bz2
gentoo-2-b8f02423a0c293cf0fa638c4018afc82df3162ed.zip
Improve eix completion
(Portage version: 2.2_rc52/cvs/Linux x86_64)
Diffstat (limited to 'app-shells/zsh-completion/zsh-completion-20091203.ebuild')
-rw-r--r--app-shells/zsh-completion/zsh-completion-20091203.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-shells/zsh-completion/zsh-completion-20091203.ebuild b/app-shells/zsh-completion/zsh-completion-20091203.ebuild
new file mode 100644
index 000000000000..bab3162c808d
--- /dev/null
+++ b/app-shells/zsh-completion/zsh-completion-20091203.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/zsh-completion/zsh-completion-20091203.ebuild,v 1.1 2009/12/04 01:49:31 cla Exp $
+
+inherit eutils
+
+MY_PV="20080310"
+DESCRIPTION="Programmable Completion for zsh (includes emerge and ebuild commands)"
+HOMEPAGE="http://gzc.tuxfamily.org/"
+SRC_URI="http://download.tuxfamily.org/gzc/${PN}-${MY_PV}.tar.bz2"
+
+LICENSE="ZSH"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE=""
+
+DEPEND=">=app-shells/zsh-4.3.5"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"/${PN}-${MY_PV}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-eix-20091203.patch
+}
+
+src_install() {
+ insinto /usr/share/zsh/site-functions
+ doins _*
+
+ dodoc AUTHORS
+}
+
+pkg_postinst() {
+ elog
+ elog "If you happen to compile your functions, you may need to delete"
+ elog "~/.zcompdump{,.zwc} and recompile to make zsh-completion available"
+ elog "to your shell."
+ elog
+}