summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-03-03 21:18:30 +0000
committerMike Frysinger <vapier@gentoo.org>2011-03-03 21:18:30 +0000
commit961c91b934b2b07626ef7a41a6027233c55f0142 (patch)
tree6afb7e6f894ece1cfc91ac162298668585f8287f /app-shells
parentVersion bump. (diff)
downloadgentoo-2-961c91b934b2b07626ef7a41a6027233c55f0142.tar.gz
gentoo-2-961c91b934b2b07626ef7a41a6027233c55f0142.tar.bz2
gentoo-2-961c91b934b2b07626ef7a41a6027233c55f0142.zip
Add fix from upstream for quoting issues.
(Portage version: 2.2.0_alpha25/cvs/Linux x86_64)
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/bash/ChangeLog6
-rw-r--r--app-shells/bash/bash-4.2_p6.ebuild4
-rw-r--r--app-shells/bash/files/bash-4.2-expand-string-unsplit.patch13
3 files changed, 21 insertions, 2 deletions
diff --git a/app-shells/bash/ChangeLog b/app-shells/bash/ChangeLog
index 90f0d8f1f216..3218a756252c 100644
--- a/app-shells/bash/ChangeLog
+++ b/app-shells/bash/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-shells/bash
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/ChangeLog,v 1.283 2011/03/02 02:28:36 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/ChangeLog,v 1.284 2011/03/03 21:18:30 vapier Exp $
+
+ 03 Mar 2011; Mike Frysinger <vapier@gentoo.org> bash-4.2_p6.ebuild,
+ +files/bash-4.2-expand-string-unsplit.patch:
+ Add fix from upstream for quoting issues.
*bash-4.2_p6 (02 Mar 2011)
diff --git a/app-shells/bash/bash-4.2_p6.ebuild b/app-shells/bash/bash-4.2_p6.ebuild
index d1fe6f02b3fa..827c372c88d8 100644
--- a/app-shells/bash/bash-4.2_p6.ebuild
+++ b/app-shells/bash/bash-4.2_p6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-4.2_p6.ebuild,v 1.1 2011/03/02 02:28:36 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-4.2_p6.ebuild,v 1.2 2011/03/03 21:18:30 vapier Exp $
EAPI="1"
@@ -69,6 +69,8 @@ src_unpack() {
cd lib/readline
[[ ${READLINE_PLEVEL} -gt 0 ]] && epatch $(patches -s ${READLINE_PLEVEL} readline ${READLINE_VER})
cd ../..
+
+ epatch "${FILESDIR}"/${PN}-4.2-expand-string-unsplit.patch
}
src_compile() {
diff --git a/app-shells/bash/files/bash-4.2-expand-string-unsplit.patch b/app-shells/bash/files/bash-4.2-expand-string-unsplit.patch
new file mode 100644
index 000000000000..75235c92cb28
--- /dev/null
+++ b/app-shells/bash/files/bash-4.2-expand-string-unsplit.patch
@@ -0,0 +1,13 @@
+*** ../bash-4.2-patched/subst.c 2011-02-25 12:03:58.000000000 -0500
+--- subst.c 2011-03-03 14:08:23.000000000 -0500
+***************
+*** 4609,4614 ****
+--- 4611,4617 ----
+ if (ifs_firstc == 0)
+ #endif
+ word->flags |= W_NOSPLIT;
++ word->flags |= W_NOSPLIT2;
+ result = call_expand_word_internal (word, quoted, 0, (int *)NULL, (int *)NULL);
+ expand_no_split_dollar_star = 0;
+
+