summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2014-03-28 02:10:54 +0000
committerMike Frysinger <vapier@gentoo.org>2014-03-28 02:10:54 +0000
commita41a781e538f517b386fb6aa65d08d1215387a80 (patch)
tree62949831fecc4caad08b14b02d5fdb694472985c /app-shells
parentStable for HPPA (bug #499954). (diff)
downloadgentoo-2-a41a781e538f517b386fb6aa65d08d1215387a80.tar.gz
gentoo-2-a41a781e538f517b386fb6aa65d08d1215387a80.tar.bz2
gentoo-2-a41a781e538f517b386fb6aa65d08d1215387a80.zip
Fix from upstream for crash when exiting the shell.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/bash/ChangeLog8
-rw-r--r--app-shells/bash/bash-4.3-r3.ebuild (renamed from app-shells/bash/bash-4.3-r2.ebuild)3
-rw-r--r--app-shells/bash/files/bash-4.3-input-line-realloc.patch17
3 files changed, 26 insertions, 2 deletions
diff --git a/app-shells/bash/ChangeLog b/app-shells/bash/ChangeLog
index 282247583d07..2e8af4f7fb06 100644
--- a/app-shells/bash/ChangeLog
+++ b/app-shells/bash/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-shells/bash
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/ChangeLog,v 1.357 2014/03/20 19:45:36 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/ChangeLog,v 1.358 2014/03/28 02:10:54 vapier Exp $
+
+*bash-4.3-r3 (28 Mar 2014)
+
+ 28 Mar 2014; Mike Frysinger <vapier@gentoo.org> +bash-4.3-r3.ebuild,
+ +files/bash-4.3-input-line-realloc.patch, -bash-4.3-r2.ebuild:
+ Fix from upstream for crash when exiting the shell.
*bash-4.3-r2 (20 Mar 2014)
diff --git a/app-shells/bash/bash-4.3-r2.ebuild b/app-shells/bash/bash-4.3-r3.ebuild
index 688b310ec3bd..df77a5657db1 100644
--- a/app-shells/bash/bash-4.3-r2.ebuild
+++ b/app-shells/bash/bash-4.3-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-4.3-r2.ebuild,v 1.1 2014/03/20 19:45:36 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-4.3-r3.ebuild,v 1.1 2014/03/28 02:10:54 vapier Exp $
EAPI="4"
@@ -89,6 +89,7 @@ src_prepare() {
epatch "${FILESDIR}"/${P}-pcomplete-dequote.patch
epatch "${FILESDIR}"/${P}-extglob-skipname.patch
epatch "${FILESDIR}"/${P}-compound-array-empty-value.patch
+ epatch "${FILESDIR}"/${P}-input-line-realloc.patch
epatch_user
}
diff --git a/app-shells/bash/files/bash-4.3-input-line-realloc.patch b/app-shells/bash/files/bash-4.3-input-line-realloc.patch
new file mode 100644
index 000000000000..f50c6f900dc8
--- /dev/null
+++ b/app-shells/bash/files/bash-4.3-input-line-realloc.patch
@@ -0,0 +1,17 @@
+https://lists.gnu.org/archive/html/bug-bash/2014-03/msg00172.html
+
+*** ../bash-4.3-patched/parse.y 2014-02-11 09:42:10.000000000 -0500
+--- parse.y 2014-03-27 16:33:29.000000000 -0400
+***************
+*** 2425,2429 ****
+ if (shell_input_line_terminator != EOF)
+ {
+! if (shell_input_line_size < SIZE_MAX && shell_input_line_len > shell_input_line_size - 3)
+ shell_input_line = (char *)xrealloc (shell_input_line,
+ 1 + (shell_input_line_size += 2));
+--- 2425,2429 ----
+ if (shell_input_line_terminator != EOF)
+ {
+! if (shell_input_line_size < SIZE_MAX-3 && (shell_input_line_len+3 > shell_input_line_size))
+ shell_input_line = (char *)xrealloc (shell_input_line,
+ 1 + (shell_input_line_size += 2));