summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-05-18 07:02:14 +0000
committerJustin Lecher <jlec@gentoo.org>2010-05-18 07:02:14 +0000
commite053489884d9b2777b7bfaef8f60cc04176d8a7a (patch)
treeedb14a5d1a16d116c6c508640fb19e6e2ef4d728 /app-shells
parentDEPEND on Module-Build. Maintenance (diff)
downloadgentoo-2-e053489884d9b2777b7bfaef8f60cc04176d8a7a.tar.gz
gentoo-2-e053489884d9b2777b7bfaef8f60cc04176d8a7a.tar.bz2
gentoo-2-e053489884d9b2777b7bfaef8f60cc04176d8a7a.zip
Version Bump, #319833, thanks Jure Varlec for the patches
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/prll/ChangeLog8
-rw-r--r--app-shells/prll/files/0.5-prefix.patch30
-rw-r--r--app-shells/prll/prll-0.5.ebuild29
3 files changed, 66 insertions, 1 deletions
diff --git a/app-shells/prll/ChangeLog b/app-shells/prll/ChangeLog
index a55bc25c9e86..bdef3bad416e 100644
--- a/app-shells/prll/ChangeLog
+++ b/app-shells/prll/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-shells/prll
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/prll/ChangeLog,v 1.3 2010/04/25 11:19:00 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/prll/ChangeLog,v 1.4 2010/05/18 07:02:14 jlec Exp $
+
+*prll-0.5 (18 May 2010)
+
+ 18 May 2010; Justin Lecher <jlec@gentoo.org> +files/0.5-prefix.patch,
+ +prll-0.5.ebuild:
+ Version Bump, #319833, thanks Jure Varlec for the patches
01 Mar 2010; Justin Lecher <jlec@gentoo.org> metadata.xml:
Added to shell-tools herd
diff --git a/app-shells/prll/files/0.5-prefix.patch b/app-shells/prll/files/0.5-prefix.patch
new file mode 100644
index 000000000000..dcf2314fb5d0
--- /dev/null
+++ b/app-shells/prll/files/0.5-prefix.patch
@@ -0,0 +1,30 @@
+diff --git a/prll.sh b/prll.sh
+index 45a4fa4..f3ec39f 100644
+--- a/prll.sh
++++ b/prll.sh
+@@ -41,7 +41,7 @@ function prll() {
+ EOF
+ [[ -z "$1" ]] && return 1 || return 0
+ fi
+- /usr/bin/which prll_qer > /dev/null
++ @GENTOO_PORTAGE_EPREFIX@/usr/bin/which prll_qer > /dev/null
+ if [[ $? -ne 0 ]] ; then
+ echo "PRLL: Missing prll_qer." 1>&2
+ return 1
+@@ -51,14 +51,14 @@ function prll() {
+ local prll_unbuffer=yes
+ shift
+ else
+- /usr/bin/which prll_bfr > /dev/null
++ @GENTOO_PORTAGE_EPREFIX@/usr/bin/which prll_bfr > /dev/null
+ if [[ $? -ne 0 ]] ; then
+ echo "PRLL: Missing prll_bfr." 1>&2
+ return 1
+ fi
+ fi
+ if [[ -z $PRLL_NR_CPUS ]] ; then
+- /usr/bin/which grep > /dev/null
++ @GENTOO_PORTAGE_EPREFIX@/usr/bin/which grep > /dev/null
+ if [[ $? -ne 0 || ! -a /proc/cpuinfo ]] ; then
+ echo "PRLL: Environment variable PRLL_NR_CPUS is not set" 1>&2
+ echo "PRLL: and either the grep utility is missing or" 1>&2
diff --git a/app-shells/prll/prll-0.5.ebuild b/app-shells/prll/prll-0.5.ebuild
new file mode 100644
index 000000000000..e4fb247d30df
--- /dev/null
+++ b/app-shells/prll/prll-0.5.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/prll/prll-0.5.ebuild,v 1.1 2010/05/18 07:02:14 jlec Exp $
+
+EAPI="2"
+
+inherit eutils prefix toolchain-funcs
+
+DESCRIPTION="A utility for parallelizing execution in bash or zsh"
+HOMEPAGE="http://prll.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~x86-linux ~amd64-linux"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-prefix.patch
+ tc-export CC
+ eprefixify ${PN}.sh
+}
+
+src_install() {
+ dobin ${PN}_{qer,bfr} || die
+ insinto /etc/profile.d/
+ doins ${PN}.sh || die
+ dodoc ChangeLog AUTHORS README NEWS || die
+}