summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2014-02-11 15:56:58 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2014-02-11 15:56:58 +0000
commite5d2df72d408df26695005ae18486d7d0057c8c6 (patch)
treeca4e713d5955718ed28ecabcf9365aea7d7d82f6 /app-text/aspell
parentia64 stable wrt bug #495552 (diff)
downloadgentoo-2-e5d2df72d408df26695005ae18486d7d0057c8c6.tar.gz
gentoo-2-e5d2df72d408df26695005ae18486d7d0057c8c6.tar.bz2
gentoo-2-e5d2df72d408df26695005ae18486d7d0057c8c6.zip
use has_version instead of built_with_use
(Portage version: 2.2.7/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'app-text/aspell')
-rw-r--r--app-text/aspell/ChangeLog5
-rw-r--r--app-text/aspell/aspell-0.60.6.1.ebuild18
2 files changed, 13 insertions, 10 deletions
diff --git a/app-text/aspell/ChangeLog b/app-text/aspell/ChangeLog
index fd0db229d6f2..6ce023e72636 100644
--- a/app-text/aspell/ChangeLog
+++ b/app-text/aspell/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-text/aspell
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/aspell/ChangeLog,v 1.145 2014/02/11 06:47:09 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/aspell/ChangeLog,v 1.146 2014/02/11 15:56:58 mr_bones_ Exp $
+
+ 11 Feb 2014; Michael Sterrett <mr_bones_@gentoo.org> aspell-0.60.6.1.ebuild:
+ use has_version instead of built_with_use
11 Feb 2014; Steve Arnold <nerdboy@gentoo.org> aspell-0.60.6.1.ebuild:
Added fixes for bug #467602 and ncurses link issue when USE=tinfo.
diff --git a/app-text/aspell/aspell-0.60.6.1.ebuild b/app-text/aspell/aspell-0.60.6.1.ebuild
index 22292d52df49..f0da566ebfc1 100644
--- a/app-text/aspell/aspell-0.60.6.1.ebuild
+++ b/app-text/aspell/aspell-0.60.6.1.ebuild
@@ -1,9 +1,8 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/aspell/aspell-0.60.6.1.ebuild,v 1.12 2014/02/11 06:47:09 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/aspell/aspell-0.60.6.1.ebuild,v 1.13 2014/02/11 15:56:58 mr_bones_ Exp $
EAPI=4
-
inherit libtool eutils flag-o-matic autotools
DESCRIPTION="A spell checker replacement for ispell"
@@ -47,12 +46,13 @@ src_prepare() {
# fix for bug #467602
if has_version ">=sys-devel/automake-1.13" ; then
sed -i -e 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/g' \
- "${S}"/configure.ac || die "sed failed"
+ "${S}"/configure.ac || die
fi
- epatch "${FILESDIR}/${PN}-0.60.5-nls.patch"
- epatch "${FILESDIR}/${PN}-0.60.5-solaris.patch"
- epatch "${FILESDIR}/${PN}-0.60.6-darwin-bundles.patch"
+ epatch \
+ "${FILESDIR}/${PN}-0.60.5-nls.patch" \
+ "${FILESDIR}/${PN}-0.60.5-solaris.patch" \
+ "${FILESDIR}/${PN}-0.60.6-darwin-bundles.patch"
rm m4/lt* m4/libtool.m4
eautoreconf
@@ -62,14 +62,14 @@ src_prepare() {
# https://lists.gnu.org/archive/html/libtool/2011-03/msg00003.html
# This has to be after automake has run so that we don't clobber
# the default target that automake creates for us.
- echo 'install-filterLTLIBRARIES: install-libLTLIBRARIES' >> Makefile.in
+ echo 'install-filterLTLIBRARIES: install-libLTLIBRARIES' >> Makefile.in || die
}
src_configure() {
# if ncurses is built with separate tinfo libs, then...
- if built_with_use sys-libs/ncurses tinfo ; then
- if built_with_use sys-libs/ncurses unicode ; then
+ if has_version "sys-libs/ncurses[tinfo]" ; then
+ if has_version "sys-libs/ncurses[unicode]" ; then
CURSES_LIB="-lncursesw -ltinfow"
else
CURSES_LIB="-lncurses -ltinfo"