summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-04-07 17:15:12 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-04-07 17:15:12 +0000
commiteb6d4e3a7e8c6c14e561aee4529791231654d36a (patch)
tree3917a090cc052d98cc557d47c542db445d4a461b /app-text/aspell
parentfixup build deps (diff)
downloadgentoo-2-eb6d4e3a7e8c6c14e561aee4529791231654d36a.tar.gz
gentoo-2-eb6d4e3a7e8c6c14e561aee4529791231654d36a.tar.bz2
gentoo-2-eb6d4e3a7e8c6c14e561aee4529791231654d36a.zip
Add ~x86-fbsd keyword after fixing linking with libintl. Add nls useflag to allow enabling/disabling nls support (with proper dependencies).
(Portage version: 2.1_pre7-r4)
Diffstat (limited to 'app-text/aspell')
-rw-r--r--app-text/aspell/ChangeLog7
-rw-r--r--app-text/aspell/aspell-0.60.4.ebuild22
-rw-r--r--app-text/aspell/files/aspell-0.60.4-nls.patch22
3 files changed, 43 insertions, 8 deletions
diff --git a/app-text/aspell/ChangeLog b/app-text/aspell/ChangeLog
index b1e7aa73004e..fe009ff8b726 100644
--- a/app-text/aspell/ChangeLog
+++ b/app-text/aspell/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/aspell
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/aspell/ChangeLog,v 1.78 2006/03/20 20:35:50 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/aspell/ChangeLog,v 1.79 2006/04/07 17:15:12 flameeyes Exp $
+
+ 07 Apr 2006; Diego Pettenò <flameeyes@gentoo.org>
+ +files/aspell-0.60.4-nls.patch, aspell-0.60.4.ebuild:
+ Add ~x86-fbsd keyword after fixing linking with libintl. Add nls useflag to
+ allow enabling/disabling nls support (with proper dependencies).
20 Mar 2006; Fabian Groffen <grobian@gentoo.org> aspell-0.60.4.ebuild:
Removed ~ppc-macos for 0.60.4, it has undefined symbols during the linking
diff --git a/app-text/aspell/aspell-0.60.4.ebuild b/app-text/aspell/aspell-0.60.4.ebuild
index 9e0a62106f23..7140937fc313 100644
--- a/app-text/aspell/aspell-0.60.4.ebuild
+++ b/app-text/aspell/aspell-0.60.4.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/aspell/aspell-0.60.4.ebuild,v 1.5 2006/03/20 20:35:51 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/aspell/aspell-0.60.4.ebuild,v 1.6 2006/04/07 17:15:12 flameeyes Exp $
-inherit libtool eutils flag-o-matic
+inherit libtool eutils flag-o-matic autotools
DESCRIPTION="A spell checker replacement for ispell"
HOMEPAGE="http://aspell.net/"
@@ -10,17 +10,25 @@ SRC_URI="mirror://gnu/aspell/${P}.tar.gz"
LICENSE="LGPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~s390 ~sh ~sparc ~x86"
-IUSE="gpm"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="gpm nls"
-DEPEND=">=sys-libs/ncurses-5.2
- gpm? ( sys-libs/gpm )"
+RDEPEND=">=sys-libs/ncurses-5.2
+ gpm? ( sys-libs/gpm )
+ nls? ( virtual/libintl )"
+
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
src_unpack() {
unpack ${A}
cd "${S}"
epatch "${FILESDIR}"/aspell-0.60.3-templateinstantiations.patch
epatch "${FILESDIR}"/aspell-0.60.4-gcc-4.1-fix.patch
+ epatch "${FILESDIR}/${P}-nls.patch"
+
+ eautomake
+ elibtoolize --reverse-deps
}
src_compile() {
@@ -28,9 +36,9 @@ src_compile() {
filter-flags -fno-rtti
filter-flags -fvisibility=hidden #77109
filter-flags -maltivec -mabi=altivec
- elibtoolize --reverse-deps
econf \
+ $(use_enable nls) \
--disable-static \
--sysconfdir=/etc/aspell \
--enable-docdir=/usr/share/doc/${PF} || die
diff --git a/app-text/aspell/files/aspell-0.60.4-nls.patch b/app-text/aspell/files/aspell-0.60.4-nls.patch
new file mode 100644
index 000000000000..4041d49a98a8
--- /dev/null
+++ b/app-text/aspell/files/aspell-0.60.4-nls.patch
@@ -0,0 +1,22 @@
+Index: aspell-0.60.4/Makefile.am
+===================================================================
+--- aspell-0.60.4.orig/Makefile.am
++++ aspell-0.60.4/Makefile.am
+@@ -91,7 +91,7 @@ libaspell_la_SOURCES =\
+ lib/string_pair_enumeration-c.cpp\
+ lib/new_checker.cpp
+
+-libaspell_la_LIBADD = $(LIBINTL) $(PTHREAD_LIB)
++libaspell_la_LIBADD = $(LTLIBINTL) $(PTHREAD_LIB)
+
+ if INCREMENTED_SONAME
+ libaspell_la_LDFLAGS = -version-info 16:4:0 -no-undefined
+@@ -129,7 +129,7 @@ word_list_compress_SOURCES = prog/compre
+
+ aspell_SOURCES = prog/aspell.cpp prog/check_funs.cpp prog/checker_string.cpp
+
+-aspell_LDADD = libaspell.la $(CURSES_LIB)
++aspell_LDADD = libaspell.la $(CURSES_LIB) $(LTLIBINTL)
+
+ prezip_bin_SOURCES = prog/prezip.c
+