summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-10-26 13:55:19 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-10-26 13:55:19 +0000
commitc37c666f5a9c7a626022375021cd44c93bb16b06 (patch)
tree56485ac2dc9780161b2b97f818de18fc1a47511b /app-text/bibclean/bibclean-2.11.4.ebuild
parentStable on ppc wrt bug 244417 (diff)
downloadgentoo-2-c37c666f5a9c7a626022375021cd44c93bb16b06.tar.gz
gentoo-2-c37c666f5a9c7a626022375021cd44c93bb16b06.tar.bz2
gentoo-2-c37c666f5a9c7a626022375021cd44c93bb16b06.zip
respect ldflags and CC/CXX variables
(Portage version: 2.2_rc12/cvs/Linux 2.6.27.3 x86_64)
Diffstat (limited to 'app-text/bibclean/bibclean-2.11.4.ebuild')
-rw-r--r--app-text/bibclean/bibclean-2.11.4.ebuild16
1 files changed, 12 insertions, 4 deletions
diff --git a/app-text/bibclean/bibclean-2.11.4.ebuild b/app-text/bibclean/bibclean-2.11.4.ebuild
index 3b836ae60a47..bfca7c6ce84d 100644
--- a/app-text/bibclean/bibclean-2.11.4.ebuild
+++ b/app-text/bibclean/bibclean-2.11.4.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/bibclean/bibclean-2.11.4.ebuild,v 1.2 2006/09/17 16:14:47 jhuebel Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/bibclean/bibclean-2.11.4.ebuild,v 1.3 2008/10/26 13:55:19 aballier Exp $
-inherit toolchain-funcs
+inherit toolchain-funcs eutils
DESCRIPTION="BibTeX bibliography prettyprinter and syntax checker"
SRC_URI="http://www.math.utah.edu/pub/bibclean/${P}.tar.bz2"
@@ -15,8 +15,16 @@ IUSE=""
SLOT="0"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-ldflags.patch"
+}
+
src_compile() {
- emake CC="$(tc-getCC)" CFLAGS="$CFLAGS" || die "emake failed"
+ tc-export CC CXX
+ econf
+ emake LDFLAGS="${LDFLAGS}" || die "emake failed"
}
src_test() {