summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuy Martin <gmsoft@gentoo.org>2004-08-30 10:14:36 +0000
committerGuy Martin <gmsoft@gentoo.org>2004-08-30 10:14:36 +0000
commit2ec1d4b0db740e0bf31b026f0f3c878c7088362d (patch)
tree9658fe5d7817b1d89f0d8e95ef86becfaa47c264 /app-text/chasen/chasen-2.3.3-r3.ebuild
parentVersion bump + #41758 fix. (Manifest recommit) (diff)
downloadgentoo-2-2ec1d4b0db740e0bf31b026f0f3c878c7088362d.tar.gz
gentoo-2-2ec1d4b0db740e0bf31b026f0f3c878c7088362d.tar.bz2
gentoo-2-2ec1d4b0db740e0bf31b026f0f3c878c7088362d.zip
Unconditonal use of -fPIC (#55238).
Diffstat (limited to 'app-text/chasen/chasen-2.3.3-r3.ebuild')
-rw-r--r--app-text/chasen/chasen-2.3.3-r3.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/app-text/chasen/chasen-2.3.3-r3.ebuild b/app-text/chasen/chasen-2.3.3-r3.ebuild
new file mode 100644
index 000000000000..cea792d48f12
--- /dev/null
+++ b/app-text/chasen/chasen-2.3.3-r3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/chasen/chasen-2.3.3-r3.ebuild,v 1.1 2004/08/30 10:14:36 gmsoft Exp $
+
+inherit perl-module flag-o-matic
+
+DESCRIPTION="Japanese Morphological Analysis System, ChaSen"
+HOMEPAGE="http://chasen.aist-nara.ac.jp/"
+SRC_URI="http://chasen.aist-nara.ac.jp/stable/chasen/${P}.tar.gz"
+
+LICENSE="chasen"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~sparc ~ppc"
+IUSE="perl"
+
+DEPEND="${DEPEND}
+ >=dev-libs/darts-0.2"
+PDEPEND=">=app-dicts/ipadic-2.6.1"
+
+src_unpack() {
+ unpack ${A}
+
+ if use perl ; then
+ cd ${S}/perl
+ sed -i -e '5a"LD" => "g++",' Makefile.PL || die
+ fi
+}
+
+src_compile() {
+ # Unconditional use of -fPIC (#55238)
+ append-flags -fPIC
+ econf || die
+ emake || die
+ if use perl ; then
+ cd ${S}/perl
+ perl-module_src_compile
+ fi
+}
+
+src_install () {
+ einstall || die
+
+ if use perl ; then
+ cd ${S}/perl
+ perl-module_src_install
+ fi
+
+ cd ${S}
+ dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README
+}