summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Gryniewicz <dang@gentoo.org>2007-03-26 19:57:06 +0000
committerDaniel Gryniewicz <dang@gentoo.org>2007-03-26 19:57:06 +0000
commit30a44c7570b2403a3b5311c1e09ef1574bd868dc (patch)
tree175f09eea4998920be7d3b44770669284631e9ef /app-text/evince
parentDropped ppc-macos keyword (diff)
downloadgentoo-2-30a44c7570b2403a3b5311c1e09ef1574bd868dc.tar.gz
gentoo-2-30a44c7570b2403a3b5311c1e09ef1574bd868dc.tar.bz2
gentoo-2-30a44c7570b2403a3b5311c1e09ef1574bd868dc.zip
Bump to 0.6.1-r3
Add patch for bug #156573 (Portage version: 2.1.2.2)
Diffstat (limited to 'app-text/evince')
-rw-r--r--app-text/evince/ChangeLog9
-rw-r--r--app-text/evince/evince-0.6.1-r3.ebuild83
-rw-r--r--app-text/evince/files/digest-evince-0.6.1-r33
-rw-r--r--app-text/evince/files/evince-0.6.1-gv-limit.patch23
4 files changed, 117 insertions, 1 deletions
diff --git a/app-text/evince/ChangeLog b/app-text/evince/ChangeLog
index a7de234a02c5..dfce65a29889 100644
--- a/app-text/evince/ChangeLog
+++ b/app-text/evince/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-text/evince
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/evince/ChangeLog,v 1.93 2007/03/24 18:04:36 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/evince/ChangeLog,v 1.94 2007/03/26 19:57:06 dang Exp $
+
+*evince-0.6.1-r3 (26 Mar 2007)
+
+ 26 Mar 2007; Daniel Gryniewicz <dang@gentoo.org>
+ +files/evince-0.6.1-gv-limit.patch, +evince-0.6.1-r3.ebuild:
+ Bump to 0.6.1-r3
+ Add patch for bug #156573
24 Mar 2007; Chris Gianelloni <wolf31o2@gentoo.org>
evince-0.6.1-r2.ebuild:
diff --git a/app-text/evince/evince-0.6.1-r3.ebuild b/app-text/evince/evince-0.6.1-r3.ebuild
new file mode 100644
index 000000000000..f7f09d8db3d6
--- /dev/null
+++ b/app-text/evince/evince-0.6.1-r3.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/evince/evince-0.6.1-r3.ebuild,v 1.1 2007/03/26 19:57:06 dang Exp $
+
+inherit eutils gnome2 autotools
+
+DESCRIPTION="Simple document viewer for GNOME"
+HOMEPAGE="http://www.gnome.org/projects/evince/"
+LICENSE="GPL-2"
+
+IUSE="dbus djvu doc dvi gnome t1lib tiff"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ dvi? (
+ virtual/tetex
+ t1lib? ( >=media-libs/t1lib-5.0.0 )
+ )
+ dbus? ( || ( >=dev-libs/dbus-glib-0.71
+ ( <sys-apps/dbus-0.90 >=sys-apps/dbus-0.33 ) ) )
+ tiff? ( >=media-libs/tiff-3.6 )
+ >=app-text/poppler-bindings-0.5.4
+ >=dev-libs/glib-2
+ >=gnome-base/gnome-vfs-2.0
+ >=gnome-base/libglade-2
+ >=gnome-base/gconf-2
+ gnome-base/libgnome
+ >=gnome-base/libgnomeprintui-2.6
+ >=gnome-base/libgnomeui-2.14
+ gnome? ( >=gnome-base/nautilus-2.10 )
+ >=x11-libs/gtk+-2.8.15
+ gnome-base/gnome-keyring
+ djvu? ( >=app-text/djvu-3.5.17 )
+ virtual/ghostscript"
+
+DEPEND="${RDEPEND}
+ app-text/scrollkeeper
+ >=app-text/gnome-doc-utils-0.3.2
+ >=dev-util/pkgconfig-0.9
+ >=sys-devel/automake-1.9
+ >=dev-util/intltool-0.35"
+
+
+DOCS="AUTHORS ChangeLog NEWS README TODO"
+USE_DESTDIR="1"
+ELTCONF="--portage"
+
+
+pkg_setup() {
+ G2CONF="--disable-scrollkeeper \
+ --enable-comics \
+ --enable-impress \
+ --with-print=gnome \
+ $(use_enable dbus) \
+ $(use_enable djvu) \
+ $(use_enable dvi) \
+ $(use_enable t1lib) \
+ $(use_enable tiff) \
+ $(use_enable gnome nautilus)"
+
+ if ! built_with_use app-text/poppler-bindings gtk; then
+ einfo "Please re-emerge app-text/poppler-bindings with the gtk USE flag set"
+ die "poppler-bindings needs gtk flag set"
+ fi
+}
+
+src_unpack(){
+ unpack "${A}"
+ cd "${S}"
+
+ # Fix .desktop file so menu item shows up
+ epatch ${FILESDIR}/${PN}-0.5.3-display-menu.patch
+
+ # Make dbus actually switchable
+ epatch ${FILESDIR}/${P}-dbus-switch.patch
+
+ # Limits on gv buffer lengths. Bug #156573
+ epatch "${FILESDIR}"/${P}-gv-limit.patch
+
+ eautoreconf
+}
diff --git a/app-text/evince/files/digest-evince-0.6.1-r3 b/app-text/evince/files/digest-evince-0.6.1-r3
new file mode 100644
index 000000000000..498e46d52a0f
--- /dev/null
+++ b/app-text/evince/files/digest-evince-0.6.1-r3
@@ -0,0 +1,3 @@
+MD5 55a1d4af3cac209c7cfbe83b7ffcee1d evince-0.6.1.tar.bz2 1212271
+RMD160 ac94e1964f4f46e505fe945daa9de288c2587898 evince-0.6.1.tar.bz2 1212271
+SHA256 ee72f48ec0c76a8f44d8a6aed6759d43a147a9d5bb2b15f06460c4d6ef86025e evince-0.6.1.tar.bz2 1212271
diff --git a/app-text/evince/files/evince-0.6.1-gv-limit.patch b/app-text/evince/files/evince-0.6.1-gv-limit.patch
new file mode 100644
index 000000000000..7ff5d155488d
--- /dev/null
+++ b/app-text/evince/files/evince-0.6.1-gv-limit.patch
@@ -0,0 +1,23 @@
+diff --exclude-from=/home/dang/bin/scripts/diffrc -up -ruN evince-0.6.1.orig/ps/ps.c evince-0.6.1/ps/ps.c
+--- evince-0.6.1.orig/ps/ps.c 2006-01-06 18:03:44.000000000 -0500
++++ evince-0.6.1/ps/ps.c 2007-03-26 15:14:13.000000000 -0400
+@@ -1231,7 +1231,8 @@ get_next_text(line, next_char)
+ int level = 0;
+ quoted = 1;
+ line++;
+- while(*line && !(*line == ')' && level == 0)) {
++ while(*line && !(*line == ')' && level == 0)
++ && (cp - text) < PSLINELENGTH - 1) {
+ if(*line == '\\') {
+ if(*(line + 1) == 'n') {
+ *cp++ = '\n';
+@@ -1302,7 +1303,8 @@ get_next_text(line, next_char)
+ }
+ }
+ else {
+- while(*line && !(*line == ' ' || *line == '\t' || *line == '\n'))
++ while(*line && !(*line == ' ' || *line == '\t' || *line == '\n')
++ && (cp - text) < PSLINELENGTH - 1)
+ *cp++ = *line++;
+ }
+ *cp = '\0';