summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Legler <a3li@gentoo.org>2009-08-16 18:21:41 +0000
committerAlex Legler <a3li@gentoo.org>2009-08-16 18:21:41 +0000
commit6dd529949be0c1075b988302a125d6d127280292 (patch)
treef9c6d6b85cf6a2352243cd7b80f8810e8e71f7cf /app-text/htmldoc/files
parentKeyword ~amd64. (diff)
downloadgentoo-2-6dd529949be0c1075b988302a125d6d127280292.tar.gz
gentoo-2-6dd529949be0c1075b988302a125d6d127280292.tar.bz2
gentoo-2-6dd529949be0c1075b988302a125d6d127280292.zip
Non-maintainer commit: Version bump for security bug 278186. Removing unneded vulnerable versions. Fixing repoman warnings.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'app-text/htmldoc/files')
-rw-r--r--app-text/htmldoc/files/fonts.diff14
-rw-r--r--app-text/htmldoc/files/htmldoc-sscanf-overflows.patch38
2 files changed, 38 insertions, 14 deletions
diff --git a/app-text/htmldoc/files/fonts.diff b/app-text/htmldoc/files/fonts.diff
deleted file mode 100644
index 5d7c83d2586b..000000000000
--- a/app-text/htmldoc/files/fonts.diff
+++ /dev/null
@@ -1,14 +0,0 @@
-diff -urN htmldoc-1.8.20/fonts/Makefile htmldoc-1.8.20-modified/fonts/Makefile
---- htmldoc-1.8.20/fonts/Makefile Thu Jun 6 07:10:24 2002
-+++ htmldoc-1.8.20-modified/fonts/Makefile Mon Aug 5 16:11:52 2002
-@@ -46,9 +46,7 @@
- Times-Bold \
- Times-BoldItalic \
- Times-Italic \
-- Times-Roman \
-- ZapfChancery \
-- ZapfDingbats
-+ Times-Roman
-
-
- #
diff --git a/app-text/htmldoc/files/htmldoc-sscanf-overflows.patch b/app-text/htmldoc/files/htmldoc-sscanf-overflows.patch
new file mode 100644
index 000000000000..3a8d4edd31a2
--- /dev/null
+++ b/app-text/htmldoc/files/htmldoc-sscanf-overflows.patch
@@ -0,0 +1,38 @@
+Fix several insecure calls to sscanf(), bug 278186. Patch by a3li@gentoo.org.
+
+diff -ru a/htmldoc/htmllib.cxx b/htmldoc/htmllib.cxx
+--- a/htmldoc/htmllib.cxx 2006-06-07 19:43:52.000000000 +0200
++++ b/htmldoc/htmllib.cxx 2009-08-01 19:52:46.301099436 +0200
+@@ -2139,7 +2139,7 @@
+ * assigned charset...
+ */
+
+- if (sscanf(line, "%*s%*s%*s%*s%f%*s%*s%s", &width, glyph) != 2)
++ if (sscanf(line, "%*s%*s%*s%*s%f%*s%*s%63s", &width, glyph) != 2)
+ continue;
+
+ for (ch = 0; ch < 256; ch ++)
+diff -ru a/htmldoc/ps-pdf.cxx b/htmldoc/ps-pdf.cxx
+--- a/htmldoc/ps-pdf.cxx 2006-08-01 18:58:50.000000000 +0200
++++ b/htmldoc/ps-pdf.cxx 2009-08-01 19:53:14.300610480 +0200
+@@ -12512,7 +12512,7 @@
+ * assigned charset...
+ */
+
+- if (sscanf(line, "%*s%*s%*s%*s%d%*s%*s%s", &width, glyph) != 2)
++ if (sscanf(line, "%*s%*s%*s%*s%d%*s%*s%63s", &width, glyph) != 2)
+ continue;
+
+ for (ch = 0; ch < 256; ch ++)
+diff -ru a/htmldoc/util.cxx b/htmldoc/util.cxx
+--- a/htmldoc/util.cxx 2005-04-24 21:20:32.000000000 +0200
++++ b/htmldoc/util.cxx 2009-08-01 19:52:14.469652088 +0200
+@@ -484,7 +484,7 @@
+ PageWidth = 595;
+ PageLength = 792;
+ }
+- else if (sscanf(size, "%fx%f%s", &width, &length, units) >= 2)
++ else if (sscanf(size, "%fx%f%254s", &width, &length, units) >= 2)
+ {
+ /*
+ * Custom size...