summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2010-03-25 22:34:33 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2010-03-25 22:34:33 +0000
commit3d7471ca8e8eddcb098a947bbe6a952298bdb14d (patch)
treed892dfcbf56007f58738ef9dd2190a4c73073143 /app-text/iso-codes
parentBump to 1.5.5. Adds CoverWallpaper, LiveRadio, Magnatune, and Telepathy plugi... (diff)
downloadgentoo-2-3d7471ca8e8eddcb098a947bbe6a952298bdb14d.tar.gz
gentoo-2-3d7471ca8e8eddcb098a947bbe6a952298bdb14d.tar.bz2
gentoo-2-3d7471ca8e8eddcb098a947bbe6a952298bdb14d.zip
Version bump, now strip unwanted translations. Clean up old revisions.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'app-text/iso-codes')
-rw-r--r--app-text/iso-codes/ChangeLog6
-rw-r--r--app-text/iso-codes/iso-codes-3.14.ebuild52
-rw-r--r--app-text/iso-codes/iso-codes-3.8.ebuild26
3 files changed, 57 insertions, 27 deletions
diff --git a/app-text/iso-codes/ChangeLog b/app-text/iso-codes/ChangeLog
index a846004829dc..68b2c857ca63 100644
--- a/app-text/iso-codes/ChangeLog
+++ b/app-text/iso-codes/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-text/iso-codes
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/iso-codes/ChangeLog,v 1.84 2010/01/15 04:10:04 abcd Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/iso-codes/ChangeLog,v 1.85 2010/03/25 22:34:33 eva Exp $
+
+ 25 Mar 2010; Gilles Dartiguelongue <eva@gentoo.org> -iso-codes-3.8.ebuild,
+ +iso-codes-3.14.ebuild:
+ Version bump, now strip unwanted translations. Clean up old revisions.
15 Jan 2010; Jonathan Callen <abcd@gentoo.org> iso-codes-3.11.1.ebuild:
Add prefix keywords
diff --git a/app-text/iso-codes/iso-codes-3.14.ebuild b/app-text/iso-codes/iso-codes-3.14.ebuild
new file mode 100644
index 000000000000..0850cebba1c9
--- /dev/null
+++ b/app-text/iso-codes/iso-codes-3.14.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/iso-codes/iso-codes-3.14.ebuild,v 1.1 2010/03/25 22:34:33 eva Exp $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="Provides the list of country and language names"
+HOMEPAGE="http://alioth.debian.org/projects/pkg-isocodes/"
+SRC_URI="ftp://pkg-isocodes.alioth.debian.org/pub/pkg-isocodes/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+RDEPEND=""
+DEPEND="sys-devel/gettext
+ || (
+ >=dev-lang/python-2.3[-build,xml]
+ dev-python/pyxml )"
+
+src_prepare() {
+ local linguas_bak=${LINGUAS}
+ local mylinguas=""
+
+ for norm in iso_15924 iso_3166 iso_3166_2 iso_4217 iso_639 iso_639_3; do
+ einfo "Preparing ${norm}"
+
+ mylinguas=""
+ LINGUAS=${linguas_bak}
+ strip-linguas -i "${S}/${norm}"
+
+ for loc in ${LINGUAS}; do
+ mylinguas="${mylinguas} ${loc}.po"
+ done
+
+ if [ -n "${mylinguas}" ]; then
+ sed -e "s:pofiles =.*:pofiles = ${mylinguas}:" \
+ -e "s:mofiles =.*:mofiles = ${mylinguas//.po/.mo}:" \
+ -i "${S}/${norm}/Makefile.am" "${S}/${norm}/Makefile.in" \
+ die "sed in ${norm} folder failed"
+ fi
+ done
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Installation failed"
+
+ dodoc ChangeLog README TODO || die "dodoc failed"
+}
diff --git a/app-text/iso-codes/iso-codes-3.8.ebuild b/app-text/iso-codes/iso-codes-3.8.ebuild
deleted file mode 100644
index 57934b567352..000000000000
--- a/app-text/iso-codes/iso-codes-3.8.ebuild
+++ /dev/null
@@ -1,26 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/iso-codes/iso-codes-3.8.ebuild,v 1.7 2009/07/04 18:33:08 ranger Exp $
-
-EAPI="2"
-
-DESCRIPTION="Provides the list of country and language names"
-HOMEPAGE="http://alioth.debian.org/projects/pkg-isocodes/"
-SRC_URI="ftp://pkg-isocodes.alioth.debian.org/pub/pkg-isocodes/${P}.tar.bz2"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sh sparc x86 ~x86-fbsd"
-IUSE=""
-
-RDEPEND=""
-DEPEND="sys-devel/gettext
- || (
- >=dev-lang/python-2.3[-build,xml]
- dev-python/pyxml )"
-
-src_install() {
- emake DESTDIR="${D}" install || die "Installation failed"
-
- dodoc ChangeLog README TODO
-}