summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2008-11-01 08:14:41 +0000
committerPeter Volkov <pva@gentoo.org>2008-11-01 08:14:41 +0000
commit257205148b8e7ff4dbbfd3b61da56c98274e60bc (patch)
tree4edcf28e040fc81e24a4e967779b65c3d64aa679 /app-text/ispell
parentVersion bump. (diff)
downloadgentoo-2-257205148b8e7ff4dbbfd3b61da56c98274e60bc.tar.gz
gentoo-2-257205148b8e7ff4dbbfd3b61da56c98274e60bc.tar.bz2
gentoo-2-257205148b8e7ff4dbbfd3b61da56c98274e60bc.zip
Resepect CC, CFLAGS and LDFLAGS, bug #209709 reported by Diego Pettenò.
(Portage version: 2.2_rc12/cvs/Linux 2.6.26-openvz.git-35f41f1 i686)
Diffstat (limited to 'app-text/ispell')
-rw-r--r--app-text/ispell/ChangeLog7
-rw-r--r--app-text/ispell/ispell-3.3.02-r1.ebuild55
2 files changed, 61 insertions, 1 deletions
diff --git a/app-text/ispell/ChangeLog b/app-text/ispell/ChangeLog
index 2dfd386a7a5d..b73310058513 100644
--- a/app-text/ispell/ChangeLog
+++ b/app-text/ispell/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/ispell
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/ispell/ChangeLog,v 1.35 2008/01/19 14:58:15 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/ispell/ChangeLog,v 1.36 2008/11/01 08:14:41 pva Exp $
+
+*ispell-3.3.02-r1 (01 Nov 2008)
+
+ 01 Nov 2008; Peter Volkov <pva@gentoo.org> +ispell-3.3.02-r1.ebuild:
+ Resepect CC, CFLAGS and LDFLAGS, bug #209709 reported by Diego Pettenò.
19 Jan 2008; Fabian Groffen <grobian@gentoo.org> ispell-3.2.06-r6.ebuild:
Dropped ppc-macos keyword, see you in prefix
diff --git a/app-text/ispell/ispell-3.3.02-r1.ebuild b/app-text/ispell/ispell-3.3.02-r1.ebuild
new file mode 100644
index 000000000000..80a62eca2e16
--- /dev/null
+++ b/app-text/ispell/ispell-3.3.02-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/ispell/ispell-3.3.02-r1.ebuild,v 1.1 2008/11/01 08:14:41 pva Exp $
+
+inherit eutils multilib toolchain-funcs
+
+PATCH_VER="0.3"
+DESCRIPTION="fast screen-oriented spelling checker"
+HOMEPAGE="http://fmg-www.cs.ucla.edu/geoff/ispell.html"
+SRC_URI="http://fmg-www.cs.ucla.edu/geoff/tars/${P}.tar.gz
+ mirror://gentoo/${P}-gentoo-${PATCH_VER}.diff.bz2"
+
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="sys-apps/miscfiles
+ >=sys-libs/ncurses-5.2"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${WORKDIR}/${P}-gentoo-${PATCH_VER}.diff"
+
+ sed -e "s:GENTOO_LIBDIR:$(get_libdir):" -i local.h || die
+ sed -e "s:\(^#define CC\).*:\1 \"$(tc-getCC)\":" -i local.h || die
+ sed -e "s:\(^#define CFLAGS\).*:\1 \"${CFLAGS}\":" -i config.X || die
+}
+
+src_compile() {
+ # Prepare config.sh for installation phase to avoid twice rebuild
+ emake -j1 config.sh || die "configuration failed"
+ sed \
+ -e "s:^\(BINDIR='\)\(.*\):\1${D}\2:" \
+ -e "s:^\(LIBDIR='\)\(.*\):\1${D}\2:" \
+ -e "s:^\(MAN1DIR='\)\(.*\):\1${D}\2:" \
+ -e "s:^\(MAN45DIR='\)\(.*\):\1${D}\2:" \
+ < config.sh > config.sh.install
+
+ emake -j1 || die "compilation failed"
+}
+
+src_install() {
+ mv config.sh.install config.sh
+ emake -j1 install || die "Installation Failed"
+ dodoc CHANGES Contributors README WISHES || die "installing docs failed"
+}
+
+pkg_postinst() {
+ echo
+ ewarn "If you just updated from an older version of ${PN} you *have* to re-emerge"
+ ewarn "all your dictionaries to avoid segmentation faults and other problems."
+ echo
+}