summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2014-09-07 12:20:32 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2014-09-07 12:20:32 +0000
commit584e89a81617e229a4af18df01ad6cece34c0a8b (patch)
tree464b3f9258302e39ad97a14ab7f642a7a4fb4858 /app-text/libwps
parentUpdate libwps dependencies. (diff)
downloadgentoo-2-584e89a81617e229a4af18df01ad6cece34c0a8b.tar.gz
gentoo-2-584e89a81617e229a4af18df01ad6cece34c0a8b.tar.bz2
gentoo-2-584e89a81617e229a4af18df01ad6cece34c0a8b.zip
Version bump to release used in lo4.3
(Portage version: 2.2.8-r1/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key 8EEE3BE8)
Diffstat (limited to 'app-text/libwps')
-rw-r--r--app-text/libwps/ChangeLog7
-rw-r--r--app-text/libwps/libwps-0.3.0.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/app-text/libwps/ChangeLog b/app-text/libwps/ChangeLog
index 1525f871df41..79cac7001ca7 100644
--- a/app-text/libwps/ChangeLog
+++ b/app-text/libwps/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/libwps
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/libwps/ChangeLog,v 1.52 2014/04/23 20:57:59 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/libwps/ChangeLog,v 1.53 2014/09/07 12:20:32 scarabeus Exp $
+
+*libwps-0.3.0 (07 Sep 2014)
+
+ 07 Sep 2014; Tomáš Chvátal <scarabeus@gentoo.org> +libwps-0.3.0.ebuild:
+ Version bump to release used in lo4.3
23 Apr 2014; Pacho Ramos <pacho@gentoo.org> -libwps-0.2.8.ebuild:
Drop old
diff --git a/app-text/libwps/libwps-0.3.0.ebuild b/app-text/libwps/libwps-0.3.0.ebuild
new file mode 100644
index 000000000000..c97d23cb424a
--- /dev/null
+++ b/app-text/libwps/libwps-0.3.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/libwps/libwps-0.3.0.ebuild,v 1.1 2014/09/07 12:20:32 scarabeus Exp $
+
+EAPI=5
+
+inherit base eutils
+
+DESCRIPTION="Microsoft Works file word processor format import filter library"
+HOMEPAGE="http://libwps.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
+
+LICENSE="|| ( LGPL-2.1 MPL-2.0 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~x86"
+IUSE="doc debug static-libs"
+
+RDEPEND="
+ app-text/libwpd:0.10
+ dev-libs/boost:=
+ dev-libs/librevenge
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+
+src_configure() {
+ econf \
+ --disable-werror \
+ $(use_enable static-libs static) \
+ --docdir=/usr/share/doc/${PF} \
+ $(use_with doc docs) \
+ $(use_enable debug)
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+}