summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2009-09-04 14:50:09 +0000
committerJeroen Roovers <jer@gentoo.org>2009-09-04 14:50:09 +0000
commitc3b116743b78ded670e0cd4bf533cb7000d57e10 (patch)
treebe6730c32f214b2c2f346ec027d4a8a797517a58 /app-text/lout/lout-3.38-r1.ebuild
parentstable sparc, bug 281475 (diff)
downloadgentoo-2-c3b116743b78ded670e0cd4bf533cb7000d57e10.tar.gz
gentoo-2-c3b116743b78ded670e0cd4bf533cb7000d57e10.tar.bz2
gentoo-2-c3b116743b78ded670e0cd4bf533cb7000d57e10.zip
Respect CFLAGS (bug #240136), LDFLAGS.
(Portage version: 2.2_rc40/cvs/Linux i686)
Diffstat (limited to 'app-text/lout/lout-3.38-r1.ebuild')
-rw-r--r--app-text/lout/lout-3.38-r1.ebuild86
1 files changed, 86 insertions, 0 deletions
diff --git a/app-text/lout/lout-3.38-r1.ebuild b/app-text/lout/lout-3.38-r1.ebuild
new file mode 100644
index 000000000000..3c80ff334ecb
--- /dev/null
+++ b/app-text/lout/lout-3.38-r1.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/lout/lout-3.38-r1.ebuild,v 1.1 2009/09/04 14:50:09 jer Exp $
+
+EAPI="2"
+
+inherit eutils toolchain-funcs
+
+IUSE="zlib doc"
+
+DESCRIPTION="high-level language for document formatting"
+HOMEPAGE="http://lout.sourceforge.net/"
+SRC_URI="mirror://sourceforge/lout/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+DEPEND="zlib? ( >=sys-libs/zlib-1.1.4 )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-makefile.patch"
+}
+
+src_compile() {
+ tc-export CC
+ local myconf
+ use zlib && myconf="$myconf PDF_COMPRESSION=1 ZLIB=-lz"
+ emake COPTS="${CFLAGS}" BINDIR=/usr/bin \
+ LOUTLIBDIR=/usr/share/lout \
+ LOUTDOCDIR=/usr/share/doc/${P} \
+ MANDIR=/usr/share/man/man1 \
+ ${myconf} lout prg2lout || die "emake prg2lout lout failed"
+}
+
+compile_doc() {
+ #
+ # SYNOPSIS: compile_doc file times
+ #
+
+ einfo "${1}:"
+ # yes, it *is* necessary to run this 6 times...
+ for i in $(seq 1 $(expr $2 - 1)) ; do
+ einfo " pass $i"
+ lout all -o ${docdir}/$1 -e /dev/null
+ done
+ # in the last one, let errors be reported
+ einfo " final pass"
+ lout all -o ${docdir}/$1 || die "final pass failed"
+}
+
+src_install() {
+ local bindir libdir docdir mandir
+ bindir=${D}/usr/bin
+ libdir=${D}/usr/share/lout
+ docdir=${D}/usr/share/doc/${P}
+ mandir=${D}/usr/share/man/man1
+ export LOUTLIB=${libdir}
+ export PATH="${bindir}:${PATH}"
+
+ mkdir -p ${bindir} ${docdir} ${mandir}
+
+ make BINDIR=${bindir} \
+ LOUTLIBDIR=${libdir} \
+ LOUTDOCDIR=${docdir} \
+ MANDIR=${mandir} \
+ install installdoc installman || die "make install failed"
+
+ lout -x -s "${D}"/usr/share/lout/include/init || die "lout init failed"
+
+ mv ${docdir}/README{,.docs}
+ dodoc README READMEPDF blurb blurb.short whatsnew
+
+ if use doc ; then
+ einfo "building postscript documentation (may take a while)"
+ cd doc/user
+ compile_doc user.ps 6
+ cd ../design
+ compile_doc design.ps 3
+ cd ../expert
+ compile_doc expert.ps 4
+ cd ../slides
+ compile_doc slides.ps 2
+ fi
+}