summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2011-08-13 12:44:44 +0000
committerAkinori Hattori <hattya@gentoo.org>2011-08-13 12:44:44 +0000
commit958e2c28d7b09a599be48a9a8f9e1df99585e9ef (patch)
tree2838e2a5979cfc02457727b70af5e887bf509ea1 /app-text/lv/lv-4.51-r3.ebuild
parentstable on x86. (diff)
downloadgentoo-2-958e2c28d7b09a599be48a9a8f9e1df99585e9ef.tar.gz
gentoo-2-958e2c28d7b09a599be48a9a8f9e1df99585e9ef.tar.bz2
gentoo-2-958e2c28d7b09a599be48a9a8f9e1df99585e9ef.zip
update to EAPI 4.
(Portage version: 2.1.10.3/cvs/Linux i686)
Diffstat (limited to 'app-text/lv/lv-4.51-r3.ebuild')
-rw-r--r--app-text/lv/lv-4.51-r3.ebuild31
1 files changed, 11 insertions, 20 deletions
diff --git a/app-text/lv/lv-4.51-r3.ebuild b/app-text/lv/lv-4.51-r3.ebuild
index 3b8375f73962..c74d97fd1ef8 100644
--- a/app-text/lv/lv-4.51-r3.ebuild
+++ b/app-text/lv/lv-4.51-r3.ebuild
@@ -1,13 +1,11 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/lv/lv-4.51-r3.ebuild,v 1.1 2011/01/13 14:47:24 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/lv/lv-4.51-r3.ebuild,v 1.2 2011/08/13 12:44:44 hattya Exp $
-EAPI="3"
+EAPI="4"
inherit eutils toolchain-funcs
-IUSE=""
-
MY_P="${PN}${PV//./}"
DESCRIPTION="Powerful Multilingual File Viewer"
@@ -15,38 +13,31 @@ HOMEPAGE="http://www.ff.iij4u.or.jp/~nrt/lv/"
SRC_URI="http://www.ff.iij4u.or.jp/~nrt/freeware/${MY_P}.tar.gz"
LICENSE="GPL-2"
-KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
SLOT="0"
-S="${WORKDIR}/${MY_P}"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
RDEPEND="sys-libs/ncurses
!app-editors/levee"
DEPEND="${RDEPEND}
dev-lang/perl"
+S="${WORKDIR}/${MY_P}"
src_prepare() {
-
epatch "${FILESDIR}"/${P}-gentoo.patch
epatch "${FILESDIR}"/${P}-xz.diff
-
}
src_configure() {
-
- ECONF_SOURCE=src econf || die
-
+ ECONF_SOURCE=src econf
}
-src_compile() {
-
- emake CC="$(tc-getCC)" || die
+src_compile() {
+ emake CC="$(tc-getCC)"
}
src_install() {
-
- emake DESTDIR="${D}" install || die
-
- dodoc README hello.sample || die
- dohtml index.html relnote.html hello.sample.gif || die
-
+ emake DESTDIR="${D}" install
+ dodoc README hello.sample
+ dohtml index.html relnote.html hello.sample.gif
}