summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2010-11-11 10:04:13 +0000
committerMichael Weber <xmw@gentoo.org>2010-11-11 10:04:13 +0000
commit3a4b899751605374751634784a66b038cb4f4988 (patch)
treee5e2c667474420e03048bbe63b4c357a57719cc4 /app-text/man2html
parentFix missing x11-misc/xdg-user-dirs runtime depend. (diff)
downloadgentoo-2-3a4b899751605374751634784a66b038cb4f4988.tar.gz
gentoo-2-3a4b899751605374751634784a66b038cb4f4988.tar.bz2
gentoo-2-3a4b899751605374751634784a66b038cb4f4988.zip
Revbump to fix bug 343943, Updated SRC_URI/HOMEPAGE.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'app-text/man2html')
-rw-r--r--app-text/man2html/ChangeLog11
-rw-r--r--app-text/man2html/files/man2html-1.6f-apostrophe.patch10
-rw-r--r--app-text/man2html/man2html-1.6f-r1.ebuild58
3 files changed, 77 insertions, 2 deletions
diff --git a/app-text/man2html/ChangeLog b/app-text/man2html/ChangeLog
index 246364fff57a..a5647e2a35b9 100644
--- a/app-text/man2html/ChangeLog
+++ b/app-text/man2html/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-text/man2html
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/man2html/ChangeLog,v 1.21 2008/05/23 23:29:29 darkside Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/man2html/ChangeLog,v 1.22 2010/11/11 10:04:13 xmw Exp $
+
+*man2html-1.6f-r1 (11 Nov 2010)
+
+ 11 Nov 2010; Michael Weber <xmw@gentoo.org> +man2html-1.6f-r1.ebuild,
+ +files/man2html-1.6f-apostrophe.patch:
+ Revbump to fix bug 343943, thanks to OKUMURA N. Shin-ya
+ <oku.ns@dream.com>. Updated SRC_URI/HOMEPAGE.
23 May 2008; Jeremy Olexa <darkside@gentoo.org> files/man2html.cron:
Modified files/man2html.cron, see bug 189582. Thanks to Harvey Chapman for
diff --git a/app-text/man2html/files/man2html-1.6f-apostrophe.patch b/app-text/man2html/files/man2html-1.6f-apostrophe.patch
new file mode 100644
index 000000000000..5ad467c8097b
--- /dev/null
+++ b/app-text/man2html/files/man2html-1.6f-apostrophe.patch
@@ -0,0 +1,10 @@
+--- man-1.6f/man2html/strdefs.c
++++ man-1.6f/man2html/strdefs.c
+@@ -90,6 +90,7 @@
+ { V('F','l'), 3, "ffl", NULL },
+ { V('a','a'), 1, "&#180;", NULL },
+ { V('a','p'), 1, "~", NULL },
++ { V('a','q'), 1, "&#39;", NULL }, /* apostrophe */
+ { V('b','r'), 1, "|", NULL },
+ { V('b','u'), 1, "*", NULL }, /* bullet */
+ { V('b','v'), 1, "|", NULL },
diff --git a/app-text/man2html/man2html-1.6f-r1.ebuild b/app-text/man2html/man2html-1.6f-r1.ebuild
new file mode 100644
index 000000000000..957cfa36cb71
--- /dev/null
+++ b/app-text/man2html/man2html-1.6f-r1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/man2html/man2html-1.6f-r1.ebuild,v 1.1 2010/11/11 10:04:13 xmw Exp $
+
+inherit eutils webapp
+
+DESCRIPTION="Convert manual pages to HTML"
+HOMEPAGE="http://primates.ximian.com/~flucifredi/man/
+ http://freshmeat.net/projects/man/"
+SRC_URI="http://primates.ximian.com/~flucifredi/man/man-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="app-misc/glimpse
+ sys-apps/gawk
+ virtual/man"
+
+S=${WORKDIR}/man-${PV}
+
+pkg_setup() {
+ webapp_pkg_setup
+ einfo "Installing into ${MY_HOSTROOTDIR}"
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/mansearch-gentoo.patch
+ epatch "${FILESDIR}"/mansec-${PV}.patch
+ epatch "${FILESDIR}"/${P}-apostrophe.patch
+ find man2html -type f | xargs sed -i \
+ -e "s:/home/httpd/htdocs/:/var/www/localhost/:g" \
+ -e "s:/home/httpd/cgi-bin/:/var/www/localhost/cgi-bin/man:g" \
+ -e "s:/home/httpd/cgi-aux/man:/var/www/localhost/cgi-aux/man:g"
+}
+
+src_compile() {
+ :
+}
+
+src_install() {
+ webapp_src_preinst
+
+ cd man2html
+ exeinto ${MY_HOSTROOTDIR}/cgi-bin/man
+ doexe scripts/cgi-bin/man/*
+ insinto ${MY_HOSTROOTDIR}/cgi-aux/man
+ doins scripts/cgi-aux/man/*
+ insinto /var/man2html
+ newins glimpse_filters .glimpse_filters
+ fperms 1777 /var/man2html
+ exeinto /etc/cron.daily
+ newexe "${FILESDIR}"/man2html.cron man2html
+
+ webapp_src_install
+}