summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2009-12-21 20:34:57 +0000
committerPeter Volkov <pva@gentoo.org>2009-12-21 20:34:57 +0000
commit7ddb890e970d9e07011cacdd4b16806c6edbd3f3 (patch)
tree167937705bdc91c69b8f6c9441f552f591544329 /app-text/mathtex/mathtex-1.03.ebuild
parentslotmove net-im/choqok from 0 to 4 (diff)
downloadgentoo-2-7ddb890e970d9e07011cacdd4b16806c6edbd3f3.tar.gz
gentoo-2-7ddb890e970d9e07011cacdd4b16806c6edbd3f3.tar.bz2
gentoo-2-7ddb890e970d9e07011cacdd4b16806c6edbd3f3.zip
Initial import. Ebuild by me and Constantin Bergemann, bug #219138. Required for pidgintex but is useful on its own ;)
(Portage version: 2.1.7.15/cvs/Linux x86_64)
Diffstat (limited to 'app-text/mathtex/mathtex-1.03.ebuild')
-rw-r--r--app-text/mathtex/mathtex-1.03.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/app-text/mathtex/mathtex-1.03.ebuild b/app-text/mathtex/mathtex-1.03.ebuild
new file mode 100644
index 000000000000..c1698b33069a
--- /dev/null
+++ b/app-text/mathtex/mathtex-1.03.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/mathtex/mathtex-1.03.ebuild,v 1.1 2009/12/21 20:34:57 pva Exp $
+
+EAPI="2"
+
+inherit toolchain-funcs
+
+DESCRIPTION="MathTeX lets you easily embed LaTeX math in your own html pages, blogs, wikis, etc"
+HOMEPAGE="http://www.forkosh.com/mathtex.html"
+SRC_URI="http://www.forkosh.com/${P}.zip"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="app-text/dvipng
+ virtual/latex-base"
+DEPEND=""
+
+einfo_run_command() {
+ einfo "${@}"
+ ${@} || die
+}
+
+src_compile() {
+ einfo_run_command $(tc-getCC) \
+ ${CFLAGS} ${LDFLAGS} \
+ -DLATEX=\"/usr/bin/latex\" \
+ -DDVIPNG=\"/usr/bin/dvipng\" \
+ mathtex.c -o mathtex
+}
+
+src_install() {
+ dobin mathtex || die
+ dodoc README || die
+ dohtml mathtex.html || die
+}
+
+pkg_postinst() {
+ elog "To use mathtex in your web-pages, just link /usr/bin/mathtex"
+ elog "to your cgi-bin subdirectory!"
+}