summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-02-14 07:11:51 +0000
committerJustin Lecher <jlec@gentoo.org>2014-02-14 07:11:51 +0000
commitaf9e7f2a4b68d6d4e2c70e33793c819a1e4c9601 (patch)
treee3d812f3a6fd0a337aa16e805b9607da43fa9dd2 /app-text/multitail
parentjust a bump (diff)
downloadgentoo-2-af9e7f2a4b68d6d4e2c70e33793c819a1e4c9601.tar.gz
gentoo-2-af9e7f2a4b68d6d4e2c70e33793c819a1e4c9601.tar.bz2
gentoo-2-af9e7f2a4b68d6d4e2c70e33793c819a1e4c9601.zip
app-text/multitail: Version Bump
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'app-text/multitail')
-rw-r--r--app-text/multitail/ChangeLog7
-rw-r--r--app-text/multitail/multitail-6.2.ebuild57
2 files changed, 63 insertions, 1 deletions
diff --git a/app-text/multitail/ChangeLog b/app-text/multitail/ChangeLog
index 4d8fd71ecf35..c339f07a6c61 100644
--- a/app-text/multitail/ChangeLog
+++ b/app-text/multitail/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/multitail
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/multitail/ChangeLog,v 1.109 2014/02/13 07:59:26 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/multitail/ChangeLog,v 1.110 2014/02/14 07:11:51 jlec Exp $
+
+*multitail-6.2 (14 Feb 2014)
+
+ 14 Feb 2014; Justin Lecher <jlec@gentoo.org> +multitail-6.2.ebuild:
+ Version Bump
*multitail-6.1 (13 Feb 2014)
diff --git a/app-text/multitail/multitail-6.2.ebuild b/app-text/multitail/multitail-6.2.ebuild
new file mode 100644
index 000000000000..f6b95fab9ec5
--- /dev/null
+++ b/app-text/multitail/multitail-6.2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/multitail/multitail-6.2.ebuild,v 1.1 2014/02/14 07:11:51 jlec Exp $
+
+EAPI=5
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="Tail with multiple windows"
+HOMEPAGE="http://www.vanheusden.com/multitail/"
+SRC_URI="http://www.vanheusden.com/multitail/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86 ~x86-interix ~amd64-linux ~x86-linux"
+IUSE="debug examples unicode"
+
+RDEPEND="sys-libs/ncurses[unicode?]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+RESTRICT="test" # bug #492270
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-6.0-as-needed.patch
+
+ use x86-interix && epatch "${FILESDIR}"/${PN}-5.2.6-interix.patch
+
+ sed \
+ -e '/gcc/d' \
+ -e '/scan-build/d' \
+ -e 's:make clean::g' \
+ -e "/^DESTDIR/s:=.*$:=${EROOT}:g" \
+ -i Makefile || die
+
+ tc-export CC PKG_CONFIG
+
+ use debug && append-flags "-D_DEBUG"
+}
+
+src_configure() {
+ emake UTF8_SUPPORT=$(usex unicode)
+}
+
+src_install () {
+ dobin multitail
+
+ insinto /etc
+ doins multitail.conf
+
+ dodoc Changes readme.txt thanks.txt
+ doman multitail.1
+
+ dohtml manual.html
+
+ docinto examples
+ use examples && dodoc colors-example.{pl,sh} convert-{geoip,simple}.pl
+}