summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Turk <satai@gentoo.org>2002-12-31 04:36:56 +0000
committerMatthew Turk <satai@gentoo.org>2002-12-31 04:36:56 +0000
commit4b33b37a0283b24353231b8e72ba071837eaacab (patch)
tree0dd47bfa1f476cc7bd34625df3be4c82905ad7fa /app-text/openjade/openjade-1.3.1-r2.ebuild
parentNew SGML catalog eclass, hopefully will fix things. (diff)
downloadgentoo-2-4b33b37a0283b24353231b8e72ba071837eaacab.tar.gz
gentoo-2-4b33b37a0283b24353231b8e72ba071837eaacab.tar.bz2
gentoo-2-4b33b37a0283b24353231b8e72ba071837eaacab.zip
Oy. Tons of changes... Fixed all of these ebuilds to inherit from
sgml-catalog.eclass, and then set them all up to have proper dependencies on the newest items, as well as use the new, more robust installation and removal system. This will probably have some growing pains over the next few days, but the long range will be worth it. All problem hints will be found at http://www.gentoo.org/~satai/
Diffstat (limited to 'app-text/openjade/openjade-1.3.1-r2.ebuild')
-rw-r--r--app-text/openjade/openjade-1.3.1-r2.ebuild114
1 files changed, 0 insertions, 114 deletions
diff --git a/app-text/openjade/openjade-1.3.1-r2.ebuild b/app-text/openjade/openjade-1.3.1-r2.ebuild
deleted file mode 100644
index 916f1fa01cdf..000000000000
--- a/app-text/openjade/openjade-1.3.1-r2.ebuild
+++ /dev/null
@@ -1,114 +0,0 @@
-# Copyright 1999-2002 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/openjade/openjade-1.3.1-r2.ebuild,v 1.8 2002/12/09 04:17:44 manson Exp $
-
-S=${WORKDIR}/${P}
-DESCRIPTION="Jade is an implemetation of DSSSL - an ISO standard for formatting SGML (and XML) documents"
-SRC_URI="mirror://sourceforge/openjade/${P}.tar.gz"
-HOMEPAGE="http://openjade.sourceforge.net"
-SLOT="0"
-LICENSE="as-is"
-
-DEPEND="virtual/glibc
- sys-devel/perl"
-
-RDEPEND="virtual/glibc
- app-text/sgml-common"
-KEYWORDS="x86 ppc sparc "
-
-src_compile() {
-
- #real weird setup here. we need to libtoolize to fix .la files.
- #
- #Azarah -- (7 April 2002)
- ln -s config/configure.in configure.in
- libtoolize --copy --force
-
- SGML_PREFIX=/usr/share/sgml
-
- ./configure --host=${CHOST} \
- --prefix=/usr \
- --enable-http \
- --enable-default-catalog=/etc/sgml/catalog \
- --enable-default-search-path=/usr/share/sgml \
- --datadir=/usr/share/sgml/${P} || die
-
- make || die
-}
-
-src_install() {
-
- dodir /usr
- dodir /usr/lib
- make prefix=${D}/usr \
- datadir=${D}/usr/share/sgml/${P} \
- install || die
-
- dosym openjade /usr/bin/jade
- dosym onsgmls /usr/bin/nsgmls
- dosym osgmlnorm /usr/bin/sgmlnorm
- dosym ospam /usr/bin/spam
- dosym ospent /usr/bin/spent
- dosym osx /usr/bin/sgml2xml
-
- insinto /usr/include/sp/generic
- doins generic/*.h
-
- insinto /usr/include/sp/include
- doins include/*.h
-
- insinto /usr/include/sp/lib
- doins lib/*.h
-
- insinto /usr/share/sgml/${P}/
- doins dsssl/builtins.dsl
-
- echo 'SYSTEM "builtins.dsl" "builtins.dsl"' > ${D}/usr/share/sgml/${P}/catalog
- insinto /usr/share/sgml/${P}/dsssl
- doins dsssl/{dsssl.dtd,style-sheet.dtd,fot.dtd}
- newins ${FILESDIR}/${P}.dsssl-catalog catalog
-# Breaks sgml2xml among other things
-# insinto /usr/share/sgml/${P}/unicode
-# doins unicode/{catalog,unicode.sd,unicode.syn,gensyntax.pl}
- insinto /usr/share/sgml/${P}/pubtext
- doins pubtext/*
-
- dodoc COPYING NEWS README VERSION
- docinto html/doc
- dodoc doc/*.htm
- docinto html/jadedoc
- dodoc jadedoc/*.htm
- docinto html/jadedoc/images
- dodoc jadedoc/images/*
-
-}
-
-pkg_postinst() {
- if [ -x "/usr/bin/install-catalog" ] && [ "$ROOT" = "/" ] ; then
- install-catalog --add /etc/sgml/${P}.cat /usr/share/sgml/openjade-${PV}/catalog
- install-catalog --add /etc/sgml/${P}.cat /usr/share/sgml/openjade-${PV}/dsssl/catalog
-# install-catalog --add /etc/sgml/${P}.cat /usr/share/sgml/openjade-${PV}/unicode/catalog
- install-catalog --add /etc/sgml/sgml-docbook.cat /etc/sgml/${P}.cat
- fi
-}
-
-pkg_postrm() {
- if [ -x "/usr/bin/install-catalog" ] && [ "$ROOT" = "/" ] ; then
- if [ ! -e /usr/share/sgml/openjade-${PV}/catalog ] && \
- [ -e /etc/sgml/${P}.cat ] ; then
- install-catalog --remove /etc/sgml/${P}.cat /usr/share/sgml/openjade-${PV}/catalog
- fi
- if [ ! -e /usr/share/sgml/openjade-${PV}/dsssl/catalog ] && \
- [ -e /etc/sgml/${P}.cat ] ; then
- install-catalog --remove /etc/sgml/${P}.cat /usr/share/sgml/openjade-${PV}/dsssl/catalog
- fi
- if [ ! -e /usr/share/sgml/openjade-${PV}/unicode/catalog ] && \
- [ -e /etc/sgml/${P}.cat ] ; then
- install-catalog --remove /etc/sgml/${P}.cat /usr/share/sgml/openjade-${PV}/unicode/catalog
- fi
- if [ ! -e /etc/sgml/${P}.cat ] ; then
- install-catalog --remove /etc/sgml/sgml-docbook.cat /etc/sgml/${P}.cat
- fi
- fi
-}
-