summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2014-03-22 14:47:51 +0000
committerChristoph Mende <angelos@gentoo.org>2014-03-22 14:47:51 +0000
commit53a3d5d397d6da40ac89c8a02ccedae1be87d03b (patch)
tree7c66508e8cf343219ebe1f78ade6ab7746c56237 /app-text/pastebinit
parentStable for HPPA (bug #505066). (diff)
downloadgentoo-2-53a3d5d397d6da40ac89c8a02ccedae1be87d03b.tar.gz
gentoo-2-53a3d5d397d6da40ac89c8a02ccedae1be87d03b.tar.bz2
gentoo-2-53a3d5d397d6da40ac89c8a02ccedae1be87d03b.zip
Version bump, remove old
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 84F20B43)
Diffstat (limited to 'app-text/pastebinit')
-rw-r--r--app-text/pastebinit/ChangeLog10
-rw-r--r--app-text/pastebinit/pastebinit-1.4.1.ebuild (renamed from app-text/pastebinit/pastebinit-1.3.1-r1.ebuild)27
2 files changed, 28 insertions, 9 deletions
diff --git a/app-text/pastebinit/ChangeLog b/app-text/pastebinit/ChangeLog
index bca062900ded..65218eb8043e 100644
--- a/app-text/pastebinit/ChangeLog
+++ b/app-text/pastebinit/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/pastebinit
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/pastebinit/ChangeLog,v 1.6 2013/12/24 12:56:08 ago Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/pastebinit/ChangeLog,v 1.7 2014/03/22 14:47:51 angelos Exp $
+
+*pastebinit-1.4.1 (22 Mar 2014)
+
+ 22 Mar 2014; Christoph Mende <angelos@gentoo.org> +pastebinit-1.4.1.ebuild,
+ -pastebinit-1.3.1-r1.ebuild:
+ Version bump, remove old
24 Dec 2013; Agostino Sarubbo <ago@gentoo.org> pastebinit-1.3.1-r2.ebuild:
Stable for x86, wrt bug #491952
diff --git a/app-text/pastebinit/pastebinit-1.3.1-r1.ebuild b/app-text/pastebinit/pastebinit-1.4.1.ebuild
index fc6829656d66..b8eadfd1e9d5 100644
--- a/app-text/pastebinit/pastebinit-1.3.1-r1.ebuild
+++ b/app-text/pastebinit/pastebinit-1.4.1.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/pastebinit/pastebinit-1.3.1-r1.ebuild,v 1.2 2013/05/23 11:35:48 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/pastebinit/pastebinit-1.4.1.ebuild,v 1.1 2014/03/22 14:47:51 angelos Exp $
EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7} )
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
PYTHON_REQ_USE="xml"
-inherit python-r1
+inherit python-single-r1
DESCRIPTION="A software that lets you send anything you want directly to a
pastebin from the command line."
@@ -15,7 +15,7 @@ SRC_URI="https://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="amd64 x86"
+KEYWORDS="~amd64 ~x86"
IUSE="crypt"
RDEPEND="${PYTHON_DEPS}
@@ -23,6 +23,19 @@ RDEPEND="${PYTHON_DEPS}
crypt? ( app-crypt/gnupg )"
DEPEND="app-text/docbook-xsl-stylesheets"
+src_prepare() {
+ local mo=""
+
+ for lang in ${LINGUAS}; do
+ if [ -f po/${lang}.po ]; then
+ mo="${mo} ${lang}.mo"
+ fi
+ done
+
+ sed -i -e "/^build-mo/s/:.*/:${mo}/" po/Makefile || die
+ sed -i -e "/#!/s/python3/python/" pastebinit || die
+}
+
src_compile() {
emake -C po
xsltproc --nonet \
@@ -32,13 +45,13 @@ src_compile() {
src_install() {
dobin pastebinit utils/pbput
- python_replicate_script "${ED}usr/bin/${PN}"
+ python_fix_shebang "${ED}usr/bin/${PN}"
dosym pbput /usr/bin/pbget
use crypt && dosym pbput /usr/bin/pbputs
dodoc README
doman pastebinit.1 utils/*.1
insinto /usr/share/locale
- doins -r po/mo/*
+ [[ -d po/mo ]] && doins -r po/mo/*
insinto /usr/share
doins -r pastebin.d
}