summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2003-09-18 17:53:06 +0000
committerMamoru Komachi <usata@gentoo.org>2003-09-18 17:53:06 +0000
commitb32eaed0728574d7b05288dd007e6deaa364854d (patch)
treeee17aad71c1a25120b6da45a5643918f296f1335 /app-text/pspresent/pspresent-1.1.ebuild
parentInitial import, closing Bug #29064 (diff)
downloadgentoo-2-b32eaed0728574d7b05288dd007e6deaa364854d.tar.gz
gentoo-2-b32eaed0728574d7b05288dd007e6deaa364854d.tar.bz2
gentoo-2-b32eaed0728574d7b05288dd007e6deaa364854d.zip
Initial import, closing Bug #29064
Diffstat (limited to 'app-text/pspresent/pspresent-1.1.ebuild')
-rw-r--r--app-text/pspresent/pspresent-1.1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-text/pspresent/pspresent-1.1.ebuild b/app-text/pspresent/pspresent-1.1.ebuild
new file mode 100644
index 000000000000..1a4abdb5eab1
--- /dev/null
+++ b/app-text/pspresent/pspresent-1.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/pspresent/pspresent-1.1.ebuild,v 1.1 2003/09/18 17:53:02 usata Exp $
+
+IUSE="xinerama"
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="A tool to display full-screen PostScript presentations."
+SRC_URI="http://www.cse.unsw.edu.au/~matthewc/pspresent/${P}.tar.gz"
+HOMEPAGE="http://www.cse.unsw.edu.au/~matthewc/pspresent/"
+
+DEPEND="virtual/glibc
+ virtual/x11
+ >=sys-apps/sed-4
+ app-text/ghostscript"
+RDEPEND="virtual/glibc
+ virtual/x11
+ app-text/ghostscript"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+src_compile()
+{
+ if [ ! "`use xinerama`" ] ; then
+ sed -i -e "/^XINERAMA/s/^/#/g" Makefile
+ fi
+ make pspresent || die "make failed"
+}
+
+src_install()
+{
+ dobin pspresent
+ doman pspresent.1
+ dodoc COPYING
+}